Internal speakers

I have installed Manjaro Kde on a Teclast f7plus3.
the only thing that does not work are the internal speakers, so either I connect via bluethoot with an external speaker or I use headphones.
From volume adjustment I have dummy output devices with the red line on the microphone symbol.

inxi -Fz                                                                                                ✔
System:    Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.4 Distro: Manjaro Linux
Machine:   Type: Laptop Mobo: N/A model: N/A serial: <filter> UEFI: American Megatrends v: Tpad3.04 date: 05/13/2021
Battery:   ID-1: BAT0 charge: 31.9 Wh (70.0%) condition: 45.6/45.6 Wh (100.0%)
CPU:       Info: Quad Core model: Intel Celeron N4120 bits: 64 type: MCP cache: L2: 4 MiB
           Speed: 1876 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 1876 2: 1156 3: 1945 4: 2098
Graphics:  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
           Device-2: Syntek HD WebCam type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 21.2.1
Audio:     Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio driver: snd_hda_intel
           Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes
           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter driver: rtw_8821ce
           IF: wlp1s0 state: up mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb
           Report: rfkill ID: hci0 state: up address: see --recommends
Drives:    Local Storage: total: 238.47 GiB used: 9.68 GiB (4.1%)
           ID-1: /dev/sda vendor: Teclast model: BD256GB SHCB-2280 size: 238.47 GiB
Partition: ID-1: / size: 134.13 GiB used: 9.62 GiB (7.2%) fs: ext4 dev: /dev/sda4
           ID-2: /boot/efi size: 96 MiB used: 68.9 MiB (71.8%) fs: vfat dev: /dev/sda1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 223 Uptime: 17m Memory: 7.59 GiB used: 1.77 GiB (23.3%) Shell: Zsh inxi: 3.3.06


This kernel is no longer supported, better switch to 5.10 or 5.13 or if you are brave choose brand new 5.14.

1 Like

It dosen t work

ALSA developers have been doing a lot of work to improve support for Intel ‘*lake’ systems, so Intel Geminilake system might benefit from using latest kernel v5.14

System data is showing 2 incompatible sound servers running

           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.33 running: yes

Pipewire cannot support audio unless PulseAudio is removed and replaced, but it might impede PulseAudio functions

Use this command to stop, disable and mask Pipewire services

systemctl --user disable --now pipewire.socket && systemctl --user disable --now pipewire.service && systemctl --user mask pipewire.socket
1 Like

the command need sudo or not ?

command will fail with sudo prefix

Ok. I ran the command without sudo. But it does not work

If command did not work please post error messages from terminal response

no, no. the command work. But after the reboot the speaker doesen’twork

New information suggests KDE might have another active service and socket pipewire-media-session

Please post response to this command to confirm pipewire is disabled/masked

systemctl --user list-unit-files | grep pipewire | awk '{print $1 " - " $2}'

and then post ALSA information

sudo --upload
sudo --upload                                                                                                                   ✔ 
[sudo] password di luca: 
/usr/bin/ line 661: tree: command not found
Uploading information to ... Done!

Your ALSA information is located at
Please inform the person helping you.

 systemctl --user list-unit-files | grep pipewire | awk '{print $1 " - " $2}'                                                                 ✔ 
pipewire-media-session.service - enabled
pipewire.service - disabled
pipewire.socket - masked

Grazie =Thankyou

1 Like

Thank you for confirming the Pipewire services, I was not aware of the additional service previously

I suggest you disable the active service

systemctl --user disable pipewire-media-session.service

ALSA data is not looking very good

The System name and model is not identified

The audio codec is only partially identified

00:0e.0 Multimedia audio controller [0401]: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio [8086:3198] (rev 06)
	DeviceName: Onboard - Sound

The 2nd line of this should have more information about the specific device and a subvendor ID code related to the manufacturer Teclast

The only audio connections detected are digital outputs for HDMI
Analog inputs and outputs are not detected

The only thing I can suggest for this is to install kernel v5.14 and see if a later kernel helps to improve detection of audio devices in ALSA

thanks but it doesn’t work. Not even with the 5.14 kernel.
At this point I decided to sell the pc and buy the previous version of the teclst that worked.

1 Like

Hello. Unfortunately version 1 of Teclast is no longer on the market. I have tried version 2 but it is worse than version 3, that is, in addition to not recognizing the speakchers, it also does not recognize the wifi card.
Therefore I should keep this version 3 and find the solution.
I would be grateful if you would like to continue following me on this path.
I apologize for my Italian-Macronic English.