Internal card reader and ethernet connections not working but will connect from a usb hub

Nope, probably not, all my blacklisted stuff is only relevant for my nvidia driver functioning.
Corrected the spelling, thanks.

I noticed that too, time for a clean out, here’s how: (MacBookPro from mid 2009 freezes before a system load - #16 by 6x12).

It is warm around the palm rests. Here’s the output of the sensors command:

Adapter: ISA adapter
Package id 0: +79.0°C (high = +86.0°C, crit = +100.0°C)
Core 0: +79.0°C (high = +86.0°C, crit = +100.0°C)
Core 1: +76.0°C (high = +86.0°C, crit = +100.0°C)

Adapter: ACPI interface
in0: 12.14 V
temp: +33.5°C
curr1: 0.00 A (avg = +0.00 A)

Adapter: ISA adapter
Exhaust : 1999 RPM (min = 2000 RPM, max = 6200 RPM)
TB0T: +33.2°C
TB1T: +29.2°C
TB2T: +33.0°C
TC0C: +76.8°C
TC0D: +77.2°C
TC0E: +78.8°C
TC0F: +79.0°C
TC0J: +0.0°C
TC0P: +71.5°C
TC1C: +75.0°C
TC2C: +76.0°C
TCGC: +76.0°C
TCSA: +76.0°C
TCTD: -0.2°C
TM0P: +46.2°C
TM0S: +57.0°C
TMBS: +0.0°C
TP0P: +61.0°C
TPCD: +69.0°C
TW0P: -127.0°C
Th1H: +53.8°C
Ts0P: +30.8°C
Ts0S: +46.0°C

Adapter: Virtual device
temp1: +33.5°C

running cat /etc/modprobe.d/*.conf gives me

:# Do not load the ‘bcma’ module on boot.
blacklist bcma

Which is what I wrote in the nobcma.conf file that I created according to the blacklist instructions linked to the first page you gave me.

I rolled back to 6.1.51, which is the LTS kernel installed on my system

Did this but still no ethernet connection except through the USB hub.

Thanks. I’ll check in there and clean out stuff.

Your laptop model is supposed to have Broadcom NetXtreme BCM57765 Ethernet controller. But it’s not detected by any system information tool.

Possible cause of that could be a blacklisting of tg3 kernel module. But there is no indication that it was blacklisted.

The last thing you could try:
sudo modprobe tg3
and if there will be no output from that command run
inxi -Nnx
with USB hub unplugged

sudo modprobe tg3`

gave no output

inxi -Nnx`

gave me this:

Device-1: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge v: N/A
bus-ID: 03:00.0
IF-ID-1: br-16beaf2622f3 state: down mac: 02:42:87:1a:71:da
IF-ID-2: br-2137f8aa0534 state: down mac: 02:42:33:ec:ad:b1
IF-ID-3: CloudflareWARP state: unknown speed: 10 Mbps duplex: full
mac: N/A
IF-ID-4: docker0 state: up speed: 10000 Mbps duplex: unknown
mac: 02:42:5c:91:f0:6a
IF-ID-5: vethe70f92c state: up speed: 10000 Mbps duplex: full
mac: 2e:9c:62:dd:24:0d
IF-ID-6: wlp3s0b1 state: up mac: 68:a8:6d:40:2b:86

Try to do the following:
pamac remove broadcom-wl-dkms
sudo rm /etc/modprobe.d/nobcma.conf
sudo mkinitcpio -P

After that
sudo modprobe tg3
inxi -N

If the last command output won’t show a new device, then I’m out of ideas

inxi -N

does give me this:

Device-1: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge

Does ethernet work now?

After removing broadcom-wl-dkms your wifi is gone right? Now follow my instructions above:

  • install b43-firmware from AUR
  • create a b43.conf file in etc/modprobe.d/ and paste:
    options b43 allhwsupport=1
  • open (or create?) etc/modules-load.d/modules.conf and add b43 so it looks like:
# List of modules to load at boot

sudo modprobe b43 allhwsupport=1
and you should have your wifi back.

Finally, try to get your card reader to work by reinstalling the udisks2 package and reboot again.

I did the b43-firmware install, created the files per your earlier instructions, and when I rebooted, I indeed didn’t have wifi. But I still had the network information in my settings and when I clicked on it, it activated and asked me to re-enter my network password, which I did, and it connected. But the ethernet didn’t work.

The difference between your previous instructions and this one was that I didn’t enter sudo modprobe b43 allhwsupport=1. So I did that this time and rebooted. But alas still no ethernet connection. The udisks2 package is already installed on my system.

sudo modprobe b43 allhwsupport=1 was to make wifi work even without a reboot. Ok, so your wifi works now using the b43 driver which is much simpler than using broadcom-wl-dkms (which conflicts with ethernet as I posted above).

Reinstall it.
pamac reinstall udisks2
and reboot.

Then disconnect your dock and

  • plug your ethernet cable directly into your macbook
  • put an sd card into your card reader
  • run another inxi -Fazy

so we can check the ethernet and card reader data again.

Here’s the output from

inxi -Fazy

Kernel: 6.1.51-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
root=UUID=30ce6b69-5909-40ef-b99a-64c373e39107 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: Apple product: MacBookPro8,1 v: 1.0
serial: Chassis: type: 10 v: Mac-94245B3640C91C81
Mobo: Apple model: Mac-94245B3640C91C81 v: MacBookPro8,1
serial: UEFI: Apple v: date: 06/13/2019
ID-1: BAT0 charge: 60.1 Wh (96.8%) condition: 62.1/65.4 Wh (95.0%)
volts: 12.1 min: 10.9 model: SMP bq20z451 type: Li-ion serial: N/A
status: full cycles: 204
Info: model: Intel Core i5-2435M bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1599 high: 2400 min/max: 800/3000 scaling:
driver: intel_cpufreq governor: performance cores: 1: 798 2: 2400 3: 2400
4: 798 bogomips: 19164
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: gather_data_sampling status: Not affected
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_rstack_overflow status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Apple driver: i915 v: kernel arch: Gen-6 code: Sandybridge
process: Intel 32nm built: 2011 ports: active: LVDS-1 empty: DP-1, DP-2,
DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0126 class-ID: 0300
Device-2: Apple FaceTime HD Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:3 chip-ID: 05ac:8509
class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: xfwm v: 4.18.0 driver: X: loaded: modesetting
alternate: fbdev,vesa dri: crocus gpu: i915 display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
s-diag: 398mm (15.69")
Monitor-1: LVDS-1 model: Apple 0x9cc5 built: 2009 res: 1280x800 hz: 60
dpi: 114 gamma: 1.2 size: 286x179mm (11.26x7.05") diag: 337mm (13.3")
ratio: 16:10 modes: 1280x800
API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
API: ALSA v: k6.1.51-1-MANJARO status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: JACK v: 1.9.22 status: off tools: N/A
Server-3: PipeWire v: 0.3.79 status: off with: pipewire-media-session
status: active tools: pw-cli
Server-4: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
type: plugin tools: pacat,pactl,pavucontrol
Device-1: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge v: N/A
modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 14e4:4331 class-ID: 0280
IF-ID-1: br-16beaf2622f3 state: down mac:
IF-ID-2: br-2137f8aa0534 state: down mac:
IF-ID-3: docker0 state: up speed: 10000 Mbps duplex: unknown mac:
IF-ID-4: veth31607c2 state: up speed: 10000 Mbps duplex: full mac:
IF-ID-5: wlp3s0b1 state: up mac:
Device-1: Apple Bluetooth Host Controller driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.1.3:8
chip-ID: 05ac:821a class-ID: fe01
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Local Storage: total: 465.76 GiB used: 206.21 GiB (44.3%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 2B6Q scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%)
used: 206.21 GiB (45.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) zswap: yes
compressor: zstd max-pool: 20%
ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) priority: -2
file: /swapfile
ID-2: swap-2 type: zram size: 19.42 GiB used: 0 KiB (0.0%) priority: 15
comp: lz4 avail: lzo,lzo-rle,lz4hc,842,zstd max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 76.0 C mobo: 0.0 C
Fan Speeds (rpm): N/A
Processes: 276 Uptime: 2m wakeups: 2 Memory: total: 16 GiB
available: 15.54 GiB used: 3.26 GiB (21.0%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: 2297 pm: pacman pkgs: 2248 libs: 433 tools: pamac,yay pm: flatpak
pkgs: 30 pm: snap pkgs: 19 Shell: Zsh v: 5.9 running-in: xfce4-terminal
inxi: 3.3.29

Is that with the dock unplugged and ethernet cable in the mbp?
Did you reinstall udisks2 and put an sd card in the slot?

And you are not using the b43 driver but still:

bcma-pci-bridge v: N/A
modules: bcma

which is causing the conflict that showed in your mhwd -l -d without the USB hub connected where the wifi is mixed up with the ethernet:

Ok, lets block this module from loading (we don’t need it since b43 should work for wifi):

  • create etc/modprobe.d/blacklist-bcma.conf and paste this line in it:
    install bcma /bin/true

reboot and check again.

Yes this was with the dock unplugged and udisks2 reinstalled . Followed your latest instructions to block bcma and list Wi-Fi altogether. Plus one of my USB ports became inactive. Deleted blacklist-bcma.conf and rebooted, and regained Wi-Fi and usb port function. Still no Ethernet or SD card either with or without the blacklist-bcma.conf file. Weird that it would affect a USB port?

Did you have a look at inxi or mhwd -l -d output to see what was used as the wifi driver when bcma was blocked? I had hoped it would be something like:

Device-1: Broadcom BCM4331 802.11a/b/g/n driver: b43-pci-bridge v: N/A
modules: b43

and that this would ‘free up’ the ethernet part of the broadcom chip. On my mbp using this b43 driver setup for the wifi allows the ethernet part of the adapter to use the ‘forcedeth’ driver supplied with my nvidia graphics driver and both wifi and ethernet work as they should.
That’s why I thought using/forcing the b43 for wifi was the way to go since I knew it doesn’t mess with the ethernet part.

You need to put a card in to see the drive in inxi output.

inxi Fazy


Device-1: Broadcom BCM4331 802.11a/b/n driver: N/A modules: bcma pice:
gen: 1 speed : 2.5 GT/s lanes: 1 bus-ID 03:00.0 chip-ID: 14e4:4331 class-ID: 0280

mhwd -l -d

doesn’t output any card information.

I’m only copying here the network card information because I don’t have a network connection with the blacklist file present so I’m writing this on another computer.

I can’t see the drive in output of

inxi -Fazy

when the SD card is inserted

Also, I deleted the blacklist-bcma.conf file again, rebooted, plugged in the ethernet via the USB hub, and now I get this for the network information:

  Device-1: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge v: N/A
    modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 14e4:4331 class-ID: 0280
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-
    chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-16beaf2622f3 state: down mac: <filter>
  IF-ID-2: br-2137f8aa0534 state: down mac: <filter>
  IF-ID-3: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
  IF-ID-4: veth0aea3ef state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-5: wlp3s0b1 state: up mac: <filter>

So it now sees the ethernet connection as a second device?