Interesting question about Audio (using PulseAudio)

So a year ago I noticed that my sound would only work properly on occasion in one of three ways after boot:

A. The volume would remain the same (low) no matter the level and plugging in headphones did nothing

B. The volume worked perfectly, and plugging in headphones worked as well

C. There would be no sound at all.

Recently I figured out that the sound will work perfectly, but only if I boot into Manjaro without my computer charger plugged in.

So I guess I have two questions:

  1. Why is that?
  2. Is there anything I can do about it? I can live with it now that I know how to get the audio to work, but if it worked upon boot regularly with a charger inserted, that would be pretty good as well.

This is my system information (My devices are an NVIDIA/Intel Hybrid):

KDE Plasma 5.25.5
KDE Frameworks 5.98.0
Qt Version 5.15.6
Kernel Version: 5.19.14-1-MANJARO (64-bit)
Graphics Platform: X11

Processors: 12 x Intel Core i7-9750H CPU @ 2.60GHz
Memory: 15.5GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2070/PCIe/SSE2
Manufacturer: ASUSTek COMPUTER INC.
Product Name: Zephyrus S GX701GWR_GX701GWR
System Version: 1.0

Have you tried to clean the local pulse configuration folder? Pulse session cookies can lead to some weird behaviour some times.
Simply rename or remove (~/.config/pulse/) and reboot to see if that solves the issue. Also check for any .pacnew files!

You can:

  • boot live iso/any other distro - see if problem persists
  • disable tlp.service (if enabled) - does it make a difference
  • actually I ran out of ideas for 3rd point :stuck_out_tongue:

Interesting, I haven’t tried that yet, I’ll give it a go and let you know!

@pux : I tried this and unfortunately I’m still having the same issue after reboot.

@zbe : I don’t seem to have tlp.service running. I tried another distro and the issue wasn’t going on. I’m also running Manjaro on another laptop and the volume works as it should on that one as well.