Intel Wi-Fi 6 AX201

I’ve got a laptop with an Intel Wi-Fi 6 AX201 wireless card. I use GNOME and am connected to my router (either Wi-Fi or ethernet) but I fail to connect to get an internet connection. GNOME tells me that I am connected but (for both cases) on top of the “connection symbol” a question mark appears. From wireless “DOT” wiki “DOT” kernel “DOT” org/en/users/drivers/iwlwifi#firmware) I downloaded the corresponding tgz-file which contains ucode-files like iwlwifi-Qu-b0-hr-48.ucode etc. All of those I already have (/had) in my “/lib/firmware” folder. So I am wondering what makes iwlwifi not select the correct ucode file(s) and how can I fix it to select the right firmware?

The command # dmesg | grep "iwlwifi" prints among others the lines (only messages):

Direct firmware load for iwlwifi-QuZ-a0-hr-b0-56.ucode failed with error -2
api flags index 2 larger than supported by driver
Found debug destination: EXTERNAL_DRAM
Found debug configuration: 0
loaded firmware version 55.d9698065.0 QuZ-a0-hr-b0-55.ucode op_mode iwlmvm
Direct firmware load for iwl-debug-yoyo.bin failed with error -2
Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x354
base HW address: 9c:29:76:0a:be:af

I am not sure if it has an impact but I feel like the problem could be connected to the docking station (Dell WD19TB) which I am not sure if it has a network card. I think (I’m not 100% sure - did not pay attention) that this problem appeared after I plugged in the docking station for the first time after installation and after the next reboot it could not connect anymore. The cable connection always went through the docking station as the laptop has no LAN port.

I’d be really happy if you could help me with this issue. Thanks in advance!

EDIT: What I also tried was setting up an arch usb, boot it, connect to wifi and chroot into my environment where I then had a connection.

EDIT 2: Ok sorry, I am too tired I guess. I forgot to mention that the command # modinfo iwlwifi does return quite a few firmware files but not the seemingly needed ones with …-48 as posted above.

I just managed to fix it. I was missing the r8152-dkms package resp. the realtek firmwire for the docking station’s network (usb, …) controller(s). So this is the solution:

pamac build  r8152-dkms


I’ve edited your post a bit and marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.