Intel Ethernet I219-LM not working


Tried to apply this fix, but it does not work for me.

I get the following error message:

Cannot get EEPROM data: Operation not permitted
No appropriate hardware found for this fixup

I have the following network card:

Network: Card-1: Intel Ethernet Connection I219-LM driver: e1000e
Card-2: Intel Wireless 8260 driver: iwlwifi

Any ideas?

Network (LAN) unstable: Intel 82573V Gigabit Ethernet - e1000e driver - undeterministic reconnection when streaming or downloading (TX Unit Hang)
[SOLVED] Dual Boot Manjaro/Windows 7 hardware problems

That’s a different chip so the same thing may not work.

Are you still having issues with kernels 4.9.72 and 4.14.9?


With 4.14.9 same issue. I have only tried 4.12.14 beside 4.14 and had the same issue. I have tested today, after applying the latest update from today. Will try 4.9 right now and report back.


have we still this patch in our current versions ?




Just tried with 4.9.72 and I have the same issue.


This may be a different issue so I’ve split this to its own thread.

What issue are you having, specifically?


After startup, everything works normally. I can open Firefox, open this page and read through to the Forum. All on a sudden I have no longer internet access. I have to disconnect to the wired connection and enable Wifi, which works without problems. Reconnecting to the wired ethernet is not possible. It just states “setting network address” but it’s not able to reconnect.
I have also seen that I have beside adapter enp0s3 again an eth0, which is the one connected after startup.

That’s how it looks after startup:

3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether 54:ee:75:96:74:10 brd ff:ff:ff:ff:ff:ff
5: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
link/ether 00:50:b6:ce:73:a4 brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic noprefixroute eth0
valid_lft 3583sec preferred_lft 3583sec
inet6 fe80::250:b6ff:fece:73a4/64 scope link
valid_lft forever preferred_lft forever


this is really not good

go page 11

not FIXED for series 100/200

found several days before

you should re install kernel 4.13.6 series it works ,
and need also report inxi -Nxx

Slow ethernet on Manjaro KDE (Fine on Antergos)

Ok, thank you for the information. So I have to wait until a fix is provided. Have installed kernel 4.13 now and will reboot later to see how it works.

Here is the output of inxi -Nxx:

Network: Card-1: Intel Ethernet Connection I219-LM driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6 chip-ID: 8086:156f
Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 04:00.0 chip-ID: 8086:24f3

EDIT: Same issue with kernel 4.13.16. :frowning_face:


You should try 4.15. It has tons of fixes for e1000e.
(aside of maybe the last patch pending to be upstreamed)

EDIT: it got in with 4.15-rc8


Kernel 4.15 does not boot if my laptop is attached to my OneLink+ docking station. Once it gets updated, I will try again

EDIT: Still same issue with kernel 4.14. 4.15 still does not boot, I get an error message that a start job is running for TLP. Have to investigate what this issue is.


It seems that the latest update has solved my issue. I have a network connection for now 19 hours, before it latest maybe 15min!