Intel AX201 suddenly stops working (part 2)

For context read the Opening another thread since it didn’t solve the issue.
Comparing the logs when the wifi works and it doesn’t, I see there is this difference
working wifi

[   10.058537] iwlwifi 0000:00:14.3: loaded firmware version 71.058653f6.0 QuZ-a0-hr-b0-71.ucode op_mode iwlmvm

not working wifi

[13813.417687] iwlwifi 0000:00:14.3: Loaded firmware version: 71.058653f6.0 QuZ-a0-hr-b0-71.ucode

so the op_mode iwlmvm (argument?) might be the difference between working and not working. I have no clue what it means and how to change it, but when I start fresh the laptop I read it in dmesg.

Does anyone know what it means and how can I set it back if the wifi stops working again?
I searched a lot but could not find anything I could comprehend. Thanks!

Hi @Edu7151 ,
I wonder whether you could read the following post and put here the outputs of the terminal commands in order to know something about your system.
Iwlwifi failing to load with Intel WiFi 6 AX201

There is a short answer but I do not know whether could fix your problem. First command to remove iwlwifi, the second to enable again and the latter to see what happened. You could find the source of this commands at the followng post:
[SOLVED]Intel WIFI 6 AX201 Driver Issues / Kernel & Hardware / Arch Linux Forums

modprobe -r iwlwifi
modprobe iwlwifi
 dmesg | grep iwl

Hope this help, regards

Thanks @j8a
I will try to grab those info next time it gets stuck.

I already checked the rfkill and it wasn’t the issue. The wireless device is not present in ip a.

I also tried to reload the iwlwifi module with different parameters disable (802n and more I found in arch forums) but nothing.

The only log I saved from the last time is the dmesg. Following the logs, it seems it tries to load the ucode version 72. It doesn’t work. It fall back to version 71, loaded with op_mode iwlmvm and it works. After a while (check the delta in the timestamp) there is the infamous Microcode SW error detected. Restarting 0x0. and it tries to reload the ucode version 71 without op_mode iwlmvm. It then fails. Further down, the log is filled with retries of Loaded firmware version: 71.058653f6.0 QuZ-a0-hr-b0-71.ucode again without the op_mode iwlmvm.
I think that could solve the issue.
Right now I am trying to use another suggestion, that is disabling the 40mhz band. I read in intel forum that ax201 might have issue with that

options cfg80211 cfg80211_disable_40mhz_24ghz=1
[    9.930697] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    9.993768] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-72.ucode failed with error -2
[   10.058209] iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
[   10.058231] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version:
[   10.058537] iwlwifi 0000:00:14.3: loaded firmware version 71.058653f6.0 QuZ-a0-hr-b0-71.ucode op_mode iwlmvm
[   10.428091] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x351
[   10.554836] iwlwifi 0000:00:14.3: Detected RF HR B3, rfid=0x10a100
[   10.621484] iwlwifi 0000:00:14.3: base HW address: d0:3c:1f:42:1f:26
[   11.224930] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0
[56160.063997] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[56160.064144] iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
[56160.064147] iwlwifi 0000:00:14.3: Transport status: 0x0000004A, valid: 6
[56160.064151] iwlwifi 0000:00:14.3: Loaded firmware version: 71.058653f6.0 QuZ-a0-hr-b0-71.ucode
[56160.064154] iwlwifi 0000:00:14.3: 0x00000FA2 | ADVANCED_SYSASSERT          
[56160.064158] iwlwifi 0000:00:14.3: 0x000022F0 | trm_hw_status0
[56160.064160] iwlwifi 0000:00:14.3: 0x00000000 | trm_hw_status1
[56160.064162] iwlwifi 0000:00:14.3: 0x004CBE06 | branchlink2
[56160.064164] iwlwifi 0000:00:14.3: 0x004B5520 | interruptlink1
[56160.064166] iwlwifi 0000:00:14.3: 0x004B5520 | interruptlink2
[56160.064168] iwlwifi 0000:00:14.3: 0x004C66CC | data1
[56160.064170] iwlwifi 0000:00:14.3: 0x00000000 | data2

ok it happened again
ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever


0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

and lspci

00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)
        Subsystem: Intel Corporation Device 4070
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at 605319c000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
        Capabilities: [100] Latency Tolerance Reporting
        Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

Hi @Edu7151 ,
The hardware address base is an IPV6 one. What if you try to disable IPV6 from the Network Manager?

You can use the GUI to do this.


Today I had several crashes, after more digging I’m trying to disable all power saving features with

options iwlwifi uapsd_disable=0
options iwlmvm power_scheme=1

and put “turn wifi on” on all (ac, battery, critical) “energy saving” KDE setting

I highly doubt ipv6 and network manager are at faults, since it works normally and then it just doesn’t start up. I will try this nonetheless if there is another crash.

I will try that and then just sell this laptop and buy another one

I don’t want to be too optimistic but the above might have solved the issue! Tagging it as solution and hopefully it will save someone else’s time!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.