Intel AX200 bluetooth not found

I have a E495 Lenovo that came with rtl8822be wifi/bt combo. The bt there stopped working randomly. I did upgrade manjaro firmware around the same time, but I am not sure that is the case. I tried a lot of things but nothing worked. inxi -n didn’t even show the card, but atleast lspci showed that i have the card and WiFi worked. Now i bought the AX200 and WiFi still works and inxi -n finally shows the card, but bluetooth is still dead. bluetoothctl can’t find any adapters. bluetooth.service is running happily and I am here just dead in the water. Any suggestions?

EDIT: I have a similar post here where i talk about RTL8822BE and what i tried to do.

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host and an rfkill list would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

Thanks for the response. At the moment I fixed my problems by reinstalling Manjaro and I am using 5.4 LTS kernel currently and that seems to be working correctly currently. If the Bluetooth disappears again I will be back for help :smiley:

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.