Intel Arc Horrible Freezing Issues

Howdy. So, in March I purchased a new PC consisting of:
AMD Ryzen 9 7950X
Gigabyte X670 Aorus Elite AX Motherboard (F11d BIOS - Latest)
Intel Arc A770 16GB
G.SKILL Ripjaws S5 Series 32GB DDR5 RAM

Kernel version: 6.4.16-1

My experience with Arc has been rocky, and I’m not sure whether it is the card, the drivers, the kernel or what. Basically I need some guidance. I know this isn’t really a Manjaro issue, but given the fact I have almost no clue where to get logs to help diagnosing this issue, I’d hoped to get some help here.
The primary issue I’m experiencing is horrible freezing when launching steam, or a game. Paradoxically, when (and if) that game launches, everything is perfectly fine. These freezes typically last between 7-10 seconds, unfreeze for about half a second, and repeat. I am able to move my mouse, but the GUI is hard locked up. Randomly, my mouse will sometimes jump back to a location on the screen it was previously at. During March when I initially set up the PC, I couldn’t get around the freezing and games not launching, so I switched back to my Radeon RX580 which worked perfectly, so it is not an aspect of the platform. During the June timeframe, I reinstalled the Arc card and test Kubuntu to see if it was distro related - same exact behavior. Arc card still installed, I was eventually able to get the system somewhat functional by installing the Mesa-git driver available on the AUR. This did not alleviate the freezing, but DID allow me to launch games mostly consistently, which was good enough for me to put up with the abhorrent freezing. However, recently I was force to uninstall Mesa-git due to some dependency conflicts with other packages and just go back to the normal Mesa package from the repos. This, or possibly the system update that caused me to have to uninstall Mesa-git, has now thrown my ability to launch steam games consistently completely out the window. Today I was even able to reinstall Mesa-git (I think it changed its dependency requirements), and I’m still in the same spot. Given that there’s something like 170+ packages in a system update, I have no idea how to tell which one has caused this issue. But, given the fact that the underlying freezing issue hasn’t ever been resolved through any amount of system updates, something deeper is causing issues here.
I’ve shied away from considering it a hardware issue, as like I said, once it gets into game, it is rock solid and has no issues to speak of.
dmesg revealed nothing useful. The only curious fact was that (until I unplugged it recently) the freezing would coincide with the kernel attempting to (and failing because there was no media) access the CDROM drive, generating some sector access errors.
And other than that, I just don’t know what to check to try tracking down this issue. I’ve used linux for a while, and know enough to be dangerous, but not enough to diagnose an issue like this.
Please let me know if there’s anything I’ve missed that would help with troubleshooting.
Thanks in advance for any help.

Its good you are trying to keep a recent kernel. If I were you I would chase the latest - 6.5, and on.

Theres also some arc-specific suggestions here:

Namely that you want to make sure to have intel-media-driver installed.

You may also consider switching over to Unstable branch to get more up-to-date packages.

If freezing occurs when launching Steam then just run steam from a terminal and see if there are any errors output there.

Then I’d look at system log messages from the time the freeze occurred - journalctl --since="YYYY-MM-DD HH:MM:SS".

Thanks, both of you, for the suggestions.
I still have yet to fully go through the arch link, but some of the things I did do from that page were:
Install both vulkan-radeon and intel-media-driver - same behavior. I’ll upgrade my kernel and try changing to the unstable branch, see if I get any help there.

MrLavender, the freezing mostly occurs when launching steam and launching a game. I did launch it from a terminal, there were no errors cropping up until I ctrl+c’d to try and end my suffering (well after the main window launched).
here’s a pastebin to the journalctl. (pastebin) the freezing would’ve been in the 21:03:00 - 21:04:00 timeframe, just up till the steam coredump where I killed it.

I don’t know if it’s the cause but putting “” into a search engine returns some results which indicate that error comes from chromium (or electron, which uses chromium). Steam uses electron.

I wonder if steam will accept the --disable-gpu-memory-buffer-video-frames option suggested as a fix there?

Other things to try off the top of my head

1 Like

That seems to have been caused by Discord. My fault for having that open while testing. See this new Pastebin - Steam is opened first until coredump, like last time (freezing still occurs), then open Discord, which does not cause freezing.

I switched over to the flatpak version. This yielded some useful information. Upon first launch, the flatpak version was fine. However, upon installing a proton enabled game, we’re right back to the horrible freezing. I assume this is down to proton initialization. this also lines up with it freezing horribly when a game launches.

I think based on that, I have enough info to say “Proton is probably causing this”. For now, I’ll open an issue with Steam, unless I hear otherwise.

Thank you!

Do you have the vulkan-intel and lib32-vulkan-intel packages installed? If not then install them.

I have heard that Vulkan performance with Intel Arc cards on Linux isn’t great (they’ve focused most of their efforts so far on improving the Windows drivers). Might be worth experimenting with some of the Proton runtime config options like PROTON_USE_WINED3D.

I did have those packages installed. Performance was never my concern, it was always just the fact that the entire system freezes when trying to launch steam, and launching a game. For the games I played (Deep Rock Galactic chief among which), the game always ran acceptably after it stopped freezing.

Based on my extensive googling (which did include attempting some proton runtime configs -dx12 and PROTON_USE_WINED3D=1 %command% chief among which), I couldn’t find anyone with a similar problem to me, post kernel 6.1.

Part of me thinks it might be a specific issue with my platform, somehow, or my GPU. However I have more evidence/experience to say it’s not the GPU than to say that it is…

One bit of additional testing I did, I installed Crusader Kings III (Linux Native); It only seems to freeze once (and for a bit less time, so maybe not the same behavior) before proceeding correctly rather than the tens of freezes, one after another, present under a proton game.

a question, what session manager are you using ? wayland or x11 ? have you tried to switch between them ?

The evidence is pointing that way but it’s going to be difficult to diagnose unless you can test the card in another PC… one thing though, do you have Resizable BAR turned on in BIOS? sudo dmesg | grep BAR= and BAR should be the same value as VRAM. If 256M then it’s off, turn it on.

I think CK3 supports both OpenGL and Vulkan, does the problem reappear if you switch to the Vulkan renderer?

ReBar is enabled - the Bar is 512m. Not sure if that’s correct. Can get a pic of the BIOS setting if need be.

CK3 Defaulted to the Vulkan Renderer. Switching to the OpenGL renderer did not change the behavior.

Forgot to say as well: I will test the GPU in another PC. It wont have ReBar but I guess it should be good enough to see if the behavior will carry over.

I’m don’t think 512M is correct… on my 8GB AMD card I get

[drm] Detected VRAM RAM=8176M, BAR=8192M.

Is CSM disabled? This isn’t for your exact motherboard but should be similar;

On some systems enabling PCI resizable BAR can result in a significant loss of performance

I figured it out. The iGPU on newest Gen AMD was causing almost everything.
I can’t upload a screenshot, but in the sudo dmesg | grep BAR command, I noticed something I didn’t notice the first time around: VRAM RAM=512M
I’m blaming Gigabyte for this. Apparently “Auto” on the integrated graphics setting means “I’m on even if you have a dGPU”. Setting it to disabled has fixed my ability to launch games, and (almost more importantly) has all but resolved my freezing issues. The freezing is down to like, 2-3 seconds, and only once or twice when a game launches. Tolerable.

I speculate that there is some kernel, driver, or some other logic in place that is assuming my Intel GPU is an iGPU and my AMD GPU is a dGPU, which would be a valid assumption given that only in this exact generation (discounting APUs which I think appear differently) is it even possible for it to be the other way around.

Anyways, thank you for all the help folks! It was specifically that ReBar command that got me thinking about it.

I hadnt realized this was a dual-dpu setup.
In that case you probably wanted to be leveraging PRIME

glxinfo | grep "OpenGL renderer"
DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
But in the case you dont care about power and/or just want to run all gfx on the dGPU then disabling the iGPU (when you have the option - its a rare BIOS that does) is a reasonable solution.

Huh, I completely forgot that Zen 4 had integrated graphics. Didn’t even cross my mind when I saw 7950X.

Quite possible it is something to do with that combo then. Probably uncommon enough that it’s not much tested, and no wonder you never found any similar reports. I know the same problem doesn’t exist with both AMD igpu + dgpu because until recently I was running a 5700G + 5500XT with no problems leaving the igpu enabled.

Anyway, glad you got there in the end :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.