[Intel 8265 / 8275] WiFi - Slow download speed

I didn't have this problem before. In windows I can download with 1.2 mps but in manjaro it is between 50KiB/s to 200KiB/s.
here is my system:

System:    Host: PIPBOY Kernel: 4.19.69-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.4 
           tk: Qt 5.13.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X510UQ v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X510UQ v: 1.0 serial: <filter> UEFI: American Megatrends v: X510UQ.309 date: 08/08/2018 
Battery:   ID-1: BAT0 charge: 17.7 Wh condition: 27.5/42.1 Wh (65%) volts: 11.5/11.5 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Discharging cycles: 583 
CPU:       Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23240 
           Speed: 799 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 794 2: 788 3: 798 4: 791 
Graphics:  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Device-2: NVIDIA GM108M [GeForce 940MX] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:134d 
           Display: x11 server: X.Org 1.20.5 driver: modesetting compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.1.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.19.69-1-MANJARO 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 chip ID: 8086:24fd 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 301.84 GiB (32.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: SDM1 scheme: GPT 
Partition: ID-1: / size: 608.30 GiB used: 301.81 GiB (49.6%) fs: ext4 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 205 Uptime: 1h 38m Memory: 11.61 GiB used: 3.73 GiB (32.1%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           clang: 8.0.1 Shell: zsh v: 5.7.1 running in: konsole inxi: 3.0.36 

Can anyone help me with this?

How you test this?
Same server? same time? ...


OT
Under Manjaro I can download with 6.3 MB.
With Win 7 only 1.2 MB and with Win 10 nothing = 0 MB.

I never had issues with Intel WiFI - but it could be a coexistence with bluetooth issue.

As wi-fi support is tied onto the kernel - you may have a better connection using the latest stable kernel.

sudo pacman -Syu linux53
1 Like

I just download some file from the same website in both operating system I also test on another windows system at the same time.

Are you sure it is stable? the kernel setting says it is experimental.

Yes the 5.4 kernel is developing - but I was suggesting 5.3 because your inxi indicated you were using 4.9.

Ah - now I understand - I didn't know that 5.3 had not made it to stable - as release - yet

https://manjaro32.org/repo-compare/core.html

Which is kind of odd -because I have been using 5.3 for quite some time - you could be using 5.2 which in any case is newer than 4.19 (and according to your screen shot you are using)

1 Like

Isn't there any solution except changing kernel?

Well it's very difficult to say where the difference comes from.
Did you check your logs (journalctl) for anything unusual?
For example journalctl -g iwlwifi

Maybe try disabling bluetooth and see whether it makes a difference.

journalctl -g iwlwifi
-- Logs begin at Wed 2019-07-17 18:13:04 +0430, end at Wed 2019-10-09 18:05:05 +0330. --
Jul 17 21:35:03 PIPBOY kernel: iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
-- Reboot --
Jul 18 02:00:15 PIPBOY kernel: iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
Jul 18 02:00:15 PIPBOY kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
Jul 18 02:00:15 PIPBOY kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
Jul 18 02:00:15 PIPBOY kernel: iwlwifi 0000:02:00.0: base HW address: f8:59:71:33:76:38
Jul 18 02:00:15 PIPBOY kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
Jul 18 02:00:21 PIPBOY NetworkManager[538]: <info>  [1563399021.0471] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.5/0000:0>
-- Reboot --
Jul 18 14:12:33 PIPBOY kernel: iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
Jul 18 14:12:33 PIPBOY kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
Jul 18 14:12:33 PIPBOY kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
Jul 18 14:12:33 PIPBOY kernel: iwlwifi 0000:02:00.0: base HW address: f8:59:71:33:76:38
Jul 18 14:12:33 PIPBOY kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
Jul 18 14:12:38 PIPBOY NetworkManager[522]: <info>  [1563442958.6592] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.5/0000:0>
Jul 18 14:53:34 PIPBOY kernel: iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
Jul 18 15:55:52 PIPBOY kernel: iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
-- Reboot --
Jul 19 18:36:14 PIPBOY kernel: iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
Jul 19 18:36:15 PIPBOY kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
Jul 19 18:36:15 PIPBOY kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
Jul 19 18:36:15 PIPBOY kernel: iwlwifi 0000:02:00.0: base HW address: f8:59:71:33:76:38
Jul 19 18:36:15 PIPBOY kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
Jul 19 18:36:20 PIPBOY NetworkManager[527]: <info>  [1563545180.3264] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.5/0000:0>
Jul 19 20:30:01 PIPBOY kernel: iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
-- Reboot --
Jul 20 04:37:10 PIPBOY kernel: iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
Jul 20 04:37:10 PIPBOY kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
Jul 20 04:37:11 PIPBOY kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
Jul 20 04:37:11 PIPBOY kernel: iwlwifi 0000:02:00.0: base HW address: f8:59:71:33:76:38
Jul 20 04:37:11 PIPBOY kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
Jul 20 04:37:16 PIPBOY NetworkManager[525]: <info>  [1563581236.0287] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.5/0000:0>
-- Reboot --
Jul 20 20:13:44 PIPBOY kernel: iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
Jul 20 20:13:45 PIPBOY kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
Jul 20 20:13:45 PIPBOY kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
Jul 20 20:13:45 PIPBOY kernel: iwlwifi 0000:02:00.0: base HW address: f8:59:71:33:76:38
Jul 20 20:13:45 PIPBOY kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
Jul 20 20:13:49 PIPBOY NetworkManager[520]: <info>  [1563637429.9679] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.5/0000:0>
-- Reboot --

But make sure your download test is credible.
Select an ISO or video download site and download an ISO or video of >500MB.
Count time manually.
(Make sure you evaluate net speed units properly)

3 Likes

Weird it is weird It is now downloading with 400KiB/s to 650KiB/s but it is still slower than windows

Maybe your internet connection isn't stable?

You could try to boot Manjaro on the other pc with Windows and see if the download speed is the same. I mean it could be hardware related instead of os-related.

3 Likes

You should do as @linux-aarhus suggests and test other kernels. It is the easiest troubleshooting step to perform and often the most beneficial. It is the first step you should take whenever you have wifi issues. Well that and rebooting your router are tied for first. If you have no speed improvements after taking those steps then reset your router to the factory default settings:

You can also test other driver options or different Intel firmware.

Try this command it will load some alternative driver options:

nmcli networking off; sleep 1; sudo systemctl stop NetworkManager; sleep 1; DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5); sudo ip link set $DEVICE down; sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod -v; sleep 1; sudo modprobe -vr mac80211; sleep 20; sudo modprobe -v iwlwifi swcrypto=1 11n_disable=8 bt_coex_active=0 power_save=0 d0i3_disable=1 uapsd_disable=1; sleep 2; sudo systemctl start NetworkManager; sleep 2; nmcli networking on; sleep 2; nmcli r wifi off; sleep 1; nmcli r wifi on

You should also disable IPv6 in your router settings and network manager. Search the forum for direction on how to do this.

Please confirm every step you have taken to correct your issue, and also post the input and output of any command you are asked to run.

1 Like

As I said

KBps, Kbps, Mbps, MBps are not the same.
There is no "kps" unit...

3 Likes

I think this is the real problem now I am testing the speed is 700KiB/s to 900KiB/s. but I will check new kernels tomorrow.

And how exactly did you fix this.

Forum kindly sponsored by Bytemark