Intel 620 integrated graphics tearing / flashing

I have a System76 Galago Pro with Intel 620 integrated graphics. When viewing the Hardware Configuration it shows Unknown Device Name (Intel Corporation) under Display Controller. The installed driver is video-linux, not video-intel. I regularly have tearing across my screen and when I mouse over icons the brightness of the display slightly changes, just enough to be annoying. What should I try next? From reading others issues the Kernel upgrade generally solves it, but it did not.

Kernel: 5.0.3-1
DE: Cinnamon

I do have the driver set via /etc/X11/xorg.conf.d/20-intel.conf:

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

Some debugging:

sudo mhwd -i pci video-intel 
Error: config 'video-intel' does not exist!

Relevant inxi -Fx section:

Graphics:
  Device-1: Intel UHD Graphics 620 vendor: CLEVO/KAPOK driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.4 driver: intel resolution: 3200x1800~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.3.4 direct render: Yes

check so

sudo mhwd -l --pci
and 
sudo mhwd -li --pci

linux intel contains drivers intel & drivers radeon & amdgpu ( free drivers )

sudo mhwd -l --pci

> 0000:00:02.0 (0300:8086:5917) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI
sudo mhwd -li --pci

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI

Here is some search info from the forum, a look through may give you a answer.
https://forum.manjaro.org/search?q=Intel%20620%20integrated%20graphics%20

Also if you look under tutorials, There is a plethora a great information to help you.

I’m using on my Thinkpad 13 (with Intel 620) configuration without Intel video driver for years.

My 20-*.conf looks like:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "3"
EndSection

and never noticed any important glitch.

video-linux contains the intel driver so video-intel is not necessary. the tearing can usually be fixed with “TearFree” option. here are examples you can try for both the intel driver and modesetting driver:

intel driver:

# xorg configuration for use with intel driver.
# xf86-video-intel or video-linux package required
#
# This driver now uses DRI3 as the default Direct Rendering
# Infrastructure. You can try falling back to DRI2 if you run
# into trouble. 
# content as /etc/X11/xorg.conf.d/20-intel.conf :
 
    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "DRI" "3"             # DRI2 and DRI1 are alternatives if DRI3 performs performs poorly
        Option      "TearFree" "true"
        #Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback
     EndSection

for modesetting driver:

#this is to use the modesetting driver
#for the intel iGPU instead of the intel driver

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0:2:0"
EndSection

try both and see which works better for your setup, only have one of those configurations at a time in /etc/X11/xorg.conf.d/

reboot after change and see how it behaves, if the flashing still occurs there are module options you can use to fix that. first try those configurations.
you can also uncomment the uxa line in the intel configuration to try a different accel method (remove the # at the beginning of the line.

#Option      "AccelMethod"  "uxa" # fallback

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.