Insync Thunar Integration: "The required package "thunarx-1 was not found on your system."

thunar
#1

On the Manjaro Linux XFCE 18 Minimal installation that I just finished on my new basic HP laptop, Insync (https://www.insynchq.com/) installs perfectly, but “insync-thunar” does not.

Here is the error message that I receive at the end of trying to let Pacman install “thunarx-python-0.3,” which is listed as a dependency for “insync-thunar”:

checking for thunarx-1 >= 0.4.0... not found
*** The required package thunarx-1 was not found on your system.
*** Please install thunarx-1 (atleast version 0.4.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
==> ERROR: A failure occurred in build().
    Aborting...

Could an old Manjaro guru please help me fix the problem?

By the way, beside this one issue, all of my setup has gone beautifully thus far. I have grown to love Manjaro over the past 7 months since I first started using it on my desktop (KDE – still my main driver).

0 Likes

#2

Are you looking for this:

aur/python-thunarx 1:0.5.1-1 (60, 0.000219)
    Thunarx Python Bindings

?

Remember to check the optdepends of a package for these sorts of “soft dependencies”, and if there’s an issue with the package please report it on the AUR package page.

0 Likes

#3

Thank you for the reply. I have tried installing that package. The problem is something to do with “thunarx-python-0.3,” which is what is specifically listed as the dependency for “insync-thanar.” Do you have any ideas about what I should do next?

0 Likes

#4

Search the AUR. It’s right there.

aur/thunarx-python-0.3 0.3.0-1 (3, 0.037272)
    Thunarx python bindings, legacy version for Thunar Gtk2
0 Likes

#5

As I noted in the original post, it is at the point of installing “thunarx-python-0.3” that I receive the error message. Is it a problem with “thunarx-python-0.3”? Perhaps that package does not work with the most recent version of XFCE? I am at a loss here. Thank you again.

0 Likes

#6

Whoops. Total mis-read of the posts… :sweat:

This might be an issue with the insync-thunar package.

thunarx-python-0.3 is maintained by our own @Lolix so I’ll ping him just in case there’s a known issue.

0 Likes

#7

Haven’t touched thunarx-python-0.3 since its creation, as the description says: legacy version for Thunar Gtk2

At first sight without touching it insync-thunar should use either python-thunarx or python2-thunarx , given that support Thunar>=1.7.0

Probably I’ll spin a VM to look at it this weekend since I don’t use Xfce at all

From the pinned comment of python-thunarx AURweb

Version 0.5.0 supports python2 and python3. Changed PKGBUILD to split package to python-thunarx and python2-thunarx. Currently they are not coinstallable. Both require thunar>=1.7.0. If you need python-thunarx for thunarx-2 (GTK2 thunar < 1.7.0), please install python-thunarx-0.3

2 Likes

#8

Thank you for the response. When I tried modifying the package build for “insync-thunar” to depend on “thunarx-python” instead of “thunarx-python-0.3,” Thunar crashed entirely. I had to uninstall “insync-thunar” and reboot the system.

0 Likes

#9

Did you have any luck, by chance? Thank you again, Lolix.

0 Likes

#10

I had not time yet

0 Likes

#11

I have no time, interest, etc… to dig into this. And I’ll disown thunarx-python-0.3 package

thunarx-python-0.3 is expecting thunarx-1 pkg-config file and headers while in thunar exist only thunarx-3

/usr/include/thunarx-3/thunarx/*.h
/usr/lib/pkgconfig/thunarx-3.pc

Searching for thunarx in the forum bring nothing useful

Please get in touch with InsyncHQ and packager of insync-thunar packager to know what is supported (thunar and python version) and what is needed to get it working

1 Like

closed #12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes