Instructions from ArchWiki lead to Blackscreen on boot (AMDGPU) - 2 year ongoing issue R9 290

Hello all …

New here and have only been a Linux user for just over 2 years … Was using Pop 20.04 with exactly the same issues b4 moving to Manjaro with advice from others … This didn’t fix my issue … but I do prefer the KDE environment so have stuck with it.

Im am also dyslexic so generally find the terminal a pita to use and remember the commands … But have found that I have no issue following the information in a guide … It just takes a little longer.

I was using the 5.9 kernel before I tried the advice in the link below and have not found myself using the 5.13 kernel, yet the issue still remains. I have also tried using the 5.10 kernel but with the same results.

TLDR … Whatever guide I have followed for the past 2 years either using PopOs or Manjaro … Always ends in a Blackscreen with no option to get the tty2.

I do hate just to drop another link in a post, but there is so much I have gone thru in the last 2 years that its probably just easier to read that post than to explain it here all again.

Please google " Instructions from ArchWiki lead to Blackscreen on boot (AMDGPU) " it should be the top link and take you to the LTT forums to a post that has the same profile details as this account (GCandy77)

I know its a long post, but to save yourself giving advice that I have already been given (or read in the hundreds of guides Ive seen) … I suggest you read it fully.

The issue could be something to do with my boot-options, but somehow I doubt it.

Instructions from ArchWiki lead to Blackscreen on boot (AMDGPU)

Any suggestions would be greatly appreciated :slight_smile:

Welcome to the forum! :wave:

Your card is neither supported by AMDGPU nor AMDGPU-PRO. The legacy Radeon driver will work out of the box.

Hi and thx for the reply :slight_smile:

Are you sure as the wiki for the Radeon_Rx_200_series#Vulkan_(API) says …

"API Vulkan 1.0 is supported for all GCN architecture cards. Vulkan 1.2 requires GCN 2nd gen or higher with the Adrenalin 20.1 and Linux Mesa 20.0 drivers and newer. " … It is based on the Hawaii Pro chip that the 390`s use which also have the same issue as mine regarding AMDGPU-pro

The chip of the R9 290 is in the Sea Island family which has no official support for amdgpu.
The official driver for Sea Island codename C.Island is radeon, not amdgpu, see here :

You can try your luck installing the experimental package amdgpu-experimental and following the instructions :

1 Like

Hi & thx for your answer … Very interesting reading!

I have already tried my luck with that guide on the Arch wiki … But that is the guide that always leads to the black screen.

I am aware that you (both) have way more experience on linux compared to me, but Im still hesitant to accept that AMDGPU will not run on the R9 290 because as mention I keep coming across a other pages that can get it running no problems … (this one is 3 years old)

If you visit “Kernel . org” & then “Bugzilla” (bottom in other resources) and look at - Bug 201539 (Comment 18+) … I cant post links yet :frowning:

As mentioned Ive spent a year n a half looking into this and the status-quo seems to be that this card requires the AMDGPU-PRO drivers to be able to run this.

Stupidly (I admit) … This forum is not the 1st place I seeked advice for this issue … I literally have bricked my Os about 20/25 times in the last few years ( been fun learning tho :innocent: ) going thru guide after guide and I get the same results when I turn on AMDGPU.

I read the 1st link you posted and agree … that on paper the card is not ment to support AMDGPU/Pro … But as you can see from that link … There a a few 290 owners that could & a lot of 390 owners that could too I assume because they share the same chipset.

Instead of just relying on the official route … What can I do myself to try and figure out what the card is not accepting the driver? … ie diagnostic terminal commands that I have not come across yet :slight_smile:

Shameless bump but with a real link now :partying_face: :innocent: