Installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’ required by ffmpeg2.8


#1

I just turned my computer on this morning and got a notification for 115 packages that needed to be updated.

Fair enough; I open up Pamac (I prefer using it over Octopi) and hit apply. I was greeted with an error message that said:

could not satisfy dependencies:
installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’ required by ffmpeg2.8

I just get that error message and can’t install any updates.

Any clue what to do? Why is this error happening?


Error during update
#2

Is from AUR, remove it, do the updates, reboot and reinstall it. Is not the best way, but when some AUR packages need rebuild but there is a conflict, is the only option.


#3

I don’t think so. I how can I check to be sure. I don’t recall installing it and feel that it must come default in the ISO.

But before I send you ona wild goose chase, how can I check if I installed it from the repositories or teh AUR?


#4

So…this is interesting. I thing it is installed from the AUR. In Pamac, each package shows which repository its installed from (community, extra, etc). Next to ffmpeg2.8, its blank.

Which, when I compare to a packaged I know I installed from the AUR (TOR), it shows the exact same thing. That the package is installed from the AUR.

Is there another way to verify where I installed the package from?

For the life of me, I don’t even remember installing it. No clue as to when, and more importantly why. (according to Pamac, I installed it on April 14…I have absolutely no memory of this)


#5

Well, we can argue about that all day long …
pacman -Qii ffmpeg2.8
will give you some info about it …but you can see some info also from the software manager you are using.


#6

I ran the command, but it doesn’t tell me which repository I installed it from (at least I can’t see it).

But it does give a reason for its installation: Installed as a dependency for another package

Is there anyway to figure out for which package that was? Becuase it would suck if there was something that I needed and would stop working because I removed this package.


#7

AFAIK, Rquired By is the field you’re looking for. Ran a quick test and I think this was installed from AUR:

~ >>> pacman -Qii libc++                                                                                                                                                
Name            : libc++
Version         : 6.0.0-1
Description     : LLVM C++ standard library.
Architecture    : x86_64
URL             : https://libcxx.llvm.org/
Licenses        : MIT  custom:University of Illinois/NCSA Open Source License
Groups          : None
Provides        : None
Depends On      : libc++abi=6.0.0-1
Optional Deps   : None
Required By     : discord  libc++experimental
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 4,90 MiB
Packager        : Unknown Packager
Build Date      : P 27 mai 2018 11:32:58 EEST
Install Date    : P 27 mai 2018 11:33:09 EEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : None
Backup Files    :
(none)

And it shows what has caused it to be installed.

Also, Manjaro has ffmpeg package in the official repos and ffmpeg2.8 comes from AUR for sure:

~ >>> yaourt ffmpeg2.8                                                                                                                                             [130]
1 aur/ffmpeg2.8 2.8.14-1 (3) (2,75)
    Complete solution to record, convert and stream audio and video

I hope this helps. :upside_down_face:

As for the solution to your initial issue, follow bogdancovaciu’s advice for removing and reinstalling the package - it’s the easiest way to go by.

And offtopic - I just love how Manjaro brings some of the frequently used applications from aur to official repos - saves some precious compilation minutes and removed some of the hassle from management. :slight_smile:


#8

It may have been installed initially, but support was dropped, so it’s no longer in the repos.


#9

From pamac, left panel installed -> Foreign
here are packages not from repo, including AUR packages.


#10

@rrrsssttt, sometimes Manjaro maintains commonly-used AUR packages in a Manjaro repo for a small number of purposes. (The AUR package ‘hplip-plugin’ comes to mind.)

Just FYI for future reference.

regards


#11

To follow up my comments in the testing thread.

This was a Manjaro overlay of an Arch package that was needed as a dependency for (at least) VLC 2.xx. Arch removed it upstream some months ago. It became redundant for Manjaro with VLC3 being pushed which does not require it. (All this AFAICT after researching a little.)

There is a newer, different package in the AUR which provides ffmpeg2.8 if some other (non-Manjaro repo) package requires it.

Manjaro could perhaps deal better with these sorts of situations, IMO.


#12

I had the same problem. What I find mostly odd, is pamac’s behaviour to not do any updates at all if there is a problem with a single one of the to-be-updated packages.

In any case, great to see that this problem was encountered before. I will report back if this fix works here as well :slight_smile: .


#13

Because this would lead to a partial-update scenario, which is bad news for Arch-based rolling-distro users and something to be avoided if at all possible.

regards


#14

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.