Installing wayfire-0.7.1 from AUR gives error during build

While installing wayfire from pamac, it gives the following error

wayfire-0.7.1/subprojects/wlroots/backend/session/ ERROR: Assert failed: -Dlogind-provider must be set to systemd or elogind since auto_features != auto

I have no idea how to solve it, and I tried to edit the above build file, but it was useless. I tried finding how to set Dlogind-provider to elogind or systemd, but did not find anything useful in net. Any idea how to proceed?
The AUR package is this one

I build this package for ARM and the main difference I see, is that the AUR package has:

 -Duse_system_wfconfig=enabled -Duse_system_wlroots=enabled

added to the build command.

Try removing those and see what happens.

Those options are already set to auto, so that shouldn’t make any difference.

Tried removing them and installing. Got the same error

You did build and install wf-config before wayfire right?

This PKGBUILD works for us in ARM.

I had both of them installed already. I was trying to update them. Previously, i don’t think i had any such errors building and installing it (3-4 months back)