Installing piklab from Arch Linux user repository

Having problem to install piklab. This is Arch-Linux depository so I hope this can be done.
I am fairly new to Linux so possibly I am doing something wrong.
Any assistance is greatly appreciated

Hi :slight_smile:

Piklab is in the AUR, does pamac install piklab work for you ? or if not, what is the output of that command?

On my gnome system the install command outputs some KDE dependency failures if I want to build it, your profile indicates KDE so you might not have this issue.

The AUR has piklab (AUR (en) - Search Criteria: piklab) but it has a missing dependency. You could try the second search result (AUR (en) - piklab-qt-svn) which doesn’t have this dependency.

If it doesn’t work, you should contact the maintainer.

Thanks. It has dependency error for me too. I tried the other pklab. This one is giving me conflict errors. It goes in never ending loop.

I run again AUR(en) - piklab-qt-svn and now it stops with the same error as piklab-0.16.2 :
could not satisfy dependencies:

  • unable to satisfy dependency ‘kdebase-katepart’ required by piklab

How can we resolve this?

piklab was not updated since 2018
piklab-qt-svn was not updated since 2016

You either edit yourself the PKGBUILD and remove the non existing dependencies (marked in red on those packages pages) and see if that works to build it, or contact the maintainers of those packages to update them.

1 Like