Installing Nvidia 450.xx drivers after 2020-08-22 stable update

In the systemsettings - driver install it does the same
manjaro-hardware

Good thing I’m not alone with this. For now I reverted back to the non-hybrid 450xx with PRIME setup since that works.

1 Like

are you on gnome?

Me? Using KDE Plasma.

konsole:
sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

Dependencies to install: video-modesetting
Proceed with installation? [Y/n] << doing nothing here, nothing happens
y << pressing y just leave whatever it was waiting for

log from the stable-update:
2020-08-22T12:06:38+0200] [ALPM] upgraded mhwd (0.6.4-2 -> 0.6.4-3)
[2020-08-22T12:06:38+0200] [ALPM] upgraded mhwd-db (0.6.4-11 -> 0.6.4-12)
[2020-08-22T12:06:38+0200] [ALPM] installed mhwd-nvidia-450xx (450.57-1)
it didn’t update to 450, but stayed on 440

nvidia sucks, it’s always the same story. i’m sick of it. please manjaro-team leave nvidia updates from the updates until it’s verified that they work. it’s a life-time-wasting trash to get it run. it’s terrible but amd is still not better. please manjaro-team take care for the gpu-drivers and if they are not checked to be worth for an update than let them out. it sucks to waste a weekend for such crap as an nvidia-driver.

3 Likes

I had all the same problems like everyone here using NVIDIA.

i managed to install the latest drivers like this:

sudo mhwd -i pci video-modesetting

Then I opened up Pamac and searched for nvidia-440 and manually uninstalled every package EXCEPT mhwd-nvidia-440xx.

Then I rebooted and I logged into tty and I was able to run sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

1 Like

Closed the KDE Session. Had to use the following instead as the previous command gave me a syntax error.

sudo mhwd -i pcie video-nvidia-450xx

Got exactly the same error as before.

error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux57-nvidia-440xx breaks dependency 'linux57-nvidia-440xx' required by linux-latest-nvidia-440xx
Error: pacman failed!
Error: script failed!

That’s crazy! Happy to be on intel integrated graphics.

1 Like

Say that again while running games on integrated graphics.

4 Likes

I get the error that removing the 440 driver breaks nvidia-utils which is required by cuda.

Installing video-nvidia-450xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-utils’ required by cuda
Error: pacman failed!
Error: script failed!

Then if you read the error message, you know that you need to first remove cuda if you want to proceed. cuda has ‘nvidia-utils’ as a dependency that will break if you remove nvidia-440xx-utils. This is where it fails.

2 Likes

You have meta package installed linux-latest****, probably for Kernel and video, so you need to not use them in order to use the ‘normal’ way. I think if you replace the meta package with the typical package it will work, uninstall it and replace it.

2 Likes

Update went ok, but had to manually configure for Nvidia 450 drivers, tty, install etc. Drivers are running, and nvidia-450xx-utils is installed, but still no hardware decoding of HEVC video. Do I need to reinstall these packages for it to work?

This solved things for me though I’m sure there is a way to do this without removing as many packages. I used this link to show me how to boot into TTY.

I used this for my GTX1080

sudo mhwd -i pci video-nvidia-450xx

1 Like

Thank you.

I did almost the same:

sudo mhwd -i pci video-modesetting
Successfully installed video-modesetting

If you have 440 installed and no need for rebooting:

sudo mhwd -r pci video-hybrid-intel-nvidia-440xx-prime
Successfully removed video-hybrid-intel-nvidia-440xx-prime

Then, without installing 440 or reboot:

sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime
Successfully installed video-hybrid-intel-nvidia-450xx-prime

Then reboot:

inxi -G
Graphics: Device-1: Intel HD Graphics 620 driver: i915 v: kernel
Device-2: NVIDIA GM107 [GeForce 940MX] driver: nvidia v: 450.57
Device-3: Chicony HD WebCam type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: nouveau resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.5

1 Like

You probably want to remove this package first.

3 Likes

Hi,
Got issue like many while updating nvidia 450. On my GTX 1060 system i have removed everything related to 440xx.
On reboot i got a black screen :flushed: So go to console using ALT + F2 (or CTRL + ALT + F2) then
sudo mhwd -i pci video-nvidia-450xx
systemctl reboot
It did the trick, thanks :facepunch:

Updating Nvidia driver has been a hassle for me too. It ended up in another TTS since installing 450 didn’t uninstall 440, config files were not created correctly… To summarize : A mess.
Conky-lua-nv now works… but uses 17% of a 3700x… Normal Conky doesn’t have the Lua graphics on my applet, but does use my CPU normally.

Unfortunately I need cuda for work. I think I remember it being mentioned that cuda support is somewhat broken for 450 series driver. Do you know if that is still the case?