Installing Nvidia 450.xx drivers after 2020-08-22 stable update

I used to have only one file in the X11/xorg.conf.d/ folder, 95-mhwd.conf. Now, there is a 90-mhwd.conf there as well, but the old one is still there. Is it safe to remove the 95 file? How can I tell which one the driver is actually using? Sorry if these are stupid questions, but am still trying to figure out why HEVC decoding is not working. I ran the nvidia-modprobe command, no change.

I was getting an error trying to update my nvidia drivers from 440 to 450.

Waiting for user input...
Starting
> Installing video-nvidia-450xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux54-nvidia-440xx breaks dependency 'linux54-nvidia-440xx' required by linux-lts-nvidia-440xx
Error: pacman failed!
Error: script failed!


Done ...

I currently have kernels 5.4 and 5.7 installed and i’m actively using 5.7. I tried to fix this issue by uninstalling 5.4 and got a message stating “Changes were made successfully”, but in the details I got

linux54

linux54-nvidia-440xx

linux54-virtualbox-host-modules

linux54-headers

Starting

checking dependencies...

:: removing linux54 breaks dependency 'linux54' required by linux-lts

:: removing linux54-headers breaks dependency 'linux54-headers' required by linux-lts-headers

:: removing linux54-nvidia-440xx breaks dependency 'linux54-nvidia-440xx' required by linux-lts-nvidia-440xx

:: removing linux54-virtualbox-host-modules breaks dependency 'linux54-virtualbox-host-modules' required by linux-lts-virtualbox-host-modules

Done ...

I manually removed those 4 linux-lts packages in pacman as I no longer use that kernel. After doing that, I was successfully able to uninstall 5.4 and return back to the hardware configuration and run the auto install proprietary to complete the upgrade. I initially intended this post to be a bug report but I solved it as I was writing lol. Bit of a specific situation, but if anyone has a similar issue it might be helpful to know.

Getting this error when trying to update to the the latest Nvidia proprietary drivers using “auto install proprietary” and mhwd install.

Starting
> Using config 'video-nvidia-450xx' for device: 0000:26:00.0 (0300:10de:1b80) Display controller nVidia Corporation GP104 [GeForce GTX 1080]
> Installing video-nvidia-450xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux57-nvidia-440xx breaks dependency 'linux57-nvidia-440xx' required by linux-latest-nvidia-440xx
Error: pacman failed!
Error: script failed!


Done ...

This didn’t work for me as it still uses mhwd and throws up the same error.

This doesn’t work for me either. I’ve tried auto install and manually install of the free drivers. I’ve tried force uninstall and force reinstall for the nvidia 440xx driver too. Still the same error each time. Tried those on Kernel 5.8 and 5.7 but get identical errors on both.

Everything else about the update works fine.

EDIT: R7 2700X GTX1080 Founders

This is probably the third or 4th thread on the same issue.
But your answer still lies above …

Its like this…

sudo pacman -R linux-latest-nvidia-440xx
## note - depending on your system you may have another 'latest' package to remove
sudo mhwd -i pci video-modesetting
sudo mhwd -f -i pci video-hybrid-intel-nvidia-450xx-prime
3 Likes

Had to clean a bit the stable announcement and was almost impossible to chose a perfect place to put it without getting intrusive. :rofl:

1 Like

I think it now uses /etc/X11/mhwd.d/nvidia.conf.
I noticed I made a mistake. I deleted the old 90-mhwd.conf which was softlinked to /etc/X11/mhwd.d/nvidia.conf which I also deleted. Then I put my old 90-mhwd.conf (never seen it being named 95-mhwd.conf) in /etc/X11/mhwd.d/ and renamed it to nvidia.conf. But when I softlinked this new nvidia.conf to /etc/X11/xorg.conf.d/ I forgot to rename it to 90-mhwd.conf (hence it’s /etc/X11/xorg.conf.d/nvidia.conf but after the update the softlink was named 90-mhwd.conf). So basically /etc/X11/xorg.conf.d/ doesn’t to matter but /etc/X11/mhwd.d/nvidia.conf.
Also, you don’t need to remove your 95-mhwd.conf. Just rename it to 95-mhwd.conf.bak.

If both files set drivers for the same device, only the last one will be applied (95-mhwd.conf). The files are read by alphabetical order.

This is that have worked for me:

  1. sudo mhwd -i pci video-modesetting

  2. sudo pacman -Rs linux-latest-nvidia-440xx

  3. sudo mhwd -r pci video-hybrid-intel-nvidia-440xx-prime

  4. sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

  5. reboot

4 Likes

This worked for me too!

Thanks!

This worked for me (no integrated graphics, nvidia 1060)

sudo pacman -R linux-latest-nvidia-440xx
sudo mhwd -r pci video-nvidia-440xx
sudo mhwd -i pci video-nvidia-450xx

then reboot

+1 The gui wouldn’t work but did exact same as this

Theres even a guide …

The problem I had wasn’t a message about failed dependencies or anything it was the same as a few other users. The manjaro settings manager gui just stopped and wouldn’t let you select anything so I had to uninstall and then install 450 via the cli. It wasn’t an issue doing it that way but there must be a issue with the gui for it to freeze for quite a few people

And what does note #2 say on that post ?

I’m not complaining or trying to pick a fight or anything. I was just reporting a bug with the gui nothing else,

Nor am I.
I agree this is an issue.
It has to do with the profiles not be updated properly by the maintainers.
And mixing that with these ‘supposed to help newbies, but are annoying’ *latest* umbrella packages.
I just meant that each of the scenarios is covered by that guide, including the steps you listed - though more concisely and correctly.
In any case glad you have things working for you.

1 Like

This worked. Thank you!

Linux noob here + Dell 7540 with dual GPU (intel + Quadro RTX3000).

I had the same problem and just successfully executed these commands (in alt+F2 terminal)

sudo mhwd -i pci video-modesetting
sudo pacman -Rs linux-latest-nvidia-440xx
sudo mhwd -r pci video-hybrid-intel-nvidia-440xx-prime
sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime
reboot

However I still get stuck at the black screen (Dell logo) after dual boot menu.

I found it helps to press the sequence: Atl+F2, Alt+F1 and enter, then the GUI login screen appears. But I have to do this every time after I reboot. Any idea how to fix that? Or should I update grub somehow after upgrading the drivers?

1 Like

I can confirm this behaviour with an Dell XPS 9560 with dual GPU (intel + GTX 1050).
I’m currently running the 5.4 LTS kernel, as everything works fine with it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.