Installing Manjaro Xfce on multi-boot UEFI laptop - problem on reboot

I have already installed Manjaro Xfce on my old Sony Vaio laptop (BIOS) and it is working very well, so pleased with the result.

I used ‘manjaro-xfce-16.10.3-stable-x86_64.iso’

I am now trying to install on my new DELL laptop (UEFI) but I am facing a problem.
laptop details are…
Processor: IntelCore i7-6500U CPU 1 Core, 2 Logical Processors
Integrated Graphics Processor: Intel HD Graphics 520
Discrete Graphics Processor: AMD Radeon R5 M335

I am still learning Linux but I have installed several Linux operating systems on this laptop (alongside Windows10) including Antergos and they are working as expected (they all boot in UEFI mode) but when I installed Manjaro, it seemed to install ok, but didn’t update the GRUB MENU at all… When I rebooted the grub menu was exactly the same as before, no sign of Manjaro in the list of operating systems.

So I would like to repeat the process and try again in case there was an unexpected glitch, and these are the steps I will follow …

Check that I am in correct UEFI mode by entering $ ls /sys/firmware and check efi is in the output.

Select Manual partitioning. (efi and swap partitions already exist and new 30GB ‘/’ partition already created for Manjaro)

Select each partition as detailed below…

				Mount
Partition	File System	Point		Format?		Flags
/dev/sda1	fat32		/boot/efi	NO		boot esp (already enabled)
/dev/sda9	linux-swap			NO
/dev/sda11	ext4		/		YES

Click next and move to the manjaro installer summary screen, this is the summary that I am presented with …

Format 30724MB partition /dev/sda11 with file system ext4.
Set up fat32 partition /dev/sda1 with mount point /boot/efi.
Install Manjaro on ext4 system partition /dev/sda11.
Install boot loader on /dev/sda.

Is the last line correct? I am not an expert but I thought the last line should say “Install boot loader on /dev/sdb1” and NOT “/dev/sdb”

I’m thinking maybe this is what happened the first time and I didn’t notice it.

Does the summary look OK to proceed with fresh installation? I don’t want to continue in case it doesn’t work again. Any advice would be appreciated. As I mentioned before, I am still learning linux but can use terminal if I know the correct syntax. Thanks for any help.

EDIT: Here is output from my inxi -Fxzc0

[manjaro@manjaro ~]$ inxi -Fxzc0 System: Host: manjaro Kernel: 4.4.33-1-MANJARO x86_64 (64 bit gcc: 6.2.1) Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Manjaro Linux Machine: Device: laptop System: Dell product: Inspiron 5559 Mobo: Dell model: 0K64R6 v: A00 UEFI: Dell v: 1.2.5 date: 10/06/2016 CPU: Dual core Intel Core i7-6500U (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10371 clock speeds: max: 3100 MHz 1: 782 MHz 2: 767 MHz 3: 707 MHz 4: 1215 MHz Graphics: Card-1: Intel HD Graphics 520 bus-ID: 00:02.0 Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430] bus-ID: 01:00.0 Display Server: X.Org 1.18.4 driver: intel Resolution: 1920x1080@60.02hz GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) GLX Version: 3.0 Mesa 13.0.1 Direct Rendering: Yes Audio: Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 Sound: Advanced Linux Sound Architecture v: k4.4.33-1-MANJARO Network: Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 02:00.0 IF: wlp2s0 state: down mac: <filter> Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0 IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> Drives: HDD Total Size: 1008.0GB (0.8% used) ID-1: USB /dev/sda model: DataTraveler_2.0 size: 7.8GB ID-2: /dev/sdb model: TOSHIBA_MQ01ABD1 size: 1000.2GB Partition: ID-1: / size: 5.8G used: 9.4M (1%) fs: overlay dev: N/A ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sdb9 Sensors: System Temperatures: cpu: 39.0C mobo: 25.0C gpu: N/A Fan Speeds (in rpm): cpu: N/A Info: Processes: 167 Uptime: 19 min Memory: 517.7/7880.7MB Init: systemd Gcc sys: 6.2.1 Client: Shell (bash 4.4.51) inxi: 2.3.4 [manjaro@manjaro ~]$

You need to enter your BIOS settings and set Manjaro’s GRUB as the default bootloader. You cannot boot Manjaro from another distro’s GRUB, as it will cause a kernel panic. But Manjaro’s GRUB is fully capable of booting other distros.

Thanks @ben81 for quick reply. I had heard that Manjaro was capable of booting other distros but not the other way around.

But I thought that even if other distros were already installed, when I installed Manjaro, then it would be in charge of GRUB MENU since it was the last distro to be installed.

That is what happened when I installed previous distros, the last one installed became in charge of GRUB MENU. Is Manjaro different from other distros in this respect?
EDIT2: when I installed Manjaro on my old Sony BIOS laptop it then took charge of the GRUB MENU.

You mentioned …
You need to enter your BIOS settings and set Manjaro’s GRUB as the default bootloader.
I’m not sure how I would do that in a UEFI setup, I did it previously on my old Sony BIOS laptop by booting from a live USB, these are the steps I used…

[code]
Boot computer with live USB * When up and running, open a terminal

$ sudo mount /dev/sda6 /mnt # Mount the Manjaro root partition on the HDD to the live environment

$ sudo grub-install --boot-directory=/mnt/boot /dev/sda # Install grub to the MBR of sda drive

$ sudo umount /dev/sda6 # Unmount the LL2 root partition

  • Close terminal, shutdown live DVD and remove from tray.

  • Boot computer normally again and you check if you have Manjaro in charge of grub menu [/code]
    The above commands worked for the old sony BIOS laptop but I believe it would be different for a UEFI setup, but I don’t have the expertise to make the necessary changes.

Do you know if this is the correct way to fix this boot problem and if so, what the correct syntax would be for my situation? Thanks for any help you can provide.

There should be a shortcut key (ie DEL, ESC, F10,F12,etc) very early in the boot process to access the BIOS/UEFI settings. I don’t know what it is for your machine, they tend to be manufacture specfic.

Within these menus there should be a boot section where you can select the Manjaro bootloader either as default, or first in a list of detected bootloaders.

Whilst here, also make sure that Secure Boot is disabled.

thanks @sueridgepipe for your feedback.

I haven’t needed to enter the (UEFI) BIOS setup on my DELL laptop before so wasn’t sure how to do this.

But I decided to give it a try.

During boot I pressed F2 key to bring up the settings screen. Then I had a look and found an option under Settings > Boot Sequence

Here it lists the “Boot Sequence” but I only saw options in following order…

Ubuntu
Debian
Windows Boot Manager

I didn’t see anything for Manjaro, but I saw a button “Add Boot Option” and on the next screen I see an option to navigate to several directories so I chose the one called “EFI” as it looked the most likely. Then I was able see more directories and Manjaro was listed so I selected that and clicked “OK” then gave it a name Manjaro. Clicked the “Apply” button and rebooted to find Manjaro was now in charge of GRUB MENU!

I must say I was surprised it was so easy. So thanks for your encouragement to try, I wasn’t very confident about doing any of that stuff.

So I have my system working again and I intent to test out Manjaro to see if it as good on my new DELL laptop as it is on my old SONY laptop.

I have a couple of questions and wondered if you could enlighten me.

Q1. Why did Manjaro not make itself in charge of GRUB MENU since it was the last distro installed (all the other distros work that way) or was it just a glitch that I had to fix in BIOS settings.

Q2. I have bought an SSD to replace the existing spinning hard drive so will be reinstalling my favourite Linux distros again and wondered if the summary of steps I described in my previous post to reinstall is correct, especially the summary at the end…

  1. Check that I am in correct UEFI mode by entering $ ls /sys/firmware and check efi is in the output.

  2. Select Manual partitioning. (efi and swap partitions already exist and new 30GB ‘/’ partition already created for Manjaro)

  3. Select each partition as detailed below…

Mount Partition File System Point Format? Flags /dev/sda1 fat32 /boot/efi NO boot esp (already enabled) /dev/sda9 linux-swap NO /dev/sda11 ext4 / YES

4 Click next and move to the manjaro installer summary screen, this is the summary that I am presented with …

Format 30724MB partition /dev/sda11 with file system ext4.
Set up fat32 partition /dev/sda1 with mount point /boot/efi.
Install Manjaro on ext4 system partition /dev/sda11.
Install boot loader on /dev/sda.

Does the last line look correct? I thought it should say “Install boot loader on /dev/sdb1” and NOT “/dev/sdb”. Or is it OK proceed with the installation?

Bootloader order is a BIOS/UEFI setting, Manjaro doesn’t set this.

How many Linux distros do you have on your machine?

Just be aware that kernel updates in your other Linux distros could cause issues for Manjaro GRUB.

For instance…

A good tutorial to fix if this happens…

In uefi (unlike bios-legacy), it does not make sense where bootloader is installed to - to sda, sdb, or to partition.
Just make sure you have the $esp mounted and that will work.
Installers for uefi install should not ask (or tell) where the bootloader is to be installed, but I guess that’s to assure people used to bios-legacy that’s alright. Same for command “grub-install /dev/sda” (it doesn’t need ‘/dev/sda’ but it works with or without it).

As for being ‘default’ bootloader for latest installed OS, there is no ‘mbr’ to overide. So there’s no default bootloader. But generally, efibootmgr will put the bootorder as first (not overide - that’s why old boots of removed OS’s will remain) in bootorder.
You can also use your method (in your bios) to do likewise if you need to.

Thanks for feedback. I am only now realising this.

To be honest I have ten distros on my SONEY VAIO (UEFI) laptop. I know it’s too much but I’m always looking for good distros to check out to see which one is best for me. They are only meant for testing purposes. I don’t like VMs. But I will probably only have 2 or 3 when I get my new SSD installed after Xmas.

I am aware that kernel updates will cause the GRUB MENU to change hands as they say, it’s happened several times in the past.

Previously when GRUB MENU changed after a kernel update, I logged into the distro I wanted to be in charge, opened terminal and ran $ sudo update-grub and $ sudo grub-install /dev/sda1 this worked for me, not sure it it’s the recommeded method.

But hopefully now I will be able to enter the BIOS Settings and make the necessary changes in the “Boot Sequence” like I did yesterday for Manjaro.

And thanks for the links, I will check them out. They look interesting.

I actually like the GRUB MENU for Manjaro since it remembers which operating system you last used. I think that is a cool feature. Haven’t seen it before.

10 distros and you have boot problems? Gosh, I thought everybody ran 10 distros without nary a burp! :smiley: :smiley: :smiley:

Regards

P.S. Manjaro loads Intel ucode in a different manner than some, which can sometimes be a bit problematic.

[quote=“gohlip, post:7, topic:14060”]
In uefi (unlike bios-legacy), it does not make sense where bootloader is installed to - to sda, sdb, or to partition.
Just make sure you have the $esp mounted and that will work. [/quote]
So before installation begins, I should always check my “EFI system partition” is mounted. To be honest, I don’t think I always did this in the past. So thanks for the advice.

In the past, when I wanted to change the distro to be in charge of GRUB MENU on my UEFI laptop, I have always used “sudo grub-install /dev/sda1” which is my “EFI system partition”. I didn’t know “grub-install” would work just as well.

[quote]
As for being ‘default’ bootloader for latest installed OS, there is no ‘mbr’ to overide. So there’s no default bootloader. But generally, efibootmgr will put the bootorder as first (not overide - that’s why old boots of removed OS’s will remain) in bootorder.
You can also use your method (in your bios) to do likewise if you need to. [/quote]
That’s funny you mentioned old boots of removed OS’s will remain) in bootorder, because when I was adding Manjaro in the “Boot Sequence” in my BIOS settings, I did notice one for Zorin which I had deleted over 6 months ago, and wondered why it was still there. Now I know.

Many thanks @sueridgepipe @ben81 and @gohlip for your help on this post. I have learned a lot over past couple of days. I will set post to solved.

I knew I would get stick for saying I had 10 distros. never mind, honesty is always the best policy :blush: But I must say this forum has given me excellent feedback and help which I appreciate. I’ve learned a lot.

LOL! That’s why I’ve given up on counselling anyone on the perils of concurrent multiple DEs or distros. Most cannot do so without inevitably running into problems. You are atypical, having successfully done so. Oops! Wait, didn’t you just run into one?

I did it when I was young in Linux, but prefer to not self-generate such problems anymore. It seems to be something about everyone does at one time or another, so I try not to be too judgmental about it. I have yet to say, “See! I told you so,” to anyone…yet…no matter how tempting it gets…yet.

Anyway, that’s why I mentioned Intel’s ucode & Manjaro. :smiley:

Regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark