Installing Manjaro in Safe-Mode (Graphics issue)

After tinkering with Ubuntu I realized that my GPU: amd r9 280 is unsupported via both proprietary and PPA (open-source) drivers. (My cpu is a Ryzen 5900x)
With Ubuntu I have been unable to boot/install without safe-mode or nomodeset.


Manjaro/Arch supposedly offers amdgpu-experimental which fixed a similar problem for another user. My installation of Manjaro however has been even more unsuccesful till this point; not even finding a way to boot safely.

I get to the boot menu and find myself lost having tried both open-source and proprietary boot options. Pressing ´´e´´ merely reveals a config (?) containing an added reboot option.

Any idea from where to go from here would be greatly appreciated.

Hello @LukeH :wink:

amdgpu-experimental just disables the radeon driver and enables the amdgpu driver.Just add this to the kernel parameter on the grub bootloader:

radeon.si_support=0 amdgpu.si_support=1 radeon.cik_support=0 amdgpu.cik_support=1

Maybe it helps :wink:

Many thanks @megavolt , I will test this at the next opportunity.

I would also add that my Grub loader (e) contains only the aforementioned 2 lines pertaining to some reboot functionality.

There is no such thing as “Safe-Mode” with GNU/Linux distros. Your post doesn’t tell us what the problem is at all. What didn’t work? What did you see? Logs?

Please see:

They both will do the same thing as there is no longer a proprietary AMD driver. There is only the legacy radeon driver and current amdgpu driver. Your card is supported by radeon. Forcing older cards to use amdgpu is experimental and may or may not work.

1 Like

Grub bootloader:

setparams 'Boot with open source drivers' 'x86... 
  linux /boot/vmlinuz-$2 driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 <SNIPPET FROM MEGAVOLT>
  initrd /boot/amd_ucode.img /boot/intel_ucode.img /boot/initramfs-x86_64.img

Yields a similar error (irq vector) I get from running nomodeset on Ubuntu 20.04, but it does not even boot; instead going black as before.


ok for clarification:

  1. Do you try to boot a local installation or a manjaro boot disk?
  2. Did you edit the bootloader menu of manjaro boot disk or did you edit /etc/default/grub on a local installation?

It would be good to have more information. At least remove quiet from the kernel parameter and see where it hangs exactly. If it is really a graphical problem, then there must be something written at your Xorg log.

Edit: Start the live session with this kernel parameter: . It will stop before entering graphical target. If till then no problem appear, then try start the display manager: sudo systemctl start display-manager.service, if it does not work, then there must be something at the Xorg.log at /var/log/.

You can share the log, if network is working, with:

for x in $(ls /var/log/Xorg*); do echo -e "---$x---\n\n$(cat $x)\n\n"; done | curl -F'file=@-'
journalctl | curl -F'file=@-'