installing expressvpn on manjaro. how to?

hi all ... i running a fresh install of manjaro and have just bought a year of expressvpn services. its not cheap but their servers are FAST and all over the world - and they have figured out how to unlock netflix et al :slight_smile:

i had it running under ubuntu no problem but cant get it to run under manjaro. there is a 64 bit arch installer so im sure there is a simple solution.

there is a step by step guide here that doesnt work from step 6 on:

i installs correctly but if i try to start up services i get an error:

[lilakmonoke@lilak-pc ~]$ sudo systemctl start expressvpn
[sudo] password for lilakmonoke:
Failed to start expressvpn.service: Unit expressvpn.service not found.

There is not much to it.

Can we see the output of:

pacman -Qs express
systemctl list-unit-files | grep -i express

[lilakmonoke@lilak-pc ~]$ pacman -Qs express
local/expressvpn 2.4.1-1 (utils)
ExpressVPN Command-line Interface
local/lib32-pcre 8.43-1
A library that implements Perl 5-style regular expressions (32-bit)
local/pcre 8.43-2
A library that implements Perl 5-style regular expressions
local/pcre2 10.34-3
A library that implements Perl 5-style regular expressions. 2nd version
[lilakmonoke@lilak-pc ~]$ systemctl list-unit-files | grep -i express
[lilakmonoke@lilak-pc ~]$

no output from the second command. so there is a file for systemctl missing?

here is the installer package, if you want to take a look at that:

I would try the AUR package

Hi @lilakmonoke,

thanks for reading that post of mine, it's a little old now and things have change a bit.

  1. on the AUR expressvpn page you can see that the last packager commented this:

WorMzy commented on 2019-01-11 11:38
Please note that, from v2.0.0, ExpressVPN will be providing signed Arch packages on their website (alongside the deb and rpm packages). I'll be continuing to update this package, but for those that find using the AUR cumbersome or just don't want to wait, please be aware of this option.

So I recently switched over to the installer on expressvpn.com, you need to download the Arch version, either 32 or 64 bit. You can also download the signature file there.

First, back up your system with Timeshift for example.

Once downloaded, I did the following:

expressvpn disconnect
sudo systemctl stop expressvpn
sudo systemctl disable expressvpn
sudo pacman -Rns expressvpn

Then once I'd removed expressvpn, I ran:

sudo pacman -U /path/to/expressvpn.package.tar.xz
sudo systemctl enable expressvpn
sudo systemctl start expressvpn
expressvpn activate >>> I didn't need to run this in fact, it told me it was already activate, maybe some log files somewhere?
expressvpn connect

And now it's working :tada:

I do have one outstanding issue but that's unrelated:
I cannot connect to the internet if i drop my VPN connection, irrespective of the network_lock status. From other posts it seems to be an issue with my DNS, perhaps in /etc/resolv.conf but I'm still trying to figure how to connect to the internet when I disconnect from VPN.

I realize this might not solve your problem, but I thought I'd put it out there in case it helps you or anyone else.

1 Like

Oh did you run

sudo systemctl enable expressvpn first?

see this answer by @Yochanan

@geomanjaro thanks for the step update. i just followed it and get the same error msg from the second line of the install part:

[lilakmonoke@lilak-pc ~]$ sudo systemctl enable expressvpn
Failed to enable unit: Unit file expressvpn.service does not exist.

so apparently the service isnt starting up. what am i missing?

I think this answer to another post might be what you need?

if so thanks and kudos to @xabbu :slight_smile:

Sorry, I went to bed last night and didn't follow-up.

Yes, this means that the system does not know about your service files which is because it seems like the package ships sample service files and doesn't install them. So you can just copy them.

sudo cp /usr/lib/expressvpn/expressvpn*.service /etc/systemd/system/.

That should copy both the services to a place where systemd can see them.

2 Likes

@dalto: great, that worked. this forum is awesome and so are you!

so here is how its done if you have a fresh install of manjaro:

  • go to expressvpn and download the Arch 64 bit version and copy the activation code
  • install it via pacman

sudo pacman -U /path/to/expressvpn.package.tar.xz

  • copy the service scripts to the correct location

sudo cp /usr/lib/expressvpn/expressvpn*.service /etc/systemd/system/.

  • enable and start the service

sudo systemctl enable expressvpn
sudo systemctl start expressvpn

  • activate it with the activation code you copied earlier

expressvpn activate

i also recommend downloading the expressvpn Add-on for firefox. then you can activate and change servers from your browser. im in germany and the best server is london UK because net_flux hasnt figured out how to block me from there. if it does just change the server.

thanks to dalto and geomanjaro for this combined effort.

5 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by