Installing Discord on Manjaro?

Hi. I recently just switched OS, from Windows 10 to Linux Manjaro.

I am still new to using linux, especially Manjaro. I am trying to install the discord app on manjaro, but I am having difficulties doing so.

So far for each problem I had with the new OS, I just googled for a solution. I tried to do the same for discord, but I am still struggling to get it to work. The most reliable source I could find was https://discordapp.com/ where it gives you a quick guide on how to install discord on any Linux Distros out there.

I know that Manjaro is a branch from Arch Linux, and I tried following the steps they provide, but It just doesn’t seem to be working for me.

The steps say I need to “untar” the folder, which I assume is just extracting the folder. After doing so I need to build a package using makepkg. The example they give is: “mkpkg -sri”. Whenever I execute that in the terminal, it says the command is not found.

I also tried using wine to install the windows version of discord. But it just gives out an error.

Using playonlinux seems to be the closest I gotten to get it to work. But after it is installed, and I try to run it, it gives the me following error: “error copying C:\users\Public\Application Data/SquirrelMachineInstalls\Discord.exe to C:\users\Public\Application Data\SquirrelMachineInstalls\Discord.exe

Any help on installing the Discord App on manajro would be greatly appreciated!

The discord app can be found here: https://discordapp.com/

It is not easy when you do not know. But you got the spelling wrong.

makepkg -sri
2 Likes

Thank you. I feel so stupid for making such a simple, yet stupid mistake…

Let us know if you succeed

 Yaourt discord    , then build it, do not edit it
1 Like

yea I got it working, thanks!

1 Like

Please check the answer so others know! I also had a sinlar problem too so don’t feel bad!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark