Installer without graphical interface

I have a very new machine and the installer gets stuck at “reached target graphical interface”. Based on other forum posts, I suspect there is hardware on my machine (at a minimum my GPU) which is not supported. Is there a way to skip the graphical interface? Is there a way to build an installer with kernel 6.1 and latest drivers? Thanks.

Update: I can access the non-GUI terminals and everything looks ok except that doing startx fails to find any screens. So indeed it looks like the drivers are not quite new enough. I can operate the GPU just fine on a manjaro with 6.1 and everything all up to date so looks like indeed I just need a way to update everything. Is it possible to install through a CLI?

I doubt it, but you can use this:

XY Problem detected. You’re asking about your imagined solution rather than your actual problem. This leads to enormous amounts of wasted time and energy, both on the part of people asking for help, and on the part of those providing help.

That’s just the last message, it’s not an error.

Check your /var/log/Xorg.0.log.

See [HowTo] Request support

Hey guys, sorry to have disappeared for a while, I had to deal with a completely unrelated hardware issue with the motherboard.

Anyway, I have figured this out.

I was attempting to boot with an nvidia RTX 4090, however the installer only included nvidia drivers version 515. Neither the 515 proprietary nvidia drivers nor nouveau support the new 40X0 cards. Though my motherboard is also extremely new, there do not appear to have been any issues with it on kernel version 5.15.

My solution was to “bootstrap” my installation by first using an older RTX 2080 video card, installing and updating everything, and then swapping out the video card. This appears to have worked just fine.

For others who might encounter this situation, an alternative approach is to install without a video card as nearly all non-server CPU’s these days include onboard graphics, install the proper drivers and then install the video card. I chose not to do this since I didn’t want to figure out what to install and tell manjaro yes I want nvidia drivers despite not having an nvidia GPU and I had the other video card so it was not hard in my case to just swap them.

I did not see instructions in the wiki about how I could have installed from the terminal and obviated the need to swap the cards, though I didn’t look very hard. I personally think it would be really nice to have an easy and obvious way to install from the terminal. I somewhat bemoan the loss of “manjaro architect” with which I could have done as I described (at least as far as I remember). I assume that the current installer is just running a script somewhere through the GUI, is there documentation on how that might be used?

That is because there is no dedicated CLI installer.

There is several guides in the #contributions:tutorials section which deals with command line installation.

One topic in particular contains information on how to mimic the currently booted ISO.

Assumption fail. You can find a lot of documentation with the Calamares project.

There is no central script as the Calamares installer runs several tasks defined by yaml configuration and python scripts.

It is of course possible to script the installation - I have done so occasionally - sometimes to help a member with some very specific issues.

There is much more at my notepad

1 Like

Thanks! The instructions on building an ISO is exactly what I was looking for!

The ultra short kickstarter is [root tip] [How To] Mini guide to build Manjaro ISO

Always use the latest ISO from the download page. It currently has the latest 525 series driver.

When was it updated? I wrote it maybe a week ago. The drivers it loaded with in the installer were definitely 515.

Oh, you know what it may have been, do the community ISO’s (i3 in my case) stay up to date? I run a customized qtile setup and I usually start with the i3 minimal installer. It’s custom enough that I should probably stop being lazy and make my own ISO’s.

Regardless, this was surely just a temporary issue, not a big deal. Thanks all.

Usually, but they’re not built at the same time the official ISOs are. There should be new community ISO releases soon™️.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.