Installer crashing!

Right after setting up partitions and starting the install, I get:

18:34:51 [0]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
Aborted

Without further information on your system, it is hard to help. Please post inxi -Fxxz so we can see what's going on. Also a quick search in the forum may have a solution, Here it is

It is much difficult since I can't paste easily from system trying to install.

What you linked perplexes me, fren. Does it say "don't try to install with NVIDIA 396.x driver"?

This makes no sense; we're in the 400s now, and I don't even know what driver Manjaro 18.0.4 attempts to install with.

I did choose the non-free driver in the USB's pre-boot thingy. And the installer crashed before, but repeated attempts eventually prevailed. Not this time, it seems. D: This is installation attempts on a system that has run Manjaro fine for quite a while, FWIW.

Is there any long-term downside to using one of the experimental builds? (The "rc5", "rc7"-suffix'd Manjaro downloads.)

I imagine they come with weird new stuff. But, eventually, will the weird new stuff get roll-updated to the normal Manjaro version's stuff?

I want to try them out of desperation. Else maybe abandon KDE since these are Qt errors after all. XD

I am not well versed in Nvidia, as I have systems with Intel and AMD graphics. hopefully the guru's can be of some help.

However, can you give more information as to

  1. Are you able to boot to desktop?
  2. At what stage, do you get the error?
  3. Are you able to drop into a terminal and go to your logs in /var/logs and see if there are any errors and post those.
  4. If this is a fresh install, maybe reinstall and see if you get the same error.
  5. What type of graphics card do you have ?
  1. Yes
  2. Right after partitioning and getting past the "You're gonna make irreversible changes to disk!" dialog.
  3. Do you mean journalctl??? I don't know how to handle disparate logs. xD
  4. ???? I cannot install. I am trying to install, and the installer is crashing.
  5. Nvidia GTX 1080 Ti

I ran Manjaro for a long time with this graphics card, so it's not suspect to me. I'm on a new chipset though. I installed successfully yesterday (the installer did crash, but someone on this forum said you gotta sudo calamares and try and someone replied that that's outrageous but I did that and it didn't crash). I am reinstalling now because I accidentally borked my system, but now sudo calamares doesn't work. x3

Hello,

Who ever said you shouldn't have to run calamares with sudo is correct? What version of Manjaro are you installing with? What kernel are you using?

The new chipset could be a issue, Have you updated your bios, even if it's a new board, the bios could be several versions behind. What type of motherboard is it, I can do some research and see what I find.

Do you get any errors when you are running it from the USB Key before you install, another words, live.

As for the logs, it would be the xorg.log, Kernel.log, Journalctl logs. NVIDIA seems to give people the most headaches when installing, there are hundreds of issues and resolutions in this forum regarding these cards. However, once they are configured right, they should be fine.

The one thing that I see that's changed has been the motherboard and the chipset. I would update the bios and then see what happens. I am sorry you are having a hard time, but don't let this discourage you because it will be well worth it, once we get it all sorted out.

One other thing, try reformatting the USB key and create a new ISO and see if it works, there may have been some corruption that has happened. QT and KDE shouldn't be an issue, it is what I run exclusively and I haven't run into any issues, other than some themes will give me kwin errors.

Also are installing via UEFI or GPT? have you set your bios to legacy mode? and disabled the secure boot? Here are some links regarding the 1060




1 Like

I switched from a fass USB 3 stick to a slow USB 2 stick, and this time it didn't crash, but then


Wtf ; ;

I used a different USB key, and the above happened.

I don't understand. I'm using the same partition scheme as before except with ext4 on / instead of F2FS. D:

I am indeed tryna install GPT for a X570 UEFI chipset.
My partition scheme is:
/, ext4, >900 GiB
/boot/efi, FAT32, esp flag, 600 MiB
swap, linuxswap, swap flag, 10 GiB

Is this a 32bit system? Also do you have a nvme drive?



What type of cpu and motherboard do you have?

https://forum.manjaro.org/search?q=ryzen%203700

At this point, can you post the specs of your system.

1 Like

I... I'm scared. This is moving too fast!

!!!!!

I tried the 18.1.0-rc7 ISO and I unplugged my ethernet cable to air gap my system. I think the latter is key because I recall doing that the first time in conjunction with sudo calamares to get it to work. We superstitious now.

I was so close to installing Kubuntu. xDDD PHEW!

Congrats to you, see it wasn't so bad and now you know what to do! :smiley::clap::clap::clap::clap:

1 Like

Forum kindly sponsored by Bytemark