Installer crashes - Fault on start Radeon R9 390

Newbie to Linux here. I’m trying to dual-boot Linux and Windows. I made the installer with the latest Linux Manjaro KDE Plasma edition in Rufus and got into the BIOS, selected the USB as the primary boot drive and booted into the first menu. From here I cannot advance any further. Picking either the default graphics driver that it selects to or the proprietary one send me to a screen where it checks the hardware and then boots me into the Manjaro loading screen, where the bar fills completely, and the screen turns black. I cannot get past this part. I have tried both KDE, XFCE, I tried installing Ubuntu, remade the USB installer in different programs multiple times and added the command “nomodeset” in GRUB, and nothing works. The farthest I have ever got into the installer was a couple of weeks ago when I tried installing and it booted into the live environment to configure the installation and I could use it for maybe 30 seconds before the screen glitched and rebooted my computer (my screen had weird artifacts and glitching the whole time until it crashed). I understand that it is a GPU problem as I have read a forum about someone with a similar issue that had an R9 280, however no solutions proposed by the comments in that forum have helped me. I have a Ryzen 5 3600 CPU and an R9 390 with an MSI MOBO, so no other display driver to connect to.

I do remember getting Linux Mint to work a couple of years back, however I had an i5 back then and it had an iGPU. Maybe a clue would be that I tried once installing PrimeOS on my computer and if I connected the HDMI to the GPU it would have screen artifacts and glitching and then shut off, much like the Linux installers, however it had no problem running it off the i5’s iGPU. I did try disabling secure boot and it didn’t help.

Any sort of help would be appreciated. Maybe there is a way to install Linux through windows so that at least I could configure the OS externally (I’m not referring to VM).

for iso , try with ventoy

check in your motherboard all option
Secure boot off
Fast boot off
CSM off
all disks on AHCI
UEFI only or others ( not windows )

if you can boot on any DE ( manjaro or other )
can you open a terminal & a browser on this topic
and returns

inxi -Fza

I will go ahead and try the settings you proposed.
Question: what do you mean open a terminal & a browser on this topic? I’m very new here.

first create your USB iso
second try to boot with checking all options Before on USB live manjaro

I just tried booting with the setting you recommended but no success. I do not understand what you’re trying to tell me in the last comment, do you want me to remake the USB installer with certain settings? What should I use? Can you give me a good and updated tutorial? All the other ones are made months ago and since the the UI for Rufus has changed.

I followed a guide and managed to boot into the live environment however after 5 seconds it crashes.

is it same with other distribution linux ?

Yes, it is.

i think you have a fault hardware
you should see with any repair service

No, I don’t think so. I’ve had this GPU for years now and it works fine in Windows, even when gaming. I heard something about the R9 series of GPUs being unsupported or the Kernel 5.xx version being bugged out.

on boot USB iso live manjaro you can get screen text or not ?
have you tried to get TTY ? ( Ctrl +Alt +F2 to F7 )

I just deleted Manjaro from the USB and I’m trying PopOS. I no longer have time today to try, but tomorrow I’ll try to do what you said.