Installer crashes at starting X (light display manager), XFCE-18.0.4

Hi All,

I have a new laptop (Lenovo 14s) with an AMD Radeon Lexa E9171 display controller.

Running the installer (of USB stick), it does boot, and I have tried choosing both free and non-free drivers, but when it gets to the 'starting X' part, it spits out a load of errors (that scroll off the screen too fast to see the start of it).

I also tried an old version, 16.10 (or 16.08) off CD, but it does the same thing.

I've tried booting some 'utils' as a test: gparted, rescatux, and they both boot fine into the X system.

I also tried the Debian installer, it booted and I didn't go past the first screen (keyboard choice ?), but it seamed to be into a graphical display with mouse...

Any suggestions ?

I've been on Manjaro for a couple of years now, the only problems I've ever had are with the installer, on different machines...

Maybe try rc3?
You'll be on testing but you can change that if it works. :slight_smile:

1 Like

ThinkBook 14s (14") Laptop??

Maybe

$ inxi -Fxxxz

could help :wink:

rc3 kernel is linux51 5.1.15-1, mhwd-chroot to new/last kernel

 5.1.17-1 or 5.2.0-0
  1. 'thinkbook 14s' - is a new laptop, both from Lenovo and for me.

So it came with (ie. has) Windows10 on it.

FYI: I'm wiping that for either Manjaro or Debian.

  1. inxi -Fxxxz

System:
Host: manjaro Kernel: 5.1.15-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 9.1.0 Desktop: Xfce 4.13.5 tk: Gtk 3.24.9 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 20RM v: Lenovo ThinkBook 14s-IWL
serial: Chassis: type: 10 v: Lenovo ThinkBook 14s-IWL
serial:
Mobo: LENOVO model: LNVNB161216 v: SDK0J40697WIN serial:
UEFI: LENOVO v: 9YCN32WW date: 04/18/2019
Battery:
ID-1: BAT0 charge: 47.0 Wh condition: 47.3/45.0 Wh (105%) volts: 15.4/N/A
model: SMP SR Real Battery type: Li-poly serial: status: Unknown
CPU:
Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP
arch: Kaby Lake rev: B L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 31880
Speed: 545 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 600 2: 600
3: 600 4: 600 5: 600 6: 600 7: 601 8: 600
Graphics:
Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3ea0
Device-2: AMD Lexa [Radeon E9171 MCM] vendor: Lenovo driver: amdgpu
v: kernel bus ID: 01:00.0 chip ID: 1002:6987
Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati,intel
unloaded: modesetting alternate: fbdev,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2)
v: 4.5 Mesa 19.1.1 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8
Sound Server: ALSA v: k5.1.15-1-MANJARO
Network:
Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:9df0
IF: wlp0s20f3 state: down mac:
Drives:
Local Storage: total: 484.34 GiB used: 51.2 MiB (0.0%)
ID-1: /dev/nvme0n1 model: HFM512GDHTNG-8310A size: 476.94 GiB
speed: 15.8 Gb/s lanes: 2 serial: rev: 80060C00 scheme: GPT
ID-2: /dev/sda type: USB vendor: SanDisk model: SDDR-113 size: 7.40 GiB
serial: rev: 1.00 scheme: MBR
Partition:
ID-1: / size: 11.52 GiB used: 51.2 MiB (0.4%) fs: overlay source: ERR-102
Sensors:
System Temperatures: cpu: 40.0 C mobo: 27.8 C gpu: amdgpu temp: 34 C
Fan Speeds (RPM): N/A
Info:
Processes: 234 Uptime: 4m Memory: 15.36 GiB used: 800.7 MiB (5.1%)
Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7
running in: xfce4-terminal inxi: 3.0.34

trying 'rc3' :-

It worked - thanks.

I didn't install yet, but it booted fine.

An then going back to 'stable', I'd just follow:

So I seam to be all set for now.

Thanks.

Great! Good luck and enjoy!

A suggestion:

could we have a forum for 'installation problems' ?

FYI: I have another problem now, so I'll create a new post.

Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by