Installed in 10m killed in 1s. #root #sudo #vipw

Hello. I hope this wont be too long to read… :warning: :grin:

I have just installed Manjaro KDE Plasma, and after being
unable to install graphics driver from AMD and HD Sentinel GUI
I was searching how to login as root, and of course I stumbled on
some posts saying that its a BIG NO NO, and how that’s why Linux
is safe and Windows is not…
Anyway after being denied to access root a few pages and forums later
I was inside password file using vipw, trying to find anything that might get
me to login as root.
I edited it just to see if its possible, then I closed it thinking changes wont be saved and
I’ll get back to it after pc restart and some more googling if that is good direction…but
pc failed to boot.

Regardless the fact I am new to Linux I can not believe that it crashed, and even though
in a way being mocked by Linux community I don’t think Windows would allow new user
to crash it so easily trying to reach, to quote some Linux post, “GOD”(root) admin level.
And no matter how much of a rookie or noob I am in a Linux world, to me this is a design flaw.
If I am the one installing the system I already should be able to easily have access to root,
with warnings when in sensitive elements of the system. For example, had I been granted
access right away, informed and warned where I am I would be ten times more careful.
Also, this might be easily fixable and I am making a long topic about nothing(I apologize in
advance), but the thing is if this wasn’t a brand new installation and had I had my documents
programs bookmarks browsing history on PC I would be so f**** pissed cause of such a lame failure, not to mention that Windows needs third party software to read Linux partitions.

I did look into other distros and even though few other seemed like “friendlier” choice I chose Manjaro because it was described as “cutting edge”, but even a cutting edge should cover and include simple stuff in a simple way.

Everything about this is just so wrong.
For example … breaking your install via permissions and root et al would never mean that the data is corrupted. It would still be intact. I would bet even doing whatever you did the whole system is probably recoverable. Regardless though … you could still retrieve your photos.

But I am sorry, no, breaking stuff because you intentionally attempted to misuse something you did not fully comprehend is not a ‘design flaw’.


With Linux - the user is in control - and if the user choose to do a disk wipe there is nothing that will stop you - Linux is about choice - you can do what ever you want whenever you want.

When users on the forum is advising new users to be careful with root access there is a reason. Lack of knowledge often leads to disasters - and the disasters happens quite fast if you ignore advice from experienced users.

There is nothing that stops you from setting up your display manager to allow inputting the user name you will use. That makes it possible to login your system as root.

About your issue - boot a live media and mount the device - undo your changes. If you have run the complete disaster command - then you may need e.g. testdisk to recover the files.

:warning: NEVER execute this as root on your system

# rm -rf / --no-preserve-root

This is not a design flaw - there may be situations where such action is necessary.

Depending on your display manager - it is often possible to change from a user list to name input - which makes it ultra simple to login as root.

If you are into pen testing you will know a lot of tools requires root and in such case you run the system as root - KALI is an example - BlackArch is another example. But only very knowledgeable users run their systems that way.

After all it is only a computer - and computers are stupid - they do exactly what you tell them to do.


It didn’t let me access but it did let me crash it…
Accessing should be much easier than crashing it.
I did not try to misuse it, I tried to get info about my SSD,
to find out if TRIM is supported and working, since its disabled by default, and since GSmart
is not showing it, HD Sentinel GUI wont install even with following
instructions on their web page. Listed KUbuntu, Ubuntu, Fedora, but no Manjaro.
Install was done on empty SSD, and it’s not like I did not know what I am doing, from what I see there are shadow files, so after boot failure I thought it will use them.
I was quite surprised that it did not ask for “save changes” “dicard” or “cancel” on closing after modification, if “design flaw” is too harsh then there is certainly ,as Elon would say on crushed Cybertruck window, “room for improvement” :stuck_out_tongue:

Also, I did not mention corruption of data, but getting it out on more common OS, read Windows, is pain in the a**.

You went about it the wrong way.
There shouldnt really be a need to edit the password file, and obviously you mucked it up.

This is listed just about everywhere you should have looked like the manjaro and arch wikis.

Not what you needed, and not how we generally install software.

You were using admin tools doing admin things … they arent made for newbs or safety nets.

Do go on about how unix/linux has room for improvement because you wrote bad configs to a system-critical file.

Once again … these things all belie your inexperience, not problems with the operating system.

Just to give a breakdown of what should have happened..
  • Check for TRIM capability (non-zero values in DISK-MAX/DISC-GRAN indicate support)
    lsblk --discard #(alternatively you may use hdparm like hdparm -I /dev/sda)

  • Enable TRIM. There are a number of ways … but most likely it is best to use fstrim service
    systemctl enable fstrim.timer --now

  • BONUS - Make sure the less-optimal function ‘discard’ is not in use in /etc/fstab

I am trying to ride a bicycle here, not to fly a plane.

You are viewing this from experienced developer perspective and me from new user.
Try this analogy, manual gearbox is much better than automatic, or at least it was considered so not so long ago, but automatic is more popular because car is easier to drive…
I will of course find what I need, my point is that OS should not be this easy to crash, boot config files should be made something like static final or have such copies, there should not be a boot failure because of few KB file, just information that “inexperienced user”, how you so eagerly call ppl who are new to Linux, tried something wrong, OS should “wipe the dust off” and continue, without live USBs, try to see this in the long run.

And current point is that features like TRIM, drive health, utilization, temps etc. should be built in, just like firefox vlc libre…in most desktop environments with GUI representation precisely because they are desktop and not terminal oriented.

I actually started this topic because it was in a way disappointing to me to see “Failed to start”, not because I wanted to rub anyone’s nose in it…and because I think that some changes might greatly improve UX and Linux, no matter the distro, and that would mean, well more users.

P.S. Plane is great machine because it designed with triple safety systems or nets, and not with none. :sunglasses:

Thank you for specific instructions, they’ll make next installation more stable! :joy:

Stage #1: Denial.
Stage #2: Anger.
Stage #3: Bargaining.
Stage #4: Depression.
Stage #5: Acceptance.

I wish you luck on your journey.


UNIX/GNU Linux is not a bicycle and is not a plane either …

You can crash everything easily - you just need to ignore every safety net.

You have deliberately modified system files using an administrative user’s permission.

Yet you blame the distribution? :man_facepalming:

You are asking for safety net yet you discard the safety net and blame the distribution - this topic is hereby closed - and don’t create another - you are wasting our time.