Installed application doesn't show up in run menu or launcher

Just installed keepassxc and neovim on a fresh manjaro kde but the applications won't show up either in the launcher or in the run menu. Desktop files have been created for both applications in /usr/share/applications. Any idea?

Thank you

Not sure why this happens but usually logging out and logging back in resolve the issue.

Already tried that and also rebooted several times but it didn't help.

I am afraid I have no idea what is going on. Saw another thread yesterday from another (KDE) user with the same issue:

2 Likes

Can you copy the .desktop file of one of the new installed applications from /usr/share/applications/ to ~/.local/share/applications/ (create that directory if it doesn't exist) and see if that helps?

If it doesn't make a difference, simply revert any changes you made.

2 Likes

That works! Should I do that as a workaround for now?

Instinct says cache issue - I have no idea where KDE caches the launcker items.

1 Like

I agree that this is only a workaround, so I would suggest waiting for replies from community members who are using KDE (I'm not a KDE user) for something better than copying .desktop files from one location to another.

EDIT:
I think that @linux-aarhus is right about the .desktop file caches, so this might help:
https://userbase.kde.org/KDE_System_Administration/Caches#KSycoca

Try right clicking in the appropriate category in the menu and select "Show hidden items"

I think that @linux-aarhus is right about the .desktop file caches, so this might help:
https://userbase.kde.org/KDE_System_Administration/Caches#KSycoca

Seems like that solved the issue (.desktop file caches).

Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by