Installation with Manjaro-Architect ISO

netinstall
installation
manjaro-architect

#134

So are you saying that nothing was mounted and it installed to directories in /mnt??


#135

@oberon, sorry for the delay but I went to eat :slight_smile:
Yes, your consideration is correct!

I suppose that if you try to repeat the sequence, you’ll get the same behaviour.


#136

Has this to do with something similiar as what fdc1b experienced ?

Im’ no expert but this seems odd…
pre partioned hardrvie with Gparted, made Architect ISO USB and launched…
during “mount partitions” section it seemed like when selected “make Swap file” -> it’s was being made to USB stick since if I try give swap file bigger than stick installer says “no space left on device…” ?

same with root and boot, it was like they were tried being made to USB /mnt/boot /mnt/root) and not to HD ?
after mounting “List Devices” gives mountpoints, root= /mnt and home=/mnt/home not as / and /home ?

Sorry for crappy text and bad english etc. and most likely useles info.
I’m just a average idiot user…


#137

not able to make testing or unstable repository switch, changing in pacman-mirrors.conf does not sort any effect, always saying no update available


#138

Making progress with btrfs subvolumes. Having problems with the current btrfs mounting option sometimes weirdly failing.

Currently writing the btrfs function as a separate menu item in the preparation menu, to be run after mounting partitions. It has 2 modes, automatic and manual. Probably need to move it right after mounting root partition, because unmounting /mnt fails when /mnt/boot/efi is mounted.


#139

I tried to test manjaro-architect but I have some problems with the internet connection.
At first I tried to connect via wlan, but I have a hidden network and I had no chance to find it in the list of the available connections. Adding my wlan network was not successful.
The second attempt was to use the wired connection but although my connection ist marked as connectet, the manjaro-architect did not build an internet connection.

Where ist my mistake?


#140

Manjaro-architect simply uses networkmanager through nmtui to connect without knowing specifics I cannot say if you did something wrong, but it seems that your hardware is just playing hard to get (convincingly). Usually adding the network connection should work.


#141

Okay, thanks for your answer.


#142

Thank you so much for Manjaro Architect! This thing is probably the best installer that I have ever used. And, of course, also thank you for this walkthrough. Keep up the good work! I can’t wait to see the finalized “Version 1.0” :slight_smile:


#143

Shouldn’t that be:
Now manjaro-architect-launcher will look for an active internet connection and then will download and install the latest available version of the installer.

Suppose there is no active internet connection, how will the architect download and install the latest version of the installer?
(First post, just below first picture)


#144

Doesn’t matter, because the installer doesn’t work without internet connection. If it cannot download the latest installer, it cannot download the packages to install either.

If there is no pre-existing connection, it launches an interactive interface to connect to a WiFi.


#145

Thanks, that is I was searching for!!! :grin:

Although I would like to choose more than one DE/WM to install so I don’t had any extra work after instalation.


#146

You can, but only one with manjaro configuration


#147

Oh! Didn’t know, thanks!!
So it’s exactly what I need!!


#148

After installing normally, go to advanced section and navigate to “Install unconfigured desktop”.


#149

I would like to install Manjaro architect on an existing software RAID 1. The array was created by the BIOS of an old Dell PC, and is currently working fine with Mandriva OS (time to upgrade I suppose, lol). When I attempted to install Manjaro architect, the array was listed as sda and sdb with similar partitions. I did not edit/format any partitions with the tools available, and decided to ask first before messing things up. How do I modify the installation, so the array is recognized before partitioning? I would like to preserve /home and /backup partitions, and reformat / and /swap specifically. Any pointers will be greatly appreciated.


#150

Unfortunately there is no special RAID support at the moment. I have have no experience on the subject, so I don’t know if it is safe to use manjaro-architect to mount the partitions. Probably not.

Therefore, if you want to install on existing RAID, I would recommend mounting the partitions manually in another terminal to /mnt, /mnt/home and so on. Then proceed to the installation step without touching the “Mount partitions” section of the installer. If you haven’t before mounted the RAID manually, this arch wiki entry is hopefully useful:

https://wiki.archlinux.org/index.php/RAID


#151

Thank you for your reply. In my case the RAID setup was called fake RAID, since it is a BIOS enabled RAID system rather than one that was obtained by special RAID card. I worked on it a few days and ended up being stuck at the grub phase. I could not get grub install within the RAID array for whatever reason, and I gave up. Of note, official Manjaro XFCE installer did not recognize the RAID array either, although the file manager on the live OS did. I am not sure how common this scenario is. It may not worth the time and effort to fix this if there aren’t too many users complaining about it IMHO.

A few useful links below in case anybody more talented and knowledgeable than me wants to tackle this issue:

https://forum.manjaro.org/t/does-manjaro-understand-mdadm-raid-and-how-to-install-it/1564/4
https://askubuntu.com/questions/468466/diskfilter-writes-are-not-supported-what-triggers-this-error
https://wiki.archlinux.org/index.php/Installing_with_Fake_RAID


#152

I need an option to just install Manajro Server without any desktop…like the good old manjaro-net


#153

You are not forced to isntall a DE in manjaro-architect. You can just skip the steps for DEs and video drivers.