Installation with Manjaro-Architect ISO

netinstall
installation
manjaro-architect

#114

@dot, can you please install

sudo pacman -U https://www.uex.dk/repos/manjaro/unstable/community/x86_64/manjaro-architect-dev-0.8.7.r2.g00805bf-1-any.pkg.tar.xz

and then just run manjaro-architect (not ‘setup’! :wink: ) and then see if size calculation now works correctly?


#115

The free space calculation looks much better now:

I would say: "works for me"
I just had a look into the corresponding code and found a way to simplify the code even more:
At the moment you do some tests to determine if the value is in GB or MB.
Instead you could use the command vgdisplay --units M to get it always in megabytes.
Megabytes also have the advantage that you don’t “lose” up to 0.99GB because of the trimming of the decimals.

Bernhard


#116

I guess then the output will also never contain a decimal, right? :wink:


#117

I doubt so. But I did not make a screenshot of it.
You would have to go to bytes to be sure there are no decimals I think.


#118

I tried this and didn’t work. I will post in next post error msgs and my steps


#119

Yes, base-devel installed as it was the case last time with the same problem that I never solved so i decided to try again with never manjaro-architect version

First I had to remove db.lck, I was doing everything in the terminal, not in Pamac.

Then I tried yaourt again and got this error again:

curl error: peer certificate cannot be authenticated with given CA cetrificates

I followed steps from the link @kainonergon posted and removed the certificate. Last command:

pacman -Su

Didn’t reinstall ca-cetrificates. Neither did any other such as -Syyuu. Running yaourt was now returning this error:

curl error: problem with SSL CA cert (path? access rights?)

Which tells me error is because of missing certificates, so I installed it back:

sudo pacman -S ca-certificates-utils

After this, old error was back:

curl error: peer certificate cannot be authenticated with given CA cetrificates

I tried few more fixes such as:

sudo pacman -S archlinux-keyring

but so far I’m still unable to install or see any package from AUR

I also reinstalled yaourt and curl

Anyone has any idea what else I can do? Threatening computer with baseball bat didn’t help either. I understand actually swinging with the bat would fix the problem for good lol but for now I’m looking for less radical sollution :wink:


#120

@AlManja Maybe:


or:
sudo update-ca-trust
https://bbs.archlinux.org/viewtopic.php?id=224214


#121

Thank you very much, I will try it out. Silly me I only searched Manjaro forums, somehow I unintentionally skipped wide i-net universe. In that response in the link you posted may be a culprit:

Is the clock on your machine correct?

I remember booting up I saw some warning or error or something regarding time or clock, but I didn’t know it is significant. But before I go into time issue, I will try out:

sudo update-ca-trust

Thanks!


#122

Yes, it was time related, my system clock was 15 minutes off and this was the reason for my yaourt problems. This fixed it:

sudo hwclock --systohc --utc

If one wants to check if computer’s system clock is off:

sudo hwclock --show
date

Which means it has nothing to do with manjaro-architect! Sorry @Chrysostomus, @oberon and @all_others


#123

Wow, interesting find!


#124

Maybe this is a stupid question…
Is there any chance to implement a new feature to “create an ISO” instead of install the system?
Something like: Boot from USB/DVD with an HD/SSD attached, configure everything and then save the ISO to the HD/SSD?
This would be easy to build a remaster/respin
TIA


#125

No. Doesn’t work, and also would not make sense as m-a installs using iso-profiles and settings-packages. To build ISOs using these we have manjaro-tools :slight_smile:


#126

We could theoretically have interactive manjaro-tools interface, but it is currently beyond the scope of this project.

However, I think the better way to implement your idea would be:

  1. make a regular installation to your USB stick with manjaro-architect
  2. use this stick to install manjaro to other systems with manjaro-architect

The benefit over using this instead of iso is obvious: you can have a package cache, so you don’t have to keep re-downloading packages. If your first installation takes 30
min, the next might be under 10 minutes. And the installer remembers your language settings. If you install often, you save a huge amount of time compared to using a custom iso.

Of course you also don’t have that iso customized. But including customization for iso is way out of scope of this project.

I still like your idea though. Having a separate tool for interactively creating a iso profile and using manjaro-tools could be fun.

It would have at least 4 options in main menu: 1) configure 2) build iso 3) create a profile 4) edit a profile.

Profile creation would offer you two startup choices: use an existing iso-profile as starting point or create a configuration using the running system as a template. Then you could edit the package list pacli style with fzf. Finally profile.conf would be opened in a text editor. Editing the overlay files would be done in the edit profile section (basically just open the right directory in the file manager).


#127

m-a 0.8.8 has just been released with

  • LVM disk-space calculation fixed for locales using decimal sign , thanks to @dot !
  • complete Polish translation added, WOW! thank you very much, @edskeye !


#128

Took so long to finish those few lines… sorry bout that, and let me know if i messed up sth.
Btw. May i test it somehow?


#129

A few lines? You are kidding!? :wink:
0.8.8 is already in the repos, including the Polish translation. You will get in when you install m-a or by using setup on the ISO. Yes, it would be great if you could just make a test install and look at everything again in action :slight_smile:


#130

Already noticed it - sorry for silly question, been sleepy a bit :stuck_out_tongue:
I will install Manjaro in VM using Architect and let you know if everything is ok :slight_smile:
EDIT: Already installed. Works fine. Pulled some fixes on GitHub :slight_smile:


#131

Today I did a test with an external HD, previously installed, with this configuration:
512Mb /boot ext4
4Gb swap
294 Gb /root LUKS btrfs.

STEP

  1. mounted the partitions using the “not to format” choice: all right
  2. remounted the partitions asking to format the /boot partition with ext4: apparently all right
  3. started the installation process and all is installed in the /mnt/root /mnt/boot but WITHOUT writing in the external hd

Previously, in a similar situation, I got the Error [255]; now this error disappear, but to write on the correct HD I must close the M-A and to restart a new session.


#132

I’m afraid I don’t understand. What is /mnt/root and /mnt/boot then if NOT the external HD? Where did it install to?


#133

@oberon: to simplify:

/dev/sda -> the drive where I’ve mnjaro-architect installed and from where I launch it
/dev/sdb is the external hd I’m using for the test.

If I do the steps reported in the previous post, the installation is done in the
/dev/sda/mnt/root and /dev/sda/mnt/boot but writing DIRECTLY on the sda device, like if the link with the sdb disappear.

Was I able to explain? I hope… :slight_smile: