Installation with Manjaro-Architect ISO



I see :wink:


Absolutely right. But I use ext4 for my test installs - so I don’t really need it but it is some kind of “bad habit” when it still was needed.


I have finished my retesting session. I can’t reproduce it again. Even though I have a video of my installation that failed I can’t get to the same problem state.
Apart from that a name like “root” (instead of “lvol” still does not work).

One thing is strange though - “50000MB remaining” (that are about 50GB and therefore not possible for a disk with a size of 16GB):


Thanks for all your testing!
Regarding the exclusion of group names:
Architect complains when either the name is empty, or contains a / or when it is found in the output of lsblk | grep ${LVM_VG}, where $LVM_VG is your input.
So apparently root appears in your lsblk…? A group name you have used the previous time for example, will still be there.
However, something seems to be off with disk space calculation in your case. Are you using an SSD? Likely not relevant, just a wild guess… :wink:


To get the available space architect does ```
vgdisplay $LVM_VG | grep ‘VG Size’ | awk ‘{print $3}’ | sed ‘s/…*//’

If we could see the actual output of your ``vgdisplay groupname`` in that moment, that would be helpful.


I’m no longer able to replicate the Error [255] with the manjaro-architect 8.7: GOOD :slight_smile:

Later I’ll do the final test with a luks partition. Great work and chapeau! :smiley:


I still didn’t have the time to add proper creation of crypttab :frowning: So, I’m afraid LUKS is not completely ready. You will need to edit that file manually for now and also fstab might need editiong… mkinitcpio should be ok, though.


Any insight on this, @Chrysostomus ? To me the 255 error still seems quite random - just somehow related to network connection, file conflicts and similar things… But no idea what could be improved there for now, you?


Most of them are a matter of mirrors and profile maintenance. But some seem to be related to mounting partitions without mounting them on certain filesystems. We can fix the latter, but can do little about the former. Former should fix itself when updates arrive in all mirrors/branches.


I installed m-a again on old & nit picky computer that hates Clamares.

As few weeks before, everything appear to be working with the exception to AUR. Just like few weeks ago I can’t see/install anything from AUR

I installed devel… or whatever it is called, first option where are kernels listed
Xfce 64, minimal

Yaourt is installed
I changed settings in Pamac to allow AUR packages and restarted computer

Can’t install from Pamac and can’t install with Yaourt,
When running Yaourt, I get some certificates error.

Is there any easy solution for this?
Is there something I’m doing wrong? (since it happened again)


I guess you should update certificates package that was mentioned in updates announcements a couple of weeks ago.


Do you have base-devel installed? Building aur packages does not work without it. There is a option to choose it in the kernel selection.

EDIT: re-checked your post, it seems you have it.


After a few days with a terrible cold I am finally back to test Manjaro Architect.

I just found out where the ban to use “root” comes from:

I think the grep is a bit too greedy at that place as it would also forbid names like “disk” or “part”.

The actual output of your command should be “15” I think.
But I get (again) an output of 0 in setup:

I already have an idea:
If I use only one 512M partition I have a LVM partition of 15.50GiB. The result is the display of 50000 MiB free space in the setup routine.
If I use a two partitions of size 512M (or one with 1G) I have an LVM partition of 15.00GiB. The result is the display of 0 MiB free space in the setup routine.
It somehow seems that the sed for Free PE / Size (available size) does not use the values before the dot but the values after it (e.g. 50 --> 50G --> 50000M).
This would result exactly in my findings.
The sed command for VG Size (total volume size) seems to be correct though.



@Chrysostomus @oberon Is it somehow possible to run Manjaro Architect in DEBUG mode? Like bash -x would do.
That would be really helpful.
starting setup with bash -x setup does not work for long - only for the first self-update process.



  bash -x manjaro-architect 

Setup is just a wrapper script.


I got debugging working with these instructions:

$ sudo -s
$ exec 3>| /tmp/manjaro-architect.log
$ bash -x manjaro-architect

The log output is redirected to the file /tmp/manjaro-architect.log with these commands.

And this is the output of vgdisplay:

As you can see there is a comma instead of a decimal point in VG_SIZE=15,50.
A possible reason for this could be my switch to german language in the setup?
But this still seems odd.



Great job! Thank you!
Yes I was also wondering about . vs , already.
@Chrysostomus I guess we’ll just have to add a

sed 's/\,.*//'



I’ve added it. Will make a now dev package and let you know when it’s online. Would be great if you can then try again with that one!



I would also like to correct the German translation at some points in the near future. But this is not that urgent I think.



I made a lot of corrections there already. What is still wrong?

of course you are more than welcome to fork and send us a pull request! :slight_smile: