Installation with Manjaro-Architect ISO

netinstall
installation
manjaro-architect

#74

Thanks for the clarification @oberon :bow:
Will try that out and let you know if I get stuck somewhere :thumbsup:


#75

Now I knew why in other places you were so keen on sorting lists - I thought you were just being a bit pedantic… :laughing:


#76

I think you can maybe remove the duplicates without sorting by using

  awk '!x[$0]++'

But I haven’t tried it.


#77

Keyboard is the same, querty. Just that there are several input methods, but pinyin is getting to be the de facto standard. So for system developers, keyboard is not an issue. Querty is fine.


#78

getting the following error trying to install base pkgs [install basepkgs] [255] Creating install root at /mnt
Edit: It seems like I got that error because I tried to install 2 kernels 4.9 and 4.11. When I just tried to do 4.9 it worked okay
Edit 2: Ok I started over because I wanted to an OpenRC system so I did 2 kernels again this time 4.9 and 4.10 and I didn’t get the error maybe it’s the 4.11 kernel? I don’t know but I just wnate dto pass that along


#79

That seems like some kind of issue with the mirrors being out of date or something. It happens sometimes with some options. Rare in base installation, common in desktop installation. Using stable branch and most up to date mirrors usually helps.


#80

Well before i started i updated the mirrors on the stable branch but that’s not say one of mirrors might have issues.


#81

Error [255]. I got it too, mainly when:

  1. I try to install mounting existing partition without redefining the HD geometry
  2. It appear independently from the kernel version and number of kernel to install
  3. if you repeat the mount step, the error disappear but nothing is installed
  4. I wasn’t able to replicate the situation, but lsblk, after a [255] error, reported me that both the root and /boot was mounted in /mnt/boot
  5. mirrors are not influent, IMO, I got it also working with the more updated mirror

#82

Ok, big thanks, I mixed this with another bug but this is new and very significant. Thank you especially for the the precise report, it helped me understand the problem better.


#83

Can someone update the iso for manjaro architect?
When launching setup, your first retrieve the new mesa/liglvnd stack because of manjaro-system forced update :slight_smile:
And regeneration of the kernels, may not be needed on the live iso.


#84

Yes, good point! I’ll update them later tonight.


#85

At least the Update works flawlessly there (just tested it too).

@oberon I think I found a bug with the LVM setup.
It was not possible for me to create a volume group and 2 logical volumes in it. It always says “0 MB available space”. I tested it inside a VirtualBox VM with UEFI enabled.
I can post screenshots if you like.


#86

Hm. I’m sure I already did exactly that successfully. Will try again later. What was the state of your drive(s) from where you started off?


Dell Inspiron 15 7567 4K
#87

@oberon

Two times I created a whole new VM (with new, empty disks).
I partitioned the disk sda with the cgdisk option like this:

  • sda1 512M (/boot/efi, Type EF00)
  • sda2 512M (/boot, Type 8300, ext4)
  • sda3 “rest” (/, Type 8e00, LVM)

Create a VG with name “manjaro”:

Select sda3 as physical volume for the VG “manjaro”:


I like to create 2 logical volumes inside the VG:

I like to name it “root”:

But it does not like the name “root” (there is also a typo “beginenn” should be “beginnen”):

I decide to use the default name “lvol”:

I would like to create a 8G LV (but it already shows 0MB remaining “0MB verbleibend”):

And this is the error that is shown if it try to set that size:

I hope these screenshots are helpful to you.

Bernhard


#88

Thanks a lot! I will try to find out what’s going on there… and fix the typos also :wink:

auch Bernhard :laughing:


#89

Hm. I don’t know why, but for me it works as it should:

btw, why do you have a /boot and a /boot/efi partition? Also boot should be vfat, not ext4…


#90

Ok, I will retest it again.
I don’t know where I did a fault unfortunately.


#91

Back again. :slight_smile:

I retested it a few times now. And it never works if I create 3 partitions (like shown in my first post)

And it works if I use two partitions (as in your example).
But I don’t know yet why it does not work with 3 partitions. I think I will play a bit with it.

Bernhard


#92

Apart from that it is strange that it doesn’t seem to work with three partitions, I would like to ask again about your setup:
Why a /boot partition and a /boot/efi partition?


#93

IMHO/boot/efi is for EFI only. And separate /boot for kernel and initrd. It helps if root has a filesystem not supported by bootloader