Installation with Manjaro-Architect ISO



Oh. I didn’t expect it would downgrade, sorry. In that case you can just launch the installer instead of the launcher with manjaro-architect


I have fixed the pacman-mirrors issue.

Maybe you can upload a replacement package - others don’t face the issue?


I am ever so grateful to you and Chrysostomus for giving us this powerful cli installer.

Everthing is now working fine and my wife (who agreed after a year of my nagging that I may install Linux on her desktop) can now also be an Enlightened Manjarian.


Awesome! :smile:


I commend you for increasing the number of people running Linux :slight_smile:


I tried installing a couple of DEs in VM with 0.8.5, nothing fancy, unencrypted ext4, but several times I ran into the following, vague error:

ERROR [install desktop-pkgs][255] ==> Creating install root at /mnt

Unfortunately the logfile doesn’t say more, either.
It happens at installing the desktop environment. Sometimes it happens right away after selecting full/minimal, sometimes after dowloading the packages, and sometimes it only says “Installation Failed”, and the above error message is only in the logfile. And then sometimes with all the same settings the installation is succesful (for example I managed to install Xfce minimal at the second try, Gnome minimal at the first try, but then when trying to reinstall it, I get this error again).


I don’t have any other ideas than either download timeouts or package conflicts because of other packages already installed. More likely the first …


Just release v0.8.6

  • use instead of ping for connectivity check
  • fix duplicate driver listing
  • fix console timeout blackscreen
  • rework luks and lvm menus

@john-soda hooks, crypttab/fstab handling still needs to be addressed, but at least luks and lvm menus should now work properly
@sueridgepipe it would be great if you could check if the duplicate driver listing is actually fixed for you in 0.8.6

Problems with LUKS+LVM installation with manjaro-architect


I’m trying this installation in virtualbox for testing purpose with lvm. I selected French langage but in virtual console menu there is no fr_CA keyboard selection option.

Nevermind… it’s “cf”. Would be better with standard typo fr_CA.


We are in fact not interfering with labelling keymaps. M-A simply creates the list from what is present in /usr/share/kbd/keymaps
"cf" seems weird, yes, although I don’t really know because I was of course never looking for a fr_CA keyboard layout :wink: I’m impressed that it would be different from a French French keyboard!


The big difference is that fr_FR (FR for France) is azerty layout and fr_CA (CA for Canada) is querty.


Ah of course! That makes sense …


choose Mate desk not work


I wonder why every language has their own layout. It makes sense with кириллица, but why do german, french and english need separate layouts?

Russian keyboards includes Latin alphabet, so if we would tweak it to include å, ä, ö and ü (possibly something else also), while still keeping it qwerty, we could have a keyboard that would be usable for greater number of people.

Of course, it would be even handier if we could all just speak one language… From efficiency point of view finnish or german might be best, but they have too few speakers to begin with. Mandarin chinese would be best for having biggest base, but it has a bit too many characters for keyboard, so maybe english, spanish or portugese would be a good compromise…


mecanic typewriters :frowning: :older_man:
The keys corresponding to the pairs of letters most used in the language are distributed so as to keep as far as possible the hammers which correspond to them, which limits the risks of blocking the rods.

Our Canadian friends are smarter than us (fr), they have abandoned azerty

Its possible to chose querty pour un québécois


Thanks, that makes sense. So it comes from similar reasons from where most of the terminal weirdness comes from (emulating outdated technology).


What exactly happens there for you? The unconfigured or Manjaro-desktop?


as this video ? (systemd stable in WM)

[desktop-pkgs][255] ==> creating install root at /mnt

but ok for xfce


Using more up to date mirror sometimes helps. Mate transitioned to different package names, so it may fail with specific mirrors that have new enough mate profile package, but old names for mate packages.


You’re right, it’s possible that the Mate profile currently on stable branch is not working. Should be ok with next stable update. Or you might want tho switch to testing branch.