Installation went OK but no boot option for Manjaro

Well, recently I've gone mad with Manjaro, installing it on every machine i can get my hands on.
HP 360 laptop now runs great as is Intel NUC.
So, I grabbed the aging Asus N53S laptop and attempted to install Manjaro.
It has just one SSD 500 Gb and partitions looks like this:

/sda1 29Gb w7/NTFS <---- i guess this is the old Windows partition
/sda3 34Gb FAT32 <---- this i created during Manjaro install when it warned me about creating an efi partition mounted at /boot/efi
/sda5 164Gb EXT4 <----- Manjaro
/sda6 274Gb EXT4 <----- Linux Mint

when i boot, i was expecting see that wonderful large-font Manjaro boot screen, but
instead i'm seeing the same old Mint option.
so the question is how do i get Manjaro to show in the boot option?

thank you for any help....

update:

from Mint, i did update-grub and it added Manjaro.
so now i see it as a boot option but when i select it, it immediately dumps a kernel panic!
something about failing to load root fs....
i will try another install.

There are several ways you can boot into manjaro from Linux Mint grub

One way, at manjaro entry of LM grub, manually change last initrd line from
(use the same kernel as in the linux line - shown as example here)

linux /boot/vmlinuz-5.3-x86_64 root=UUID=
initrd /boot/intel-ucode.img

to

linux /boot/vmlinuz-5.3-x86_64 root=UUID=
initrd /boot/initramfs-5.3-x86_64.img

Boot up to manjaro. At terminal,

sudo grub-install /dev/sda
sudo update-grub

But I think it best you provide to us

sudo blkid
sudo parted -l
cat /etc/fstab
efibootmgr -v

I think you have installed some OS's in uefi and some in bios-legacy.
That shouldn't be done. You'll need to fix it if so.

Yes, I fear you are correct here since this is an old Windows laptop.
And I am rather confused with EFI partition which the Manjaro install warns me about.
So, that is /sda3 which i created and mounted on /boot/efi.

In any case, I did the commands you specified on Mint and shown below.
Per you comment about mixed uefi/bios installs,
how can i tell if existing Mint is uefi?
'cause I am willing to erase all vestiges of Windows and convert to uefi.

=============================================================
~$ sudo blkid
/dev/sda1: LABEL="w7" UUID="01D0328C6A1A40A0" TYPE="ntfs" PARTUUID="d9af6897-01"
/dev/sda3: UUID="C312-B922" TYPE="vfat" PARTUUID="d9af6897-03"
/dev/sda5: UUID="7a4c2d6b-dc72-413e-88d2-b81a15354fad" TYPE="ext4" PARTUUID="d9af6897-05"
/dev/sda6: UUID="f989bbd4-faf1-489f-b736-79a2d9eb47e1" TYPE="ext4" PARTUUID="d9af6897-06"

~$ sudo parted -l
Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 28.9GB 28.9GB primary ntfs
3 28.9GB 62.9GB 34.0GB primary fat32 esp
2 62.9GB 500GB 437GB extended lba
5 62.9GB 226GB 164GB logical ext4 boot
6 226GB 500GB 274GB logical ext4

~$ cat /etc/fstab
UUID=f989bbd4-faf1-489f-b736-79a2d9eb47e1 / ext4 errors=remount-ro 0 1
/swapfile none swap sw 0 0
192.168.1.150:/mnt/music /mnt/NUCi nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0

~$ efibootmgr -v
EFI variables are not supported on this system.

Please, use the </> button above the post entry box when pasting terminal output so it's formatted properly.
You can edit your post (pencil button)


or
Important knowledge

Please select the text in the terminal
Paste the text into the post
Select the newly pasted text in the post
Click the </>icon in the post toolbar

This creates nicely formatted text.

(Text was copied from @ linux-aarhus)


Have you done this?

Then reboot and see if you can boot up Manjaro normally. Tell us.
Is LM in the grub menu?
Does that boot from Manjaro's grub?
You still have Windows? Does that boot up from Manjaro's grub?

1 Like

Actually, my situation is reverse of what you are saying.
By update-grub in LM, I am able to select Manjaro now.
Problem is that it immediately kernel panics with:
VFS: Unable to mount root fs in unknown-block

So, at this point, both LM and Manjaro are in grub menu.
LM boots fine as before.
Manjaro panics immediately.
Windows looks to be in the MBR partition, /sda1

First, I was able to boot Manjaro by selecting the "fallback initramfs" in Advanced options.
Then, I did your suggestion:

Now, Manjaro boots beautifully.
Thank you for help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by