Installation of USB Wifi adapter / Realtek RTL8811FY / Network Manager


I’ve running manjaro latest version on my physical hardware for coding and development purposes with the following specifications:

Desktop : Gnome
Wifi Adapter : Realtek 8188FTV
CPU : Intel Core 2 Duo
USB : 2.0
Linux Kernel: 5.18

I tried to install the proprietary driver for this wifi adapter by following this link:

I cloned this repository and followed appropriate commands for arch linux instead of Ubuntu. It appears that dkms package has been already added and/or probably installed. But, I could not use this USB wifi adaptor.
To make things worse, now I couldn’t even connect to USB Ethernet as the Network Manager isn’t running anymore. Now, I am totally out of connection and I even tried to run NetworkManager with systemctl command, but it is still not running.

I would be highly thankful if someone help me in getting out of this situation. Please let me know if I need to share any additional information.

Thank you.

Welcome to the forum! :wave:

Please post your system info as outlined here:

Are you from the future? :stuck_out_tongue_winking_eye:

The drivers are available in the AUR (Arch User Repository), no need to install them manually. Always use the package manger to install things, never manually.

First uninstall what you installed manually so there are no untracked / conflicting files on the system.

Install the Linux Headers for your kernel; i.e., linux510-headers for 5.10.

Install 8188fu-dkms-git via Add/Remove Software or via terminal:

pamac build 8188fu-dkms-git

Then reboot and see if it worked for you.