Installation of Kernel 5.14 doesn't create a grub menu entry

Same issue with linux515 (Branch = unstable). I tried using the graphical manjaro-settings, mhwd-kernel -i linux515, update-grub and every time, there is no error displayed. pacman -Qs linux[0-9] shows that the kernel is installed. However, the /boot/grub/grub.cfg remains untouched, but a new/modified version of /boot/grub/ is present.
I can live with the current linux514, but there is definitively something wrong with the update mechanism.

edit: manually copying cp /boot/grub/ /boot/grub/grub.cfg makes the newly installed kernel bootable. Last working mhwd-kernel update was ~24th of September…

1 Like

Did you at some point play with grub-customizer?

@omano : If you mean me (samuel): no, never. It’s a completely fresh install (~3 weeks old).

Is it possible, that the new coreutils (8.32 → 9.0) is causing this behaviour? The Arch guys switched to it on September 24th (History for trunk - archlinux/svntogit-packages · GitHub). This is no coincidence (I’m doing -Syuu on a daily basis).

I’m trying a kernel install to see if I can reproduce the issue on my side.

//EDIT: my coreutils is at 8.32-1 on Testing branch (currently I think Stable branch is on par with Unstable branch, Testing branch for sure didn’t receive some updates that Stable seem to have)

//EDIT2: I could install and boot on another kernel installed through Manjaro Settings GUI.

//EDIT3: coreutils seems to be on par with Testing branch on Stable branch, only Unstable and Stable-staging have version 9 apparently Manjaro - Branch Compare so it seems unlikely that it is related to that package, as opening poster claims to be on Stable branch if we trust his profile.

Could you please check your coreutils version?

So I should open a new thread? (I bet a case of beer that in my case coreutils is the root issue :wink: )

I don’t know, I just updated my system (Testing branch caught up to Unstable), I checked, the coreutils package is at version 9 now, after reboot I installed Linux 5.15 and it didn’t create a, and it updated properly the grub.cfg so something else is probably creating your issue.

I want my beers now.


//EDIT: and here you go, I found that by googling

The .new is created whenever you have a typo in any of the grub files used to create grub.cfg. I once forgot a closing } in 40_custom. It then showed error as last line which did not help much, but it may show error line. Also could be in /etc/default/grub, if line not correct.

oldfred - Nov 30 '19 at 17:34

Sorry for the late reply, answering several questions:
Yes, I rebooted, no kernel 5.14 in the grub menu
I’ve installed the kernel with paru, with pamac and also with the manjaro gui (same result for all)

My profile is misleading (it describes my desktop)
This issue concerns my laptop: a fresh install of manjaro gnome with btrfs and I switched to unstable branch

I did not play with grub-customizer (never had it installed)

➜  ~ paru -Qi coreutils                                                                                                                                                                                                                                                             
Name            : coreutils
Version         : 9.0-2

Just tried the copying, now it works

Did you read my previous post? If you talk about ‘the copying’, that means you have a file, is that it?

Now I have :sweat_smile:
I’m not sure where the error in my grub file is but I will look again
Do you know if there is a tool that can check my file for correctness? (with useful error messages)

I don’t really know. But that seems to point to an issue somewhere in the various config files. It may be your fault, or maybe a package you installed, or is installed by default has an issue. On my side I have no issue, but I don’t have a default installation.

Maybe it is possible to try a grub update command, with more output to spot possible errors. I will try to check.

//EDIT: didn’t find a way to have more output from update-grub, but we can actually see the error in the output you already posted (when installing kernel it then generate the images, and then it updates GRUB try it sudo update-grub:

error: command failed to execute correctly

So there is an error somewhere in the configs/scripts used to generate the grub config.

Maybe in /etc/default/grub or /etc/grub.d/ or /boot/grub/custom.cfg (not sure about that one, it may be loaded on the fly instead of being used to generate the GRUB config) or somewhere else, hard to say.

I found my issue:
I had a faulty/unnecessary 41_snapshots-btrfs in my /etc/grub.d. Just deleted it (I’m using ext4). Googling the .new really helped :wink:
Thanks for the hints!
And here is the beer:
:beer: :beer: :beer:
:beer: :beer: :beer:

If you didn’t make it yourself, maybe you installed a package that created it, so the real fix is to find the package and remove it.

[omano@omano-nvme ~]$ pacman -F 41_snapshots-btrfs
community/grub-btrfs 4.9-1

Did you install this package?

I also have a /etc/grub.d/41_snapshots-btrfs but I guess it is useful for my system?

I have grub-btrfs installed but I’m also using btrfs, so it makes sense

You need to find what is causing you an error during the update-grub command. What was causing him issues may be different. I told you where to look.

Just installed the new version grub-btrfs-4.10.2-1 and also installed linux5.15 to test.
And it worked, /boot/grub/grub.cfg was updated and I changed nothing on my config.
So I guess the bug was in grub-btrfs and is now fixed

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.