Installation issues with Nvidia 3080

I’m installing Manjaro i3wm version on x86_64 platform. It will ideally be installed on an SSD shared with an Ubuntu installation.

My hardware is in short an intel CPU 12th Gen Intel Core i7-12700K, an Nvidia GPU 3080, and many drives. inxi -v7azy can be found at . I can post output from further system info commands from if needed, I would do so now but to get them into pastebin is tedious for reasons I’ll explain below.

The kernel currently running is 6.1.1-1-MANJARO (linux61) and it appears to be the only one installed in my system.

The output in liveCD of mhwd -li is:

video-linux 2018.05.04 true PCI

The output in liveCD of mhwd -l is:

video-nvidia 2021.11.04
video-nvidia-470xx 2021.11.04
video-linux 2018.05.04
video-modesetting 2020.01.13
video-vesa 2017.03.12

Upon running liveCD, based on advice from here and stackoverflow, I chose the “boot with proprietary drivers” option. However, this caused a A start job is running for livemedia mhwd script (1 min 30s/ nolimit) loop. I let it run for 20 minutes just to be safe. When it failed, I hard rebooted, and tried the “boot with open source drivers” option. This successfully launches the liveCD environment, however, there’s a display bug that makes everything tedious. If I launch the installer, it displays as a pop-out frame that’s transparent in the center. If I move it, it remains transparent. If I resize it, contents display the last frame rendered.

I assumed I could fix this after installing and manually installing nvidia drivers, so, I would select options, resize the panel to see the updated frame, and continue. I split my ubuntu partition to install manjaro i3 and it installed without issue.

I booted into manjaro and the last-rendered-frame-until-resize issue persisted, so, after confirming the free drivers were being used with inxi -G, I installed nonfree drivers with sudo mhwd -a pci nonfree 0300 based on this article: .

I rebooted to test, however, now the system won’t boot at all, displaying [FAILED] Failed to start Load Kernel Modules. when I try to launch from Grub. No other error messages display, and after this step it launches into a turqois screen with a cursor that sometimes displays in the top left, with no input possible (or maybe there is, but I can’t tell without being able to resize the terminal to check?). I also can’t launch into advanced options or anything along those lines.

I’m at the step where I’ll start trying to chroot and try different kernel versions, however, the liveCD still has the issue with frames not refreshing, so in order to see output in my terminal i need to open/close a new terminal to force a refresh. Very tedious, so instead I thought I would pause for a moment and see if anybody had any advice before I move forward.

I’ve gone through the as well to ensure there’s nothing funky about my bios / firmware.

I love manjaro on my laptop so I would really enjoy having it on my desktop PC as well, any advice is greatly appreciated.

the inxi output from pastebin is incomplete, it is cut out in the graphics section… if you can, post the output here…
also you are using RAID… try switching to AHCI in bios/uefi… and also check if secure boot is disabled, since you are dual booting with ubuntu, which doesnt require secure boot to be disabled…
and how is the nvidia connected? via cable or directly plugged in?
and since you managed to install it with free drivers, and you are getting this:

probably failed to load the nvidia modules, you can enable early loading; you can do it also from TTY - in the stuck screen press ctrl+alt+f2 or f1-f6, enter your username and password; and then:
sudo nano /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it with ctrl+x, press ‘y’, then enter, and update it:
sudo mkinitcpio -P
install again the nvidia drivers, if they were previously removed:
sudo mhwd -a pci nonfree 0300
reboot and test

Thanks for the help.

When doing mkinitcpio -P I got some warnings just a fyi

possibly missing firmware for module: xhci_pci
consolefont: no font found in configuration
Possiblying missing firmware for module: aic94xx
... wd719x
... qla1280
... qed
... qla2xxx
... bfa
... xhci_pci

I ran sudo mhwd -a pci nonfree 0300 and it seems to indicate it’s already installed:

Skipping already installed config 'video-nvidia' for device: 000:01:00.0 (0300:10de:2216) Display controll nVidia corporation

Rebooting now to test and also grab full inxi. In the meantime, I double checked that secureboot is indeed disabled, and also dived ore into RAID settings. I think it looks like it’s enabled because… maybe the driver is installed? I could only find indication of that in my BIOS, not that there were any actual RAID devices attached (the bios indicated “no raid devices found.”) I can deep dive more into my BIOS manual later to double check.

Ok, just rebooted, still the same error as prior. Confirmed that the nvidia modules remain added to the MODULES line.

Much time has passed since the above and desperation (can’t find any way to like, CURL stuff to pastebin or something) has led me to type out by hand the following hopefull helpful bits of inxi

Device-1: NVIDIA GA102 [GeForce TX 3080 Lite Hash Rate] driver: N/A
alternative: nouveau, nvidia_drm, nvidia non-free: 525.xx+
status: current (as of 2022-12) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: :01:00.0 chip-ID: 10de:2206 class-ID: 0300
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Kernel: 6.1.1-1MANJARO arch: x86_64 bits: 64 compiler: gcc v:12.2.0 parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64 root=UUID=834509a6... rw quiet apparmor=1 security=apparmor udev.log_priority=3
  Console: tty 2 DM: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/a serial: <superuser>  
  Mobo: ASUSTeK model: ROG STRIX B660-G GAMING WIFI v: Rev 1.xx serial: <superuser> UEFI: AMerican Megatrends v: 0406 date: 10/29/2021
  RAM: tota: 31.09 GiB used: 895.6 MiB (2.8%)
  Info: modeL: 12th Gen Intel Core i7-12700K bits: 64 type MST AMCP arch: Alder Lake gen: core 12 level: v3 note: check built: 2021_ process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) setpping: 2 microcode: 0x26

EDIT: Oh and the graphics card is connected directly to the motherboard via PCIE (I believe in terms of terminology: it’s definitely stuck directly into the board). The monitor is driven via displayport cable plugged into the card, and, the card and monitor both function fine in ubuntu and windows. Ubuntu uses either gnome + wayland or i3 + x11 depending on my mood, both work ok (well, wayland is buggier, but the proprietary driver at least works most of the time)

Those mkintcpio warnings are normal… The drivers are not being loaded, they are N/A in the inxi output…
You didnt mentioned that you are using windows too… so check if fast startup is disabled in windows, if not disable it; also check if fast boot is disabled in bios - you may not have this option… And dont switch from raid to ahci, since you are using windows, otherwise you will not be able to boot into it…

Double checked and confirmed Fast Boot in BIOS has been disabled during this time, as well as Fast Startup disabled in windows.

if you can, provide logs from the failed boot:
journalctl -b-1 -p4 --no-pager
and also, install a newer kernel from tty:
sudo mhwd-kernel -i linux64
reboot and test with it (it should automatically boot with it)…
also you have an intel gpu, which is probably disabled in bios, so you could test by switching to it; but make sure you have installed video-linux, check with mhwd -li

Doesnt matter. We may be interested in mhwd -l -li from the installed system though.

This seems to indicate you are out of date. (current video-nvidia is 535)

sudo pacman -Syu

TLDR appears solved

@cscs thanks for the note about the paste services, I missed that link in the HowTo.

journalctl -b-1 -p4 --no-pager output. Note that current system time is Aug 9 7:32 so I guess this is from yesterday? I just booted now again to run.

mhwd -li of installed system from tty

mhwd-l of installed system:

inxi -v7azy on installed system:

Previous to the next commands. Will get updated info after.

Installing new kernel first with sudo mhwd-kernel -i linux64… it gave warning about packages being out of date and that I should update my system first, so I cancelled and did sudo pacman -Syu. Then proceeded with new kernel installation.

Now, I can get to login screen after boot. Logged in… successfully! Also, the refreshing pane issue seems to be gone. Nice! Thanks for the help. Just for the record, I’ll post the updated info anyway:

Updated info:

mhwd -li :

Nice, looks like it’s correctly using the nonfree driver.

mhwd -l :

inxi -v7azy:

So am I correct in understanding that the issue was some combination of:

  1. Out of date kernel
  2. Out of date non-free graphics driver
  3. Perhaps out of date packages


Really appreciate the help!

EDIT: I can’t mark both people’s answer as solved but I think both are why I’m working now, sorry, dunno what to do lol

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.