Installation issues on Macbook Air 7,1

Hello there,

As the title suggests I have a Macbook Air 7,1. When it was first released it was almost impossible to install linux on as it had an NVMe drive that was not reporting itself properly iirc. But, on to the issue

So, I have tried a number of different ways of installing the Manjaro Gnome edition that I use on my desktop & at work but have yet to be successful. The graphical installer always errors out at about 90% of the way through the installation with the grub installation throwing an error.

Things I have tried:

  • Disable Secure boot
  • Chroot in and fix grub (seen in thread about a macbook pro)
  • Manually partition before installation
  • New iso

I have also googled around a bunch and tried some of the stuff in the arch wiki page for mac installation but have yet to find a solution. The result always remains the same: no operation operating system detected.

I don’t want to dual boot, just want a Manjaro install

Any help appreciated,

Thanks

Update - The Error

When you create the partitions, you must create a new partition table as GPT. The first partition must be fat32 > 300MB (200MB will sufice too) /boot/efi as mount point, and marked as esp boot flag. From there the other partitions can be as you want them (i suggest to go with ext4 and only one partition for root and be sure you select: >> / << for mount point. The installation should work fine.

I think I had all of that. Well, with the exception of esp flag rather than asp which I assume you meant and I had a swap. I followed the Manjaro user guide for Manual installation on a UEFI system

No, is esp all the way. Had a typo there …

‘esp’
(MS-DOS, GPT) - this flag identifies a UEFI System Partition. On GPT it is an alias for boot.

Yeah, I used esp. Was trying to say I used it in place of asp, sorry if that wasn’t clear

No worries. Can you screencapture the error is taking place and share it here? Or post the output error in text format …

It is essentially the same error as can be seen here. However I tried the resolutions in the comments and couldn’t get it to work. I’ll mess with architect tomorrow though didn’t see that last time. thread

So, your boot partition looks like this, and is 300MB or 200MB ?
image

Also, have you considered to use rEFIND boot loader ?

Keep in mind a “boot” partition is different to an “EFI” partition.

You can have separate partitions which mount at /boot and /boot/efi, and if you say you “created a boot partition” most will interpret that as /boot not /boot/efi.


If Calamares isn’t checking /boot/efi filesystem type that should be flagged as an issue: https://github.com/calamares/calamares/issues

1 Like

Had The same kind of “misnomer” in this post, but i can’t avoid it … You will see why :slight_smile:

1 Like

So… This is not to say that Manjaro installer hasn’t still a bug and shouldn’t be fixed

But could you try to check if systemd-boot works and all?
It helped quite a lot here

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by