Installation Failed: rsync failed with error code 11

Last thread I was told that I had 2 EFI partitions, a windows in nvme0n1p2 and manjaro in nvme0n1p5. I was told to backup the manjaro disk image and reinstall fresh. I thought it was weird to backup the full nonfunctional disk so I used clonezilla part to image to backup “/” and “/home” to an external hard drive – was this correct or should I have done disk to image?

After that I decided to clean the Windows by using the beginning of the dual boot Windows 10 and Manjaro guide by linux-aarhaus. I did the chkdsk c: /F, etc. Then I booted into live media and ran calamares, went into manual partitoning and started to edit flags. I changed the flag for nvme0n1p2 to no longer be boot, flagged nvme0n1p5 as /boot/efi, and then nvme0n1p7 “/” and nvme0n1p8 “/home” respectively. but it failed with the rsync error code 11 from the title.

I DDGd around and found an old thread here about switching SATA configuration to AHCI in the bios/EFI menu. I double checked and mine was already set to that so that can’t be the solution.

Should I just save the files I need from windows and complete wipe my system? Should I disk image with clonezilla to the EHD first?

i don’t understand why you have changed flag on nvme0n1p2 :
this is windows efi boot , you need theses flags for windows.

do not change under calamares theses options with Gparted in same time

why do you want create another UEFI partition ?
this is the best way to loose all boot on your disk !

so you restore theses options flag on this nvme0n1p2 and you try to boot to windows first

then you launch USB live manjaro , open a terminal and a browser on this topic
an return

sudo parted -l 

I changed it because I thought having 2 boot partitions was bad according to what you said in the last thread, now I’m confused.

I followed the dual boot setup from linux-aarhaus, and I followed the multiple partitions for manjaro so I have root (nvme0n1p7), swap (nvme0n1p6), home (nvme0n1p8) and then a boot for manjaro (nvme0n1p5) as per the guide, no?

The Windows boot is nvme0n1p2 but wouldn’t any dual boot system have two boot partitions then? Regardless, the installation failed and the windows boot on nvme0n1p2 still has its boot flag.

I notice on Windows nvme0n1p3 does not display when the disk management gui is up and in Calamares nvme0n1p3 registers as “unknown”; I’m not sure what this partition is

I will post the sudo parted -l after breakfast

you refers to this topic

the older one is
and there is more return about this point

since January / February 2021 , there is big update in Grub ( concerning boot & efi ) and os-prober ,
after review security , 117 ( + a few ) patches has been done on Grub ( version is 2.06 and more ) ,
BY DEFAULT os-prober WILL NOT add entry boot windows , you will have to change these option

, also calamares has changed to install to /boot

just for understanding about theses 2 flags boot & ESP

  1. boot concerns only one partition
  2. you can have 2 ESP and in order to boot by default only one of 2 ESP will be flagged
  3. if possible do create before on your UEFI motherboard 2 profiles , one for linux , other for windows

if you create another /boot/efi , it will required boot&esp activated , older one will only keep esp ( windows)
flag boot is required , as flag ESP for any partition vfat for EFI

better is to install on second disk.

i think that windows will change to add boot flag on windows esp partition ( nvme0n1p2 ) , and required after to change profile for boot on linux because from all options SecureBoot & cie.

for the code error 11 , if you try again
can you confirm this point before

a) all options ( secure boot off , CSM off , olny UEFi and disks in AHCI on ) are applied

b) boot on USB live manjaro with < UEFI : vendor name USB > < partition 1 or 2 > for install in UEFI

c) before install open a terminal and recheck

inxi  -Mxza
test -d /sys/firmware/efi && echo efi || echo bios

then use this command for debug

sudo calamares -d

@linux-aarhus or @philm , it this always possible to have dual boot windows & linux ,
by using 2 ESP partitions with all theses changes since march 2021 ( Grub , os-prober , calamares with /boot )?

1 Like

The reason I put in the part with a second efi partition is primarily due to an assumption that Windoww wouldn’t mess with it.

The efi partition cannot be encrypted nor controlled in any way (FAT32) which is why the TPM and Secure boot exist.

The efi specification does not limit how many EFI partition you can create - but only one can be active at a time which is what the efibootmgr manages or inside the firmware when you decide which loader comes first.

1 Like

I double checked and I’m embarrassed to say that CSM was on, but is now off.

[manjaro@manjaro Desktop]$ inxi -Mxza
Machine:   Type: Desktop Mobo: Micro-Star model: B450 GAMING PRO CARBON AC (MS-7B85) v: 1.0 serial: <filter> 
           UEFI: American Megatrends LLC. v: 1.F4 date: 04/22/2021 
[manjaro@manjaro Desktop]$ test -d /sys/firmware/efi && echo efi || echo bios

i think code 11 come from CSM active
you can forward for install

I tried to install again and got the code 11 error once more (CSM is disabled).

08:17:49 [1]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    ERROR: Installation failed: "Failed to unpack image \"/run/miso/bootmnt/manjaro/x86_64/desktopfs.sfs\"" 
    ..  - message: "Failed to unpack image \"/run/miso/bootmnt/manjaro/x86_64/desktopfs.sfs\"" 
    ..  - details: rsync failed with error code 11.
08:17:49 [6]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    Calamares will quit when the dialog closes. 
08:17:49 [6]: void Config::doNotify(bool, bool)
    Notification not sent; completion: failed 

how have you created this USB live manjaro ?

I downloaded the most recent stable xfce image from and used rufus to make a live USB with the ISO I downloaded

you can see with ventoy under windows

I’m not sure I understand your last message.

Is making it with the ISO and rufus incorrect? I’ve used it successfully several times before

I’m at a loss for how I borked this so badly (originally I just updated my motherboard drivers on Windows hoping it’d fix some inconsistent pulseaudio behavior I was experiencing).

I have my “/” and “/home” backed up to an external hard drive. I have the few files from my Windows OS that I want to save also on the external hard drive. At this point, should I just make a bootable Windows 10 media and start the dual boot installation completely fresh (i.e. fresh install Windows 10, then install manjaro dual boot, then copy my root and home from the external hard drive)?

for better understanding about ventoy

you can drag& drop iso under windows to USB

if you have all windows ok on nvme , you can still boot , partitions for linux is only from
nvme0n1p5 and more and do not concerns windows

so can you confirm status

  • windows boot is ok on nvme
  • you need another USB stick if necessary for ventoy if you want keep rufus for others iso
  • you can use ventoy under windows to copy iso on USB sticks
1 Like

I’ll try when I get home but I don’t understand why. Are you suggesting Rufus is not appropriate for making live ISO media I’ve used Rufus probably half a dozen times for this and it’s worked every times but now. I feel that this is likely not a problem with the ISO on the USB

Same error persists with the Ventoy live media as with the Rufus. When I go through the manual partition, none of my linux partitions have flags on them so I am adding the root flag to nvme0n1p7 (my system “/” partition), the /home flag to nvme0n1p8, and /boot/efi to the nvme0n1p5 partition – should I not be doing this and just run the manual partition install option without modifying anything?

Correct me if I’m wrong but it seems I’ve reached the point where no one understands why it’s not working, and it doesn’t seem to be possible to troubleshoot it, so a complete system wipe might be the best move?

I like to learn as I go and understand what the issue is, but unless I’m understanding it wrong we have no clue what the issue is, or how I got the system to this state. Having two boot partitions is normal since I followed the dual boot guide and the would end with a GRUB and Windows partition (as my system has). Repairing the grub didn’t work which involved booting to live media and following the chroot grub repair guide from the arch wiki. Running the install with a freshly made live media didn’t work, and consistently threw the rsync error 11. Normally that means check CSM and all the Windows settings are disabled (fast boot, hibernate, etc.) which I’ve done several times and yet the same error persists.

Is anything in my summary incorrect?

If nuking is the best, I’m about to try and get a second SSD for my system, and the goal is to have one SSD be my manjaro OS and the other be my Windows OS. I would like to have it setup so that GRUB is the master bootloader and I am able to select which OS to boot into upon restart (the same functionality I had with my current setup before it all went to hell) – is this difficult to setup, or is there a guide for doing so?

What is your partition / block-device layout?

Can you post, from a live USB session,

lsblk -o name,fstype,parttype

[manjaro@manjaro Desktop]$ lsblk -o name,fstype,parttype
loop0       squashfs 
loop1       squashfs 
loop2       squashfs 
loop3       squashfs 
└─sda1      exfat    0x7
sdb         iso9660  
├─sdb1      iso9660  0x0
└─sdb2      vfat     0xef
├─nvme0n1p1 ntfs     de94bba4-06d1-4d40-a16a-bfd50179d6ac
├─nvme0n1p2 vfat     c12a7328-f81f-11d2-ba4b-00a0c93ec93b
├─nvme0n1p3          e3c9e316-0b5c-4db8-817d-f92df00215ae
├─nvme0n1p4 ntfs     ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
├─nvme0n1p5 vfat     21686148-6449-6e6f-744e-656564454649
├─nvme0n1p6 swap     0657fd6d-a4ab-43c4-84e5-0933c84b4f4f
├─nvme0n1p7 ext4     0fc63daf-8483-4772-8e79-3d69d8477de4
└─nvme0n1p8 ext4     0fc63daf-8483-4772-8e79-3d69d8477de4

p1 is Windows recovery, p2 is windows boot, p3 is a mystery as it comes up “unknown” when going through Calamares, and doesn’t register in Windows when looking at Disk management, p4 is the main Windows OS, p5 is manjaro boot, p6 is swap, p7 is manjaro root, and p8 is manjaro home

It’s marked as your “esp”. My guess is only your Windows EFI boot files are within.

That’s Microsoft’s “reserved” partition. Leave it as is and don’t try to edit or resize it.

You mean the EFI partition (esp) configured for Manjaro to use? You have two choices: use a single esp for both Windows and Manjaro (p2), or define separate ones, such as p2 for Windows, p5 for Manjaro.

You need to mark p5 with the “esp” flag. You can do this in parted quite easily.

sudo parted /dev/nvme0n1

Then inside the parted terminal, set the “esp” flag to “on” for partition number “5”.

set 5 esp on

You can review this change,


You can type “quit” to safely exit out of parted.


Double-check now with,

lsblk -o name,fstype,parttype

Depending on your motherboard, you might need to choose a different default boot entry, which will likely show as “manjaro” or “MANJARO” in your BIOS setup screen.

UPDATE: You can also use efibootmgr to view and change the defaults.

UPDATE 2: Honestly, the above is for your own reference, but a fresh installation is the cleanest method, with CSM disabled, and either pointing to p2 for your EFI partition (shared with Windows loader), or creating a new one and using that one for Manjaro to save its loaders.

For the record, the PC I am writing from is dual-booting Windows 10 and Manjaro, and they both are using the same EFI partition. After numerous Windows updates, it still has not interfered with Manjaro’s loaders. :crossed_fingers:

1 Like

So if I were to do the clean fresh installation of both Os-es, should I skip the step in the guide to create a boot partition when making the manjaro partitions?

For your machine, when you boot are you met with GRUB and the option to select which to boot to?