Installation Failed Boost.Python error in job "networkcfg"

I am reinstalling Manjaro on a 2012 MacBook Air 11". I hadn’t used it in some time since the battery was bad, but I’ve just replaced the battery and wanted a fresh start. I’m using the KDE Plasma Manjaro installer downloaded today. After a few failed attempts, I noticed that my hardware clock was quite off, so I reset it with timedatectl set-time and hwclock --systohc, which seem to have fixed the time, although I have also noticed that the time jumps 5 hours (the difference between my time and UTC), sometimes during my install attempts. I’m not sure if this is actually related to my problem (see below), but that was my best guess.

Here’s the error message I get each time. I am grateful for any help!

Installation Failed
Boost.Python error in job "networkcfg".
<class 'NameError'> name 'target_network' is not defined
File "/usr/lib/calamares/modules/networkcfg/", line 126, in run replace_username(target_network, live_user, user)
File "/usr/lib/calamares/modules/networkcfg/", line 76, in replace_username
with open(target_network, "r") as network_conf:

Same error here, was installing KDE Manjaro for the first time on a new SSD on HP ProBook 4540s laptop.

Same error here

here too

and me too

Same here…
I need my system back. And can not install Manjaro. WTF

Not really an expert on calamares, but how about trying to install offline, that means no internet?

I tried to turn off the internet, the error persisted

I thought it might be because of the name of my hotspot called =^.^=

an other shot at it: also try update the live system ? … be sure to terminate hangig calamares processes
before trying again, if not working also worth trying an older live medium

I’m getting the same error on the gnome installer…

at least in the gnome live system I see no way to update it before trying to install

@vilas using the terminal? sudo pacman -Syu

(It seems to be a python error)

“there is nothing to do”

Yeah, my daily driver computer isn’t working now because of this :frowning:

Has anyone tried installing the previous version?

No, not because of this. Just want to clean install

Actually because of this - I already formatted my SSD and now I can’t get it working :smiley:

same thing

There’s an issue with installer itself. I replicated mentioned pull request changes in my local copy at “/usr/lib/calamares/modules/networkcfg/” before running the installer and managed to install it. Now checking if everything works properly.


Good that you know what happens here…thank you for your nice support and useless meassage