Installation error in 21.3.1 (Ruah) -- tried all official editions

Hello, everybody.

I’ve been trying for the past (entire) day to install Manjaro version 21.3.1 and it always fails with the same problem.

The problem is that, just before the ending of the installation process, the installer reports an error related to trying to unmount a device. I ran it with the --debug flag and the results can be seen here.

To summarize, I have one NVMe, one SSD, and one HDD. I’ve manually partitioned them to be used as follows:

  • NVMe: /boot/efi, /
  • SSD: swap, /var, /opt
  • HDD: /home

All the partitions (except for the EFI one) are using btrfs. The error I get complains about trying to unmount /tmp/calamares-root-????/var/log. (The actual message the UI shows can be seen on line 1674 in the file I linked).

I find this odd, because I only ask for /var to use a custom partition, and maybe this is related to the problem.

I wish to install with UEFI enabled and Secure Boot disabled, but I actually tried every combination and they don’t affect the outcome.

Also, I want to install the Gnome edition, but I actually tried all the editions (in the case of Gnome I tried both minimal and full versions) and I get the same problem in the end.

I suspect all of this trial-and-error was in vain because the problem is with calamares and all of the editions use the exact(?) same script…

Would anyone be kind to try and help me sort this out? I’ve already lost an entire day on this and I’m currently trapped with an ancient laptop with a flickering screen and a bad keyboard until I can use my PC again…

Thank you.

1 Like

Hey. I’d just like to commend you for nicely formatted first post, with included logs and other relevant info. Many first time posters could learn something from you.

I’m sorry I can’t help you with the actual problem at this moment (don’t have time).

2 Likes

I suspect this is related to btrfs and your combination of hardware.

Unless you have a knack for btrfs -

My recommandation

  1. using ext4
  2. Don’t forget swap
  3. Don’t use hibernation

I tested all full ISOs on my end and had no issue. You may want to try with the older Ruah ISO which ships Calamares 3.2.59: https://download.manjaro.org/gnome/21.3.0/manjaro-gnome-21.3.0-220617-linux515.iso. If you still have the issue you can simply disable the umount module in /etc/calamares/settings.conf, as it is not really needed. Also even if it fails at that stage the installation is still a success. Did you try to reboot into your installation?

1 Like

On second taught it might be something with BTRFS and your partitoning layout:

Filed issue upstream. You may want to comment on that one @araruna

You need a non BTRFS partition for /boot.
And: when you use a background image for grub menu, then /usr/share/grub/themes/manjaro/theme.txtmust be on a non BTRFS partition or you must comment this out in /etc/default/grub.

Yes, I tried rebooting and I got no output (no video, not even text) everytime…

I’ll try your suggestions next. Thank you.

Thank you for that.

I don’t know what to add to the discussion there right now, but I’ll be following the issue to see if I can clarify anything.

This may be the reason why I can’t boot the installation. I’ll try to address that. Thank you for this information.

I simultaneously tried changing the configs from the info provided by @philm and @Keruskerfuerst and I was finally able to use the system.

The only problem I had was that the GPU’s free driver was not working, so I had to boot into single mode and install the nonfree version.

Thank you guys.

I think boot partition must always be vfat /FAT32

The /boot/efi partition must be FAT32.
Not the boot partition.

Sorry I stand corrected - boot/efi partition

Based on the issue posted upstream, the BTRFS subvolume layout as you created it @araruna is not yet supported. You might get some ideas why it fails by reading on the bugtracker …

Olá passei pelo mesmo problema e fiz todos os teste possiveis que vi na internet e não deu certo.
Consegui resolver apenas EXCLUINDO as PARTIÇÕES do SSD antes de prosseguir a instalação.

Exclui e não criei novamente, deixei o sistema criar sozinho, aí deu tudo certo.

PS: fiz a instação no disco inteiro, não sei vai se aplicar no seu caso.

Google-Translator
Hello, I have the same problem and I did all the possible tests that I saw on the internet and it didn’t work.
I was able to resolve it by just DELETING the SSD PARTITIONS before proceeding with the installation.

I deleted it and didn’t create it again, I let the system create it by itself, then everything worked out.

PS: I installed the entire disk, I don’t know if it will apply in your case.

The most recent version of Manjaro is 21.3.7.

Can you post the partitioning ?