Installation - EFI unknown filesystem

I want to install manjaro with existing /home on sda2, I have tried several installations w/ and w/o EFI from USB stick and DVD, also reinstalled grub on sda right after installation, after a reboot it shows:
error: unknown filesystem
it’s a lenovo mini PC security options & uefi disabled, it seems it can not boot with fat32 EFI …
is there’s a way to just install grub to sda1 - oldschool without fat32 crap?
there is no other OS installed or dualboot needed

Please check this topic

1 Like

I have set boot order to EFI, but always the same result: error: unknown filesystem
I have double checked the EFI installation incl. recheck-grub
no errors reported, but the system can not boot

First, be aware that it is recommended to either

a) Boot in BIOS (legacy) mode and use a msdos parted disk (with MBR).
b) Boot in UEFI mode and use a gpt parted disk.

In your post you talk about EFI (which is only required for b)), you said you re-installed grub on sda (which is only OK for a)), then you said you disabled uefi, which would be OK for a) and you mentioned booting with fat32 EFI, which would be OK for b).

1 Like

now I have installed an old v18.x KDE from DVD and it worked without complaints about EFI or unknown filesystem …

This error is from the grub bootstrap and means that it can’t read one or more of the partitions, commonly the one with the kernel. It depends on when the error is reported. Does it appear before the grub menu or after selecting a grub menu option? The former is more likely to occur when trying to boot a liveUSB. It can mean that grub is not using the correct device. The installed grub.cfg should be using UUID’s and not using hd0 or /dev/sda type partition specifiers. How the partitions are formatted matters and grub may need some extra file system modules for specialized file systems. That should be handled by the installer, but…

it appears before the grub menu and the partitions are formatted during installation setup …

The bootstrap is defective. The bootstrap is the .efi file in /boot/efi/EFI/manjaro/ The link in post 2 covers a number of things to try to fix it. Another idea would be to try grub-vanilla to replace grub.

Since Manjaro-18 installed without problems, it is probably safe to assume that there are no hardware issues or erroneous BIOS security settings. Maybe some default settings changed in Manjaro-20.

Calamares does not always default to the right ESP partition when there is more than one storage device in the system. Calamares tends to use sda even when other options are wanted, especially when trying to install to an external device (slightly off-topic.)

Grub is in the top 5 installation issues along with graphics, wifi, bluetooth and audio (touchpad honorable mention.) Unless the devs can reproduce what you are seeing, it is difficult to guess what has gone wrong.

1 Like

there is no such file or folder, I have started w/ manjaro when 18x was released and also the same w/ 3 of my other manjaro systems …

When I’ve had that problem, it was because my boot partition wasn’t updated after an update. I use systemd-boot and there is a simple install hook that I deployed, ‘why isn’t this automatic?’, that resolves the issue. Basically, when my boot partition is out of synch with installed kernel, I’d get the error "unknown file system and get kicked to emergency prompt.

I have just tested a default installation (erase disk auto part.) in a vbox with manjaro KDE (latest) … no EFI folder or efi file is created here either … but when using an ssd with mbr partition table & existing /home partition the installer should not request EFI in such a case …
If I see that correctly EFI is only required when windows is installed (dual boot with win) or if the partition table was created by windows or as GPT

default grub package files:

or is there something wrong with it?