Installation: Cannot install to hard drive (only to USB stick)

Hi. I’m moving from Arch to Manjaro and trying to install it on a new laptop. When running the installer, under “partitions”, I don’t have the option to partition and install to the laptop’s hard drive -only to the USB stick.

Laptop is a Dell CPX 9370, which came with Windows 10 pre-installed. I’ve disabled bitlocker and secure boot (couldn’t boot from the usb drive before doing those).

Any help is greatly appreciated.

I think you have to be sure if the Bios is set to UEFI to boot Manjaro installer in UEFI.

Thanks, I’ll check that out. I used Rufus to create the bootable. I can choose between MBR partitioning schem for BIOS or UEFI, or either MBR or GPT for UEFI.
I’ve used the former so far -should I change to one of the latter ones?

i have to ask … was DD mode ?

So you actually go to the install point to partitioning and there you have only the USB displayed not the internal HDD ?

i have to ask … was DD mode ?

I’m sorry but I don’t know what you mean by “was DD mode.”

Correct.

DD is an exact clone of the image onto the USB. Basically, this flat copies the image byte by byte onto the USB.
More on wiki about how to prepare the ISO to USB
and would be something like this

But if you get to the installer/partitioning there should be a submenu to select the HDD

Select Storage Device

1 Like

Ah. No, I made it in ISO image mode.

The submenu is there, but nothing but the USB is on it.

Check what settings you have in BIOS for SATA controller and be sure to be AHCI. If you have Windows installed then there might be a problem, but i can’t be specific about it, or your laptop needs a driver for that SATA controller to work …
maybe you have to add kernel flag acpi_osi=! acpi_osi="Windows 2015" at boot

Thanks, this was indeed the problem. After enabling ahci, the disk appeared fine. I installed Manjaro alongside Win10, but now my laptop just boots into win10 after installing.

Follow this instructions, the part 2 regarding windows

Thanks, problem is, my partitions are not named with the standard names (sda, etc). Mine are called stuff like nvme0n1p1.

Oh then you might want to take a look at this. Read the entire posts there!

1 Like

@ahura, jumping in ahead. If in doubt, try booting up the installed Manjaro OS using this., Then do the commands at step 6 with the [UEFI - additional commands] below that.

If you are still unsure, provide the output when booted up as posted in post #4.

Good luck.

ps: @bogdancovaciu
appreciate it. that helps. going to sleep now. thanks.

2 Likes

I’m really sorry for being a noob here, but it’s not clear to me what to do from this.

check output of
grub> echo $grub_platform
If output is pc, you’ve booted up in bios-legacy.
If output is efi, you’ve booted up in uefi.
If you’re in the wrong mode, reboot livecd in the right mode.

This outputs ‘PC’. I assume this is ‘wrong’ as my BIOS mode under “system information” in Win10 is UEFI. I don’t know what “reboot livecd in the right mode means.” I only have option to boot from the liveUSB from the menu when I press F12 during startup, so no idea how to go about this.

There’s an option to change boot mode in the boot menu (the one that appears when pressing F12 during startup), but the only options are legacy mode WITHOUT secure boot and UEFI mode WITH secure boot.

If this is actually correct, then you are on BIOS mode, even if you think (your system says) otherwise.
For example, if you let it go on and boots to Win, then Win is installed in BIOS/legacy mode.
The point is, whatever boot mode boots to Win, use the same to boot Manjaro LiveISO and install.

I don’t think so. In Rufus when I made the bootable, I could choose either bios or uefi. I found out later it seems uefi only works if I make it in dd mode for some reason, but I could boot from both because I have legacy boot enabled. At any rate, I got it installed now and just need to get the bootloader working - I’ll create another topic for that since this is pretty far from the tile of this thread by now.

But this may have to do with the boot mode you used when installing.
To be clear and AFAIK

  • For Manjaro LiveUSB with Rufus you need to use DD mode
  • For Manjaro dual boot with Win you need to boot the same mode Win boots
  • I think you need to stay on this topic (the 2nd on your installation marathon), since it is still not certain that your installation was proper even if

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark