Installation & Boot failure

This is the fifth day that I am trying to install Manjaro KDE (latest iso 21.2.5). And I am going nuts. I searched the forum and the Web and my issue is similar to those who posted that the installation did not complete due to …”grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force’ returned non-zero exit status 1”.

I also tried installing Manjaro Lxqt-Kwin and Cutefish and Budgie. No dice - Got the same error message.

Thought my SSD was about to fail. Tested it with gsmartcontrol tool. Got a clean bill of health.

Still bought and installed a Nvme M.2 970 Evo Plus, used Gparted 1.4.0 (latest) selected gpt partition table and created:

  • 512mb fat32 EFI partition and set flags to boot+esp
  • 24G ext4 root (/) partition
  • 20G xfs /home partition
  • 8G swap partition

Installations kept failing.

So I decided to wipe clean the M.2 and start on a clean slate using the Manjaro partitioner that comes with the Calamares installer. Still in GPT mode, I started creating the 512mb fat32 EFI partition; when I got to setting flags I noticed that there is NO boot+esp option ONLY a boot option. So I decided to let the installer go on only to test my lucky star … but at about the 90% completion mark the infamous error message popped up on the screen. Now I am really at my wits end.

While still searching for a solution, I found out that Manjaro is using version 3.2.51-1 of the Calamares installer. The newest Calamares version is 3.2.55 as shown on the installer Web site, maybe this new version could solve this issue that has been dragging on for quite some time according to the various posts I read. I also checked the latest Gparted version and it works fine.

Now, YES secure boot is disabled (has always been) and OS boot is set to Another (meaning Linux) (stating from memory, wording may differ)

Mobo: Asus TUF Gaming x570 Plus.

If anyone knows the solution, please chime in.

1 Like

did you try booting into the liveusb with propietary drivers?
did you try unmounting the drive, before you install onto it?
did you try running the calamares in sudo with debugging:
sudo calamares -d
did you use ventoy to flash the iso onto usb
did you boot the usb in uefi/bios mode, depending if you using your bios or uefi

3 Likes
  1. Proprietary drivers not needed. Running APU Ryzen 5 5600G and no graphics card. And no NVidia.
  2. Booted from the USB drive to install on to M.2.
  3. Running sudo calamares -d did not yield positive results, also a failure.
  4. Didn’t use ventoy. As I always do: in a terminal window I use the “sudo dd” command, it never failed me.
  5. Of course I booted the usb in UEFI mode, as stated in my previous post I selected the gpt partition table to apply to the M.2.
1 Like

there were some people who couldnt install until they booted with proprietary drivers, even if they didnt need them… did you open the kde partition manager, and unmount the drive… trying ventoy want hurt, have nothing to lose… recreating again partition table in kde partition manager could help

2 Likes