Install Manjaro along with a dual boot Mint 18 / Windows 7

Also, in my experience, Ubuntu-based bootloaders can’t load Manjaro, it runs in kernel panic, so you have to use Manjaro’s own bootloader.

ok… thanks a lot.
So I have to select the Install boot loader in sda
After installation, will grub show Mint and Windows options along with Manjaro.
Or do I have to do extra steps for this.
Thanks again…

Yes.[quote=“mnjusr, post:4, topic:18592”]
Or do I have to do extra steps for this.
[/quote]
No.

Thanks a lot gohlip for your quick reply.
Let me try it and come back…

What a coincidence! I got that kernel panic today. Installed elementaryOS grub and Manjaro is no longer booting. :disappointed:

Will reinstalling grub on manjaro (using livecd) fix that?

No, you have to use Manjaro’s own grub to boot Manjaro, not another OS’s grub.

When you start your computer, there should be an option to choose which bootloader you want to choose - something like Boot Device Options (it depends on the computer brand which key you have to press to enter this menu, you can look it up online if you are not sure), which should show Ubuntu for all Ubuntu-based distros and Manjaro for Manjaro, then if you select Manjaro, you will go to Manjaro’s bootloader and you can start Manjaro from there.

1 Like

@anand

muser’s method will work if you’re on UEFI because there’s an option in the uefi-bios boot setup.
Then you have to make the Manjaro boot entry as default.

If your computer is bios-legacy, see this link..

Good luck.

1 Like

@muser & @gohlip hat was pretty quick reply. :slight_smile: Thanks for the the link. It worked pretty fine and was really easy.

1 Like

Just to be safe, the boot loader should be installed in
MBR of /dev/sda or
system partition (/)
Kindly let me know.
(Sorry for missing the obvious)
Thank you.

This is the correct way on BIOS (non-UEFI) system.

1 Like

Thank you all, I managed to install Manjaro alongside Mint.
Mint was there in the Grub menu.
But after the update or trying to enable Hibernate, I am not sure which one, now Mint cannot be found on the grub menu. It shows only Manjaro.
(os-prober shows Mint.)
How to get Mint back in the grub menu.
Please help.
Thanks.

First, try

sudo update-grub

ok… thanks.
Please let me know whether from the (Manjaro) installation or liveCD.

From the installed OS, Not from livecd.

ps: please confirm you had booted Linux Mint before from Manjaro grub menu after Manjaro installation.

Will do and post back.

ps: please confirm you had booted Linux Mint before from Manjaro grub menu after Manjaro installation.

Yes, I had booted from Manjaro grub menu after the initial install - before system update.
Thanks again.

Which system did you update? Mint or Manjaro? If Mint, there is a inconvenience you have to tolerate.

  1. if Manjaro was the last distro installed and you chose in the midst of installation to install Manjaro’s grub bootloader in MBR, then Manjaro’s grub will show up when you reboot. The Manjaro bootloader will have Manjaro entries right at the top and a Manjaro logo at the bottom right corner so you’ll know if you got it right.

  2. BUT (assuming you had previously installed Mint’s bootloader into MBR when first installing Mint) if I subsequently update Mint and there are kernel updates, the kernel update automatically triggers the update-grub process and Mint’s grub steals back its place as the bootloader in the MBR.

You will know it because the Mint entries will be placed first in the grub menu when you reboot, and the Manjaro logo won’t be there anymore.

When that happens I need to get back into Manjaro. While in the grub menu, edit (press “e”) the first Manjaro boot entry. The initrd line of the boot code should be amended to read:

The last bit is always missing from Manjaro’s grub entry when you use another distro’s bootloader to generate the grub menu. All it will show is the intel-ucode.img portion. So type in the missing bit and then boot into Manjaro by pressing F10.

In Manjaro,

and then:

sudo grub-install /dev/sdX where X is a or b or whatever letter of the alphabet denotes the device on which MBR is installed.

Manjaro has now taken back its place as the bootloader on MBR.

1 Like

To make it easy to get back into Manjaro whenever this happens, I have a custom.cfg file saved on the /boot/grub folder in Mint with a chainloader grub menu entry for Manjaro.

Then whenever Mint’s grub menu shows up I use that entry to chainload into Manjaro’s own grub menu.

Jumping ahead. Logging off for a while.

If “update-grub” don’t work, check the following
o No grub-customizer installed anywhere, either in Manjaro or in Linux Mint.
o If there is more than one disk, check if all disks are msdos or gpt. If more than one and unsure of disk, let us know.

Do the following (at Manjaro terminal) if there’s no grub-customizer installed (sigh) and only one disk.

sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub

To @wongs
mnjusr said

It should be Manjaro grub, not Mint’s grub.

ps (to wongs): try configfile instead of chainload. It’s more reliable.
and thanks for jumping in. Cheers.

Thanks heaps @gohlip.

update-grub

worked.
Thanks @wongs for your detailed reply.
I tried to install hibernator script to enable hibernation (on my desktop) which is essential to me.
The hibernate option did not show up. Manjaro Deepin, btw.
Not sure whether this messed up my grub…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark