Install Davinci Resolve 14 on Manjaro

#1

Hello everyone!

After the warm welcome as a noob in this OS, I was motivated enough to “transfer” my latest struggles in hopes to help you -interested- people. Install Davinci Resolve 14 (currently @ beta 4) on Manjaro.

The method I’ll explain, is not perfect. It still has some thumbnail issues and produces an exit error, but the system appears fast, stable and works alongside all its intended filters. I dare say, yes, that includes color correction. Though I’ll reach to that when the time comes, as -for some- it might require a tweak.

By the way, the course we’ll talk about is non-foreign-OS-invasive. It’s all Manjaro stuff. And yes, the app will load. :slight_smile: (currently copying a 70GB project from the file server to verify). It has tons of image sequences, so the copy is rather slow from backup.

Have your software installer ready, you’ll need it.

So, go ahead and download the program @ https://www.blackmagicdesign.com/products/davinciresolve

Go to your download folder and type on terminal:

Step #1
Visit https://aur.archlinux.org/packages/davinci-resolve/ and make sure you have the main dependencies, which I believe are already covered by the latest Manjaro updates. Ignore all driver dependencies such as CUDA & OpenCL for now.

Also, ignore the log4cxx. It’s part of Apache and you don’t want to get entangled with that right now. It’s not vital.

However, do install the libpng & libpng12. Both the normal and the 32bit ones.

Step #2
You don’t need to download any libs from the Ubuntu distro. It’s all in your system. So, hit the following lines on a terminal:

sudo ln -s /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.10 sudo ln -s /usr/lib/libssl.so.1.0.0 /usr/lib/libssl.so.10 sudo ln -s /usr/lib/libgstreamer-1.0.so.0 /usr/lib/libgstreamer-0.10.so.0 sudo ln -s /usr/lib/libgstbase-1.0.so.0.1201.0 /usr/lib/libgstbase-0.10.so.0

That should solve all the important dependencies that stop Resolve from launching.

Step #3
Go to your software installer and download/install CUDA (for those with nVidia cards). For you that have an AMD, let me tell you… you are in luck. Especially if you can install the AMDGPU-Pro, that comes with its own OpenCL package.

Step #4
Normally, one would go and launch Resolve. However, it has an issue. Its CUDA is buggy and it causes a segmentation fault. So, open up a terminal and hit the following:

cd /opt/resove/configs sudo nano config.dat

Head to the end of the file, just prior to the double dashes that speak of Parameters to crashes and import the following lines:

LsManager.3.NumGPUs = 1 LsManager.3.GPUMapping = 0 LsManager.3.GPUMappingEnable = 1 Local.GPU.Mode = OpenCL

Save and exit.

Step #5
The application is now ready to launch.
So launch it. Then do the following steps:

Go to Davinci Resolve menu (top left) > Preferences > Video I/O and GPU settings and change the GPU processing from Auto to OpenCL. Preferably, hit the manual mode below it and make sure your graphics card is selected.

Place in your media storage file, save and exit.

Now, on the exit, it will produce some errors, which I am trying to solve (any help would be appreciated here), but it does not affect the current functionality.

If by any case, you forget to change the preferences (and have an nVidia card), Davinci will not restart. To ensure a launch, shoot the following lines on the terminal:

cd /opt/resove/configs sudo nano config.dat
And at the end of the file (prior to the crash parameters), add:

And you’ll be fine.

And that’s it! At least the app will come alive!

Color Correction black screen
If by any chance you try to color correct and you see just a black screen on the coloring monitor, simply go to Project Settings and turn the 10-bit down to 8-bit and the issue should be solved.

Current Issue
It’s basically the error you get on exit. It appears to be related to QT5 libs installed in the Resolve folder, so I can’t make any connections at the moment. I thought it was the lack of timeline thumbnails, but they appear normally as an option.

By the way, I got some more time before the project copies over to do further testing, but I believe you’ll have a running beta app to play with.

Enjoy!

MAJOR UPDATE
I found the issue with the exit error.
Just give the application rights to your user. I did the following:

cd /opt sudo chown -R <myusername> resolve/*
And the issue was solved.

Now the app is squeaky clean!

7 Likes
Manjaro Installation
#2

And here is a screen-capture from Davinci on Manjaro Gnome. It appears to be working correctly.

#3

Thank you for this. I moved your topic from General Discussion into the Tutorial Section.

1 Like
#4

Just a side question. What is the benifit to this method of installation viz installing from the AUR?

$ yaourt -Ss davinci-resolve
aur/davinci-resolve 12.5.6-1 (2) (0.63)
    Professional A/V post-production software suite
aur/davinci-resolve-beta 14.0b4-2 (3) (1.57)
    Professional A/V post-production software suite
#5

Maybe moving your original post to the tutorials category closed you out. Due to the fact you are new. Kind of a “permission” thing, @Phrosgone , IDK. Here is a past of your pm for others:

https://forum.manjaro.org/t/cant-respond-on-the-forum-thread-for-some-reason/26519?source_topic_id=26514

kvassilis
17m

…so I’ll respond here instead.

Primarily, I arrived on Manjaro less than 12 hours ago. So I am extremely fresh & still learning the ropes big time. Secondarily, the raw installation -as is intended- does not supercede the bug CUDA has on some older nVidia cards (I did a full test run on CentOS). So, even though it installs correctly there, it doesn’t run for a good number of people.

And last, I did a search for Manjaro installation and the only things I came up with were various redirections. Therefore I took the time to consolidate what I experienced in both Ubuntu Studio (which I use primarily) and CentOS for the Manjaro community.

Nothing further.

Just a side question. What is the benifit to this method of installation viz installing from the AUR? $ yaourt -Ss davinci-resolve aur/davinci-resolve 12.5.6-1 (2) (0.63) Professional A/V post-production software suite aur/davinci-resolve-beta 14.0b4-2 (3) (1.57) Professional A/V post-production software suite

By the way, pamac and octopi can access the AUR, as can yaourt which is a pacman front-end as well.

I’m pretty new at this all too so I was wondering… :relaxed:

1 Like
#6

Octopi ends the install like this:

==> Building and installing package
  -> Please remember to put a package archive DaVinci_Resolve_14.0b4_Linux.zip in to 
==> Making package: davinci-resolve-beta 14.0b4-2 (Sun Jun 25 10:51:02 EEST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> ERROR: DaVinci_Resolve_14.0b4_Linux.zip was not found in the build directory and is not a URL.
==> ERROR: Makepkg was unable to build davinci-resolve-beta.

Maybe that is why @kvassilis chose his approach …

1 Like
#7

The DaVinci file must be downloaded manually @bogdancovaciu

2 Likes
#8

Thank you! I stand corrected.
I had no idea that there is a free version and the way it works to get it.

1 Like
#9

I installed resolve using this method however whenever I add a video (its .mp4 .ogv wont load) to the media pool or track it shows up as audio but won’t play. I have a gtx 1060 3gb in a Ryzen workstation. Any ideas would be appreciated.

#10

Install it under CentOS or RHEL - that’s the only “supported” Linux platform.

#11

Chip:
The free version does not support mp4 or ogv files, unfortunately. You’ll have to convert them to m4v, mov or avi (or image sequence). That’s how I did it at least.

Johnathan:
The RHEL/CentOS are basically aimed for server platforms and don’t do too well with the evolving post production & VFX requirements. CentOS was my first real attempt to use it. However, I had the misfortune of using an RX480 card & found out that AMD is really as in really playing catch-up with their drivers. The MESA version is incredibly superior, but the OpenCL is a labyrinth to function with Resolve (or Fusion)… but -for some interesting reason- is visible to Houdini.

Under the stock Kernel of CentOS 7.3, my video-drive SSD would only read around 127MB/sec. In order to get it to 207MB/sec, I had to upgrade to a later stable Kernel. That upgrade did indeed improve the overall speed, but the AMD drivers went haywire, giving me white screens and other issues that became too frequent & cumbersome to handle. So I dumped that option real quick.

I even went to Fedora, where I “smashed my head” on the AMD driver wall yet again (it doesn’t recognize the Wayland server and I’d have to downgrade). In short, I jumped around some distros and after a “black screen of death” I got after a Manjaro update, I eventually shifted back to Ubuntu Studio. I clearly blame AMD for that.

Now, my SSD read speed launched up to 423.3MB/sec - sustained, not burst. If that is no indication as to how much CentOS needs to catch up, I don’t know what is.

Honestly, I do regret getting the RX480. It’s great for games under MESA, but that’s where it stops. Even with Windows 10, the drivers were losing DirectX connectivity after 2-3 reboots and needed a full uninstall & reinstall. And for the record, I got rid of all Windows OS on 5 stations. Thankfully, I am working on a decent project right now and one of my first steps is to throw that card in the garbage.

I don’t even want to describe the back-and-forth I had with AMD support because they uploaded the incomplete file of their AMDGPU-Pro driver on the official server and had it there for two weeks(!). They finally fixed that.

3 Likes
#12

Seems like i cant launch resolve. Im using open source amd drivers (video-ati) . Ive installed all the required dependencies. I was able to go through the quick setup tour and thats it. When i run it in terminal i get this:

ActCCMessage Already in Table: Code= 2282, Mode= 0, Level= 0, CmdKey= 8, Option= 0
ActCCMessage Already in Table: Code= c005, Mode= 13, Level= 1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level= 1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level= 1, CmdKey= -1, Option= 0
14.0 (#078)
Main thread starts: 009C6F40
[0x7ff9009c6f40] | Undefined | INFO | 2017-10-08 19:24:38,973 | --------------------------------------------------------------------------------
[0x7ff9009c6f40] | Undefined | INFO | 2017-10-08 19:24:38,973 | Loaded log config from /opt/resolve/configs/log-conf.xml
[0x7ff9009c6f40] | Undefined | INFO | 2017-10-08 19:24:38,973 | --------------------------------------------------------------------------------

Command has been completed, press ENTER to exit the terminal.

Any idea ?? :dizzy_face:

#13

Please direct questions and support requests to Da Vinci.

They won’t fix Linux support unless people ask them to.

#14

Can confirm that davichi resolve works perfectly for me, I can color correct without issue as well as pretty much everything else

I’m using a 6gb 1060 with an i5

edit: Just had it crash on me, I imagine thats a one off thing but just thought I’d say

#15

“Go to your download folder and type on terminal:”

No command is visible after that…
Please update

1 Like
#16

(full disclosure - dont use it, havent tried or tested)

Looks like they were edited away (no longer needed?)
If they are gone for good reason I would assume just

pacaur -S libpng libpng12 lib32-libpng lib32-libpng12 davinci-resolve

(or whatever helper you use)

then follow steps 2-5.

Then

sudo chown -R <YourUserName> /opt/resolve/*

…from what I can tell :woman_shrugging:

#17

Thanks!

#18

When I’m using /opt/resolve/bin/resolve to start DaVinci Resolve, I’m getting the following error:

ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
14.3 (#014)
Main thread starts: 61111040
log4cxx: No appender could be found for logger (Undefined).
log4cxx: Please initialize the log4cxx system properly.

#19

But your message obviously points to it. If you absolutely need it there is log4cxx in aur.

1 Like
#20

Unless something says “error” and something doesn’t work because of it, it’s not an “error”, it’s a “message”. This particular message about log4cxx is a message.

1 Like