Install aurman with error output


#1

[captain@captain-pc ~]$ git clone https://aur.archlinux.org/aurman.git
正克隆到 ‘aurman’…
remote: Enumerating objects: 240, done.
remote: Counting objects: 100% (240/240), done.
remote: Compressing objects: 100% (158/158), done.
remote: Total 240 (delta 82), reused 240 (delta 82)
接收对象中: 100% (240/240), 29.76 KiB | 29.76 MiB/s, 完成.
处理 delta 中: 100% (82/82), 完成.
[captain@captain-pc ~]$ cd aurman/
[captain@captain-pc aurman]$ ls
PKGBUILD
[captain@captain-pc aurman]$ makepkg -si
==> 正在创建软件包:aurman 2.18-1 (2018年09月10日 星期一 12时15分03秒)
==> 正在检查运行时依赖关系…
==> 正在检查编译时依赖关系
==> 获取源代码…
-> 正在克隆 aurman_sources git 仓库…
克隆到纯仓库 ‘/home/captain/aurman/aurman_sources’…
remote: Counting objects: 4307, done.
remote: Compressing objects: 100% (19/19), done.
remote: Total 4307 (delta 5), reused 6 (delta 1), pack-reused 4287
接收对象中: 100% (4307/4307), 967.77 KiB | 778.00 KiB/s, 完成.
处理 delta 中: 100% (2748/2748), 完成.
==> 正在验证 source 文件,使用md5sums…
aurman_sources … 已跳过
==> 正在使用 gpg 验证源文件签名…
aurman_sources git repo … 失败 (未知的公共密匙 465022E743D71E39)
==> 错误: 一个或多个 PGP 签名无法校验!

i install it in pamac and get the same error…how to fix it?


#2

I can’t read that, but presumably you need to add the key 465022E743D71E39 to your keyring.

You can do so by following this guide:

That being said, aurman is no longer being publicly supported by the author. Here is quote by the author from the aur page:

aurman development for public use has been stopped. i suggest migrating to yay, i am not interested in any kind of feedback, bug reports, feature requests etc. anymore.


#3

but yay’s dependency is aurman…still need to install it…


#4

It’s still being developed, just to his own requirements, which makes perfect sense to me.

The amount of aggro you get trying to fulfil the wants of every person with a web browser makes things very tiring, even more so if you try to meet all of those wants. It’s a thankless and unforgiving task.

So - aurman works, it will keep working, the dev will continue to develop it, just in the way that he wants to for himself. And I’m OK with that. :wink:


#5

I don’t have aurman as a dependency to yay when I look it up:

Repository      : community
Name            : yay
Version         : 8.998-2
Description     : Yet another yogurt. Pacman wrapper and AUR helper written in go.
Architecture    : x86_64
URL             : https://github.com/Jguer/yay
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : pacman>=5.1  sudo  git
Optional Deps   : None
Conflicts With  : yay-bin  yay-git
Replaces        : None
Download Size   : 1470,88 KiB
Installed Size  : 5022,00 KiB
Packager        : Jonathon Fernyhough <jonathon@manjaro.org>
Build Date      : s
Validated By    : MD5 Sum  SHA-256 Sum  Signature

closed #6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.