Input password wrong now Manjaro doesn't load after boot

I have a dual boot setup with Windows. I recently input my password incorrectly for my manjaro account and I saw “10 minutes to log in” being displayed. I was late for a meeting so I booted to Windows and now when I return to Manjaro, after selecting manjaro in GRUB, I get a blank black screen. Logging into windows is fine, but for Manjaro nothing happens. Even the lights on my mouse aren’t on suggesting it’s not receiving power? I have no idea how to troubleshoot this

When I plug my keyboard after manjaro has booted and the screen is black, the blue indicator LEDs are all lit up. However, if the keyboard was plugged in before the restart, all the indicator LEDs are off (just like the mouse indicator LEDs). This makes it seem as if manjaro is loading and locking peripherals, so it seems I’m locked out of my account but without any graphical display nor any input devices being recognized

Any insights or leads available? Having to take time off work currently for this

? - that is a functionality I have never heard about - I heard of it - but I cannot provoke it - so I am a in the dark with this.

From the display manager you should be able to switch to a TTY.

From a TTY you should be able to login using either your username - or you could use the root account - then use this to reset your username - if it is indeed locked.

I have been testing this and finally I was able to provoke the behavior.

You can work around it logging in as root then unlocking - replace $USERNAME with the actual locked username - then reboot the system.

# usermod -U $USERNAME
1 Like

What’s the best way to go about this considering when I boot to manjaro I don’t have display funcitonality?

Do I need to boot to a USB manjaro media?

I don’t want to be a nuisance but I don’t want to use more vacation time tomorrow and I’m not sure what to do from this step. I can enter the GRUB commandline, is that where I should input the above command? As soon as I select manjaro from GRUB all my peripherals get locked and the screens are black so I can’t log in as root

I tried to boot to a USB with manjaro on it, and it successfully loads to the desktop environment, but when I run sudo usermod -U $USERNAME with the appropriate username it says “usermod: user ‘$USERNAME’ does not exist”

which makes sense because the terminal session is manjaro@manjaro rather than $USERNAME@$machine but again this suggests to me that I have no way of entering the locked manjaro partition

Hi @blp92 :wink:

  1. $USERNAME is a placeholder for your current username.
  2. sudo usermod -U $USERNAME unlocks the user, but you need boot the local system, that is not possible on a live boot (even if chrooting).
  3. TTY means, type: CTRL+ALT+F3 to switch to another TTY, then login and unlock the user with that command.

Hope that make it more clear.

1 Like

Thanks for the response.

1 and 2 I understood, and that’s why I was confused about the method and didn’t think it would work. 3 is new to me but does not work unfortunately.

Maybe I’m not being clear but once I have selected manjaro linux in GRUB, my peripherals all go black and are no interactive at all. Pressing CTRL+ALT+F3 yields nothing. I need to somehow unlock it from GRUB since as soon as manjaro is selected I am completely cut out from any interaction with my peripherals

The wrong password don’t lock everything - it only block login after 5 attempts - blocking for 10 minutes.

This could be a case of initrd not containing the needed modules or not able to autodetect the needed modules - but I am 99% sure it has nothing to do with the password.

When you are in GRUB menu edit the grub command line pressing e on the default entry.

Then use to reach line containing quiet the press End add a space to the end of the line and the digit 3 then press F10 to continue booting.

This should bring you to the console (runlevel 3 in the old days) - login using root credentials.

I suggest you run a full system sync using pacman

# pacman -Syyu

Then unlock the locked username - exit - and reboot.

1 Like

I trust your expertise in this but I had a manjaro install working perfectly until I entered the password wrong twice and rebooted to windows to make a last minute meeting. Ever since I’ve been stuck in this state.

If it’s not password related that’s all well and good I’d just like to resolve it somehow :sweat_smile:

Following this, there was already a 3 at the end of that line. I tried what you suggested anyways and I still end with the locked peripherals and not a console unfortunately. Let me post a cell phone picture of what I see from the GRUB editor

That 3 is probably the kernel argument

... udev.log_priority=3

Just add a space and another digit 3 like this (without the dots - they designate whatever is present beforhand)

... udev.log_priority=3 3

You are right it does have udev.log_priority=3 and I did add it to become udev.log_priority=3 3 and still got the locked screens and keyboard and mouse.

I don’t know is wrong but this needs an USB stick with a Manjaro ISO to boot the system from.

I am pretty occupied so I have to leave … Sorry I can’t followup on this.

I tried that and I successfully boot to the media but then I’m in a session on the media and I can’t do the usermod command as the username will be unrecognized

understood, thanks for your help!

Use chroot.

Locate your root device /dev/sdyX replace with your device


Then mount the device on /mnt

sudo mount /dev/sdxY /mnt

Then chroot

manjaro-chroot /mnt /bin/bash

Then you can use usermod to unlock - and you should also be able to run a full sync as mentioned above.

Was successfully able to run this, thank you! Do I need to close anything in the terminal or unmount before I close this session from media?

I used this method and it seemed to work (no error was thrown at any point) and yet the issue persists. My root is in nvme0n1p7 and so I did

sudo mount /dev/nvme0n1p7 /mnt

followed by

manjaro-chroot /mnt /bin/bash

and once that was going I input

usermod -U $USERNAME (with correct username filled in) and it seemed to work as no error was thrown. But after rebooting and selecting manjaro again I get the same behavior as before