Input method settings - Is GTK_IM_MODULE environment variable required to trigger input method with GNOME 42?

Hi team, I’m raising a (maybe stupid) question: Is GTK_IM_MODULE environment variable required by Manjaro Testing branch?

Background: Last week I moved from Manjaro stable to Manjaro testing, which upgrades GNOME 40 to GNOME 42. After moving I noticed some applications failed to start Chinese input method, but some still works fine. The impacted applications I tested include Gvim, Slack via AUR, Google Chrome, and all Electron-based applications like Slack and Discord). However, built-in GNOME applications like gnome-terminal works fine.

After digging I noticed the problem was gone by setting GTK_IM_MODULE and XMODIFIERS environment variables. (So the problem does not bug me anymore, wow!) However, this is kinds of unexpected because I didn’t set it for years since moving to GTK+3/GNOME 3. And Manjaro stable does not need it either. I see this issue happening only on Manjaro testing.

I’m still not clear whether any changes in Manjaro testing branch or GNOME 42 has some changes that causing this change. Anyone can give a suggestion?


Most likely related to this IBus configuration broken on x11 (#682) · Issues · GNOME / gnome-settings-daemon · GitLab

Wow so it is a bug. Thank you for the info!

From Gitlab seems upstream already has a fix at xsettings: Remove direct mapping from gtk-im-module to Gtk/IMModule (!296) · Merge requests · GNOME / gnome-settings-daemon · GitLab. Hopefully it can be applied soon. For now I’m lucky enogh that GTK_IM_MODULE helps. Thanks again.

I also faced this issue. The command mentioned in the bug report fixed it for me:

gsettings set org.gnome.desktop.interface gtk-im-module ibus