Inconsistent Network Speed with Newer Kernels / Firmware

Hi there. I have recently noticed an issue where network activity under the last few kernels has been inconsistent, and nearly unusable. I do not know exactly where the problem arose, but any sustained network traffic slows to a crawl under kernels 6.4-6.6. I have an un-updated arch install with kernel 6.0 that does not exhibit the behavior below and functions as expected. Also, Windows has no network issues on this system.

When performing an internet speed test, a couple of different scenarios will occur. The most likely is that the download speed will be limited to roughly 10Mbps (connection is 300 Mbps). Some time, the speed test will start at a maxed data rate of near 300 Mbps and trail off to between 10 and 50 Mbps. To remove the variability of my isp, I tested my local network throughout with iperf. Similar behavior was observed here as well. Transfers would start at 1Gbps then drop to below 50Mbps. The same iperf test run on Windows resulted in a consistent t 960Mbps transfer across the network.

I have booted the latest manjaro install image as well as endeavouros and observe the same behavior in both, leading me to believe this is most likely a software issue. Any switching between Windows and manjaro is done by performing a full shutdown before booting manjaro.

inxi

System:
  Host: patrick-linux Kernel: 6.6.0-1-MANJARO arch: x86_64 bits: 64
    compiler: gcc v: 13.2.1 Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11
    wm: kwin_x11 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: X670E AORUS MASTER v: -CF
    serial: N/A
  Mobo: Gigabyte model: X670E AORUS MASTER v: x.x serial: N/A UEFI: American
    Megatrends LLC. v: F13d date: 09/14/2023
CPU:
  Info: 12-core model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4
    rev: 2 cache: L1: 768 KiB L2: 12 MiB L3: 64 MiB
  Speed (MHz): avg: 933 high: 3600 min/max: 400/5733 cores: 1: 3599 2: 400
    3: 400 4: 400 5: 400 6: 400 7: 400 8: 3600 9: 400 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 21: 400
    22: 3600 23: 400 24: 3600 bogomips: 225696
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] driver: nvidia v: 535.113.01
    arch: Pascal pcie: speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1b80
  Display: server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 108
  Monitor-1: DP-0 pos: primary,left res: 2560x1440 dpi: 109
    diag: 685mm (26.97")
  Monitor-2: DP-4 pos: right res: 2560x1440 dpi: 109 diag: 685mm (26.97")
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 2 drv: swrast
    gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 535.113.01
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2
  API: Vulkan v: 1.3.264 surfaces: xcb,xlib device: 0 type: discrete-gpu
    driver: nvidia device-ID: 10de:1b80
Audio:
  Device-1: NVIDIA GP104 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f0
  Device-2: Logitech Blue Microphones
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 bus-ID: 3-5.1:4 chip-ID: 046d:0ab7
  Device-3: Creative Sound Blaster X4
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 3-5.2:6 chip-ID: 041e:3278
  API: ALSA v: k6.6.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: PipeWire v: 0.3.81 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
Network:
  Device-1: Intel Ethernet I225-V vendor: Lenovo driver: igc v: kernel pcie:
    speed: 5 GT/s lanes: 1 port: N/A bus-ID: 0d:00.0 chip-ID: 8086:15f3
  IF: enp13s0 state: up speed: 1000 Mbps duplex: full mac: d8:5e:d3:e1:c9:2b
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: speed: 5 GT/s lanes: 1 bus-ID: 0e:00.0 chip-ID: 8086:2725
  IF: wlp14s0 state: down mac: 4a:7e:1d:61:ed:9b
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-9:3 chip-ID: 8087:0032
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: 4C:03:4F:C3:11:84
    bt-v: 5.3 lmp-v: 12

Please let me know what other information might be needed to diagnose this issue. Thanks!

Have you already installed the newest driver pack?

https://www.intel.com/content/www/us/en/products/sku/184676/intel-ethernet-controller-i225v/downloads.html

While the driver pack does have an updated i225-v driver for Windows, it would appear that there is not an updated driver (or any driver at all) included for linux.

Install the update in Windoze and then verify. It could affect the performance on Linux.

After installing the update in Windows, linux performance is the same as before. I’ve also booted my arch install and found network performance there to be matching that of the newer kernels now. I’ll start reverting my driver version to test further.

edit: Reverting to older versions of the Windows driver does not improve the situation at all.

I’ve spent some more time investigating this with no success. I have replaced my network switch, network cable, reverted to older versions of my BIOS, and unplugged my opnsense router just in case it could be interfering. In my testing, I did notice that RX flow control was enabled. I’ve run some iperf tests before and after disabling flow control but haven’t had any luck.

It may be a red herring, but doing some testing with iperf has shown that there are quite a bit of retransmissions occurring intermittently. It does not matter if my desktop that is having the issue is the server or client.

Desktop as server (client side output).

iperf3 -c 192.168.10.3 -t 15                                                                                                                                                                                         ✔  15s   patrick@scout 
Connecting to host 192.168.10.3, port 5201
[  5] local 192.168.10.221 port 46332 connected to 192.168.10.3 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  44.8 MBytes   376 Mbits/sec  422   35.4 KBytes       
[  5]   1.00-2.00   sec  40.3 MBytes   338 Mbits/sec  280   50.9 KBytes       
[  5]   2.00-3.00   sec  3.48 MBytes  29.2 Mbits/sec   27   38.2 KBytes       
[  5]   3.00-4.00   sec  95.1 MBytes   798 Mbits/sec   85    389 KBytes       
[  5]   4.00-5.00   sec  16.8 MBytes   141 Mbits/sec  484   39.6 KBytes       
[  5]   5.00-6.00   sec  2.49 MBytes  20.9 Mbits/sec    4   42.4 KBytes       
[  5]   6.00-7.00   sec  91.0 MBytes   763 Mbits/sec    0    349 KBytes       
[  5]   7.00-8.00   sec   111 MBytes   932 Mbits/sec    0    543 KBytes       
[  5]   8.00-9.00   sec   113 MBytes   944 Mbits/sec    0    683 KBytes       
[  5]   9.00-10.00  sec   111 MBytes   933 Mbits/sec    0    799 KBytes       
[  5]  10.00-11.00  sec   111 MBytes   933 Mbits/sec    0    901 KBytes       
[  5]  11.00-12.00  sec   111 MBytes   933 Mbits/sec    0    990 KBytes       
[  5]  12.00-13.00  sec  53.8 MBytes   451 Mbits/sec  1370   48.1 KBytes       
[  5]  13.00-14.00  sec  2.50 MBytes  21.0 Mbits/sec   14   36.8 KBytes       
[  5]  14.00-15.00  sec  8.75 MBytes  73.4 Mbits/sec  205   36.8 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-15.00  sec   916 MBytes   512 Mbits/sec  2891             sender
[  5]   0.00-15.01  sec   913 MBytes   511 Mbits/sec                  receiver

Desktop as client

iperf3 -c 192.168.10.221 -t 15                                                                                                                                                                                                       ✔  15s  
Connecting to host 192.168.10.221, port 5201
[  5] local 192.168.10.3 port 34316 connected to 192.168.10.221 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  2.77 MBytes  23.2 Mbits/sec    0    148 KBytes       
[  5]   1.00-2.00   sec  23.6 MBytes   198 Mbits/sec   52    382 KBytes       
[  5]   2.00-3.00   sec  4.04 MBytes  33.9 Mbits/sec    0    431 KBytes       
[  5]   3.00-4.00   sec  13.0 MBytes   109 Mbits/sec   31    322 KBytes       
[  5]   4.00-5.00   sec  97.7 MBytes   819 Mbits/sec   47    379 KBytes       
[  5]   5.00-6.00   sec   112 MBytes   942 Mbits/sec   51    451 KBytes       
[  5]   6.00-7.00   sec  66.8 MBytes   560 Mbits/sec   46    443 KBytes       
[  5]   7.00-8.00   sec  4.04 MBytes  33.9 Mbits/sec    0    443 KBytes       
[  5]   8.00-9.00   sec  66.7 MBytes   559 Mbits/sec   48    431 KBytes       
[  5]   9.00-10.00  sec   113 MBytes   945 Mbits/sec   58    362 KBytes       
[  5]  10.00-11.00  sec   111 MBytes   934 Mbits/sec   36    437 KBytes       
[  5]  11.00-12.00  sec  17.9 MBytes   150 Mbits/sec   28    331 KBytes       
[  5]  12.00-13.00  sec  8.12 MBytes  68.1 Mbits/sec    0    410 KBytes       
[  5]  13.00-14.00  sec  33.8 MBytes   283 Mbits/sec    0    443 KBytes       
[  5]  14.00-15.00  sec   112 MBytes   942 Mbits/sec   92    321 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-15.00  sec   787 MBytes   440 Mbits/sec  489             sender
[  5]   0.00-15.00  sec   785 MBytes   439 Mbits/sec                  receiver

For comparison, here is iperf with my desktop as server and client under windows, to the same host as above:

Output from client side (desktop as iperf server).

iperf3 -c 192.168.10.3 -t 20                                                  
Connecting to host 192.168.10.3, port 5201
[  5] local 192.168.10.221 port 33658 connected to 192.168.10.3 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec   113 MBytes   951 Mbits/sec    0    218 KBytes
[  5]   1.00-2.00   sec   112 MBytes   940 Mbits/sec    0    218 KBytes
[  5]   2.00-3.00   sec   113 MBytes   945 Mbits/sec    0    218 KBytes
[  5]   3.00-4.00   sec   112 MBytes   943 Mbits/sec    0    218 KBytes
[  5]   4.00-5.00   sec   112 MBytes   938 Mbits/sec    0    218 KBytes
[  5]   5.00-6.00   sec   112 MBytes   944 Mbits/sec    0    218 KBytes
[  5]   6.00-7.00   sec   112 MBytes   941 Mbits/sec   15    158 KBytes
[  5]   7.00-8.00   sec   112 MBytes   941 Mbits/sec    0    211 KBytes
[  5]   8.00-9.00   sec   112 MBytes   944 Mbits/sec    0    211 KBytes
[  5]   9.00-10.00  sec   112 MBytes   940 Mbits/sec    0    211 KBytes
[  5]  10.00-11.00  sec   113 MBytes   946 Mbits/sec    0    211 KBytes
[  5]  11.00-12.00  sec   112 MBytes   942 Mbits/sec    0    211 KBytes
[  5]  12.00-13.00  sec   112 MBytes   939 Mbits/sec    0    211 KBytes
[  5]  13.00-14.00  sec   113 MBytes   945 Mbits/sec    0    211 KBytes
[  5]  14.00-15.00  sec   112 MBytes   940 Mbits/sec    0    211 KBytes
[  5]  15.00-16.00  sec   113 MBytes   945 Mbits/sec    0    211 KBytes
[  5]  16.00-17.00  sec   112 MBytes   942 Mbits/sec    0    211 KBytes
[  5]  17.00-18.00  sec   112 MBytes   938 Mbits/sec    0    211 KBytes
[  5]  18.00-19.00  sec   113 MBytes   945 Mbits/sec    0    211 KBytes
[  5]  19.00-20.00  sec   112 MBytes   942 Mbits/sec    0    211 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-20.00  sec  2.19 GBytes   943 Mbits/sec   15             sender
[  5]   0.00-20.00  sec  2.19 GBytes   942 Mbits/sec                  receiver

Output from windows (as client).

.\iperf3.exe -c scout.lan -t 20                                                                                   
Connecting to host scout.lan, port 5201
[  4] local 192.168.10.3 port 49814 connected to 192.168.10.221 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec   114 MBytes   951 Mbits/sec
[  4]   1.00-2.00   sec   113 MBytes   949 Mbits/sec
[  4]   2.00-3.00   sec   113 MBytes   949 Mbits/sec
[  4]   3.00-4.00   sec   113 MBytes   948 Mbits/sec
[  4]   4.00-5.00   sec   113 MBytes   950 Mbits/sec
[  4]   5.00-6.00   sec   113 MBytes   949 Mbits/sec
[  4]   6.00-7.00   sec   113 MBytes   949 Mbits/sec
[  4]   7.00-8.00   sec   113 MBytes   949 Mbits/sec
[  4]   8.00-9.00   sec   113 MBytes   949 Mbits/sec
[  4]   9.00-10.00  sec   113 MBytes   948 Mbits/sec
[  4]  10.00-11.00  sec   113 MBytes   950 Mbits/sec
[  4]  11.00-12.00  sec   113 MBytes   949 Mbits/sec
[  4]  12.00-13.00  sec   113 MBytes   949 Mbits/sec
[  4]  13.00-14.00  sec   113 MBytes   949 Mbits/sec
[  4]  14.00-15.00  sec   113 MBytes   949 Mbits/sec
[  4]  15.00-16.00  sec   113 MBytes   949 Mbits/sec
[  4]  16.00-17.00  sec   113 MBytes   949 Mbits/sec
[  4]  17.00-18.00  sec   113 MBytes   949 Mbits/sec
[  4]  18.00-19.00  sec   113 MBytes   949 Mbits/sec
[  4]  19.00-20.00  sec   113 MBytes   949 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-20.00  sec  2.21 GBytes   949 Mbits/sec                  sender
[  4]   0.00-20.00  sec  2.21 GBytes   949 Mbits/sec                  receiver

HI, I noticed exactly the same behavior, my network suddenly gets slow and almost unuseable.

inix

System:
  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=402597f3-af8e-49a3-b27a-07b4be16f8de rw quiet
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: HKD-WXX v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: HKD-WXX-PCB-B1 v: M1010 serial: <superuser required>
    UEFI: HUAWEI v: 1.20 date: 04/19/2022
Battery:
  ID-1: BAT1 charge: 9.6 Wh (17.8%) condition: 53.8/59.7 Wh (90.1%) volts: 11.5
    min: 11.6 model: SUNWODA HB5781P1EEW-31T type: Li-ion serial: <filter>
    status: charging cycles: 168
Memory:
  System RAM: total: 16 GiB note: est. available: 15.41 GiB
    used: 7.21 GiB (46.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: 11th Gen Intel Core i7-11370H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xAC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 557 high: 1036 min/max: 400/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 1026 4: 400
    5: 400 6: 400 7: 1036 8: 400 bogomips: 52856
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities:
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: QUANTA
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: 37303042313939314D4134 USB Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:3 chip-ID: 3408:c200
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2520x1680 s-dpi: 96 s-size: 666x444mm (26.22x17.48")
    s-diag: 800mm (31.51")
  Monitor-1: eDP-1 model: TL142GDXP02-0 built: 2021 res: 2520x1680 hz: 90
    dpi: 213 gamma: 1.2 size: 300x200mm (11.81x7.87") diag: 361mm (14.2")
    ratio: 3:2 modes: 2520x1680
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
    device-ID: 8086:9a49 memory: 15.05 GiB unified: yes
  API: Vulkan v: 1.3.264 layers: 4 device: 0 type: integrated-gpu name: Intel
    Xe Graphics (TGL GT2) driver: mesa intel v: 23.1.9-manjaro1.1
    device-ID: 8086:9a49 surfaces: xcb,xlib
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: QUANTA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 221.07 GiB (46.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: KPART512GBC2DVT size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    tech: SSD serial: <filter> fw-rev: FW000003 temp: 37.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 221.05 GiB (47.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 402597f3-af8e-49a3-b27a-07b4be16f8de
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 18.9 MiB (6.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: 3AB8-B3D8
Swap:
  Alert: No swap data was found.
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-4:2 info: Shenzhen Goodix Fingerprint Device
    type: communication,CDC-data driver: N/A interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 27c6:5125 class-ID: 0a00 serial: <filter>
  Device-2: 3-6:3 info: 37303042313939314D4134 USB Camera type: video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 3408:c200 class-ID: fe01 serial: <filter>
  Device-3: 3-10:4 info: Intel AX201 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0026 class-ID: e001
  Hub-4: 4-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 271 Uptime: 6h 8m wakeups: 51343 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1579 pm: pacman pkgs: 1568 libs: 408 tools: pamac pm: flatpak
  pkgs: 0 pm: snap pkgs: 11 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.30

it does not matter if I use Wifi or ethernet