Inconsistent installer boot results

bspwm

#1

Hi. Im completely new to manjaro and is trying to install this community editon. I downloaded the iso from https://osdn.net/dl/manjaro-community/manjaro-bspwm-17.1.7-stable-x86_64.iso.
I had a lot of struggle installing it.
First, is that i cant use rufus, which i usually use. So i used etcher instead.
I finally able to boot the usb stick with the iso on it. But whenever i try to select boot manjaro, i get different results. Sometimes it ends up doing nothing for a pretty large sum of minutes without any error message. So rebooting my laptop is the only solution. Then after some retries (because i really want this thing to work) i was able to get to the login screen. I cant login using the
Username: manjaro
Password: manjaro
Until i read another post, used username: root made me able to pass the login process. But after running
sudo setup
And configured my internet connection correctly, an error message prevents me to proceed. I get error:
Invalid or corrupted package.
So i tried the solution from this post.
But i cant pass thru the key refresh thing and get an error saying something like there is no key container. All in all, its already 12:30am now and still cant make it work.

  1. Did i downloaded at the correct link? Cause i see here that there is a download link at sourceforge. I did a checksum and its good. So corrupted iso might not be the case.

  2. Is there a step by step guide on installing this? Ive been looking around but i cant see any. Maybe i didnt searched good enough.

  3. Upon checking on reviews online, this DE seems to be good yet lightweight. Which is what i need. I tend to move away from MATE. But does this community editon supports my old laptop?

Lenovo ideapad s10-3s
Intel atom N550
Ram: 2gb

Is it natural taking too long to get somewhere after hitting
Boot: manjaro. X86_64 bspwm given my device is not that good?
Im really getting different results.
Here is what i got on screen.

Please somebody shed light. Thanks.


[Bspwm] v17.1.7 stable isos released
#2

Ill try to redownload the iso. Maybe it might work. Or can i just do architect install and just install bspwm? But surely i might miss a lot of things thats already made with this community release. Hmm.


#3

Sounds like a broken iso, downloading again is the correct choice. Bspwm is available for installation only with manjaro-architect anyway, so any manjaro iso will do. Manjaro-architect was originally written for bspwm edition.


#4

Hi. Still having problems. Cant make it install yet.
So I tried to install linux mint Tara 64bit (just to test) using the same usb stick and etcher.
It also didnt worked.
So probably its the usb stick or etcher.
Ive seen online that etcher has a bug on ubuntu and ubuntu based distro and im using mint 19 to burn iso via etcher.

  1. Do you have any recommendation on what app or any other way i can have this ISO on this USB stick without using etcher?
  2. Is this ISO PAE or non-PAE? Cause i remember before, i used to install linux distros on this laptop and able to make it as long as its non-PAE.

My goal really is to have a 64bit linux distro installed and i want manjaro on bspwm. So i wish i can make this work. thanks.


#5

Hi. The most direct way is to use dd command from command line. There are some gui applications, yet I haven’t used them for a long time. See
https://wiki.manjaro.org/index.php?title=Burn_an_ISO_File#Writing_to_a_USB_Stick_in_Linux


#6

Thanks. But i dont have a running manjaro yet. Will that command be ok using mint? Thats what i have for now.


#7

dd should work on any Linux distribution. Just be careful to use correct drive letter lest overwrite your system drive instead of USB stick.


#8

Thanks. But again? How about the PAE issue? Ive been roaming the forum last night but cant see a clear answer if manjaro installer for 64bit has PAE or not.


#9

I can’t be sure, but I think PAE and non-PAE kernels are only for 32-bit architecture. Since your CPU is 64-bit and you want to install 64-bit kernel, there is no issue here.


#10

Ow i see. Ill just try dd command later. Hope it will work. Thanks.


#11

HI there! It seems that my usb stick is somewhat broken. I usually see ‘input output error’. Is it possible to copy the ISO file in a partition on the hard drive and set boot flag on it and install from there?


#12

No. But you can try this


#13

Awesome! This is what i need. So it will just be between me, my old laptop and the iso. no usb and no burning. great. Thanks. Probably gonna try this at home tonight.


#14

I wasnt able to do what gohlip had said. I bought a new usb instead. And it worked. So the issue regarding “mixed results” is totally because of a broken usb flash drive. Im trying to use the iso from the community w/c is bspwm-manjaro but it seems that it has a git problem. I really want to try bspwm-manjaro and not bspwm-vanilla. I dont have any other running manjaro. This is my first attemt for this distro.
Well anyway, this topic should be closed now.